Results 1 to 4 of 4

Thread: ubuntu 14.04 server install blank screen

  1. #1
    Join Date
    Aug 2013
    Beans
    2

    ubuntu 14.04 server install blank screen

    I'm attempting to install ubuntu 14.04 server on a somewhat dated pc workstation. After selecting the keyboard and country a purple blank screen appears and nothing appears to happen.

    Workstation specs:
    cpu: dual opteron cpu
    ram: 16gb
    hard disk: maxtor 350gb x 4
    video card: radeon 4850

    Could anybody suggest what might be the reason as to the installation appearing to stall?

    Thanks
    Peter

  2. #2
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    6,088
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: ubuntu 14.04 server install blank screen

    pkoukoulis-r; Hi ! Welcome to the forum;

    Maybe a graphics driver issue:
    video card: radeon 4850
    AMD no longer supports that card, so you must use the open source driver. If in the 'server' install you have the options to install 3rd party software and install updates during the install, don't .
    And try to install with the boot parameter "nomodeset".
    http://ubuntuforums.org/showthread.php?t=1613132

    hey, it is a thouhgt
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubutu'n !

  3. #3
    Join Date
    Aug 2013
    Beans
    2

    Re: ubuntu 14.04 server install blank screen

    Hi

    thanks for replying. Tried the installation with the "nomodeset" option, but still the same outcome. Just a blank purple screen.
    I'm tempted to buy a new video card and see if that makes a difference.
    Can anybody else suggest a way around the blank screen?

    Thanks
    Peter

  4. #4
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    7,123

    Re: ubuntu 14.04 server install blank screen

    Welcome to the Ubuntu Forums

    I suppose that you are trying to run Ubuntu Server in text mode.

    You should try to modify the file /etc/default/grub (uncomment the GRUB_TERMINAL line) to the following

    Code:
    # Uncomment to disable graphical terminal (grub-pc only)
    GRUB_TERMINAL=console
    and run

    Code:
    sudo update-grub
    But with a blank terminal it is not easy, so at first, modify the target file of sudo update-grub from a live drive:

    Code:
    sudo mount /dev/sdxy /mnt
    where x is the drive letter and y is the partition number, so something like /dev/sda1

    Code:
    sudo nano /mnt/boot/grub/grub.cfg
    and modify the corresponding entry at the end of the first part of the file "00_header"

    Code:
    if [ x$feature ... ]
    ...
    ...
    ...
    fi
    terminal_output gfxterm
    if [ "${recordfail}" = 1 ] ; then
      set timeout=-1
    else
      set timeout=15
    fi
    ### END /etc/grub.d/00_header ###
    In a system Lubuntu 14.04 LTS, where I tested, it was changed to

    Code:
    terminal_input console
    terminal_output console
    if [ "${recordfail}" = 1 ] ; then
      set timeout=-1
    else
      set timeout=15
    fi
    ### END /etc/grub.d/00_header ###
    This will be overwritten, so I suggest that you change /etc/default/grub too (if the tweak works).

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •