Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Hibernate (Win8) stopped working (grub2, 12.04, dual boot, dmraid, EFI)

  1. #1
    Join Date
    Sep 2007
    Beans
    15

    Hibernate (Win8) stopped working (grub2, 12.04, dual boot, dmraid, EFI)

    Hi all,

    I'm running Ubuntu 12.04.1 on my laptop (Sony Vaio Z13) in dual boot with Windows 8 Release Preview. Both 64 bits and using an EFI bootloader. The 'bios' is put in UEFI mode to. The laptop contains 2 ssd's in raid0 (dmraid).

    Because my laptop doesn't have an optical drive i first tried to use a USB stick to install ubuntu, but that failed (dmraid support, kernel panics and some more stuff). I then put a alternate iso on my usb, but that failed too because it started looking for the cd again (bug is easily found by google, but no solution worked for me). I then used an external USB optical drive with the alternate iso which worked. I installed the grub2 bootloader onto the disk, but it didn't show after a reboot. I fixed this problem using these tips: http://askubuntu.com/a/157062.

    I now finally got grub2 working (sort of) and can choose between Win and Ubuntu at boot. The problem is that when i'm using grub2 as default bootloader Win8 is unable to return from hibernate. My laptop starts, shows the grub2 screen, boots Win8, but then it shortly hangs and i get a clean restart instead of restore from hibernate.

    I've read a lot of topics regarding this topics individually but it looks like almost nobody got them all at the same time (dmraid, efi, win8, grub2, sony h2o insyde bios). Please don't tell me to use linux software raid (instead of dmraid), drop efi or the win8 dual boot. I can't use linux software raid because of the dualboot and would like to keep using EFI because of the incredible startup/sleep/hibernate speed combined with Win8.

    I use hibernate on a daily basis, so hopefully somebody could help me out here.

    Thanks in advance,

    Mart

  2. #2
    Join Date
    Nov 2008
    Location
    Lleida, Spain
    Beans
    1,157
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Hibernate (Win8) stopped working (grub2, 12.04, dual boot, dmraid, EFI)

    Please, in an ubuntu terminal type:
    Code:
    sudo fdisk -l
    and paste the result.

  3. #3
    Join Date
    Sep 2007
    Beans
    15

    Re: Hibernate (Win8) stopped working (grub2, 12.04, dual boot, dmraid, EFI)

    I'm sorry i forgot to include it the first time, here it is:
    http://paste.ubuntu.com/1261574/

  4. #4
    Join Date
    Nov 2008
    Location
    Lleida, Spain
    Beans
    1,157
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Hibernate (Win8) stopped working (grub2, 12.04, dual boot, dmraid, EFI)

    Quote Originally Posted by shappie View Post
    I'm sorry i forgot to include it the first time, here it is:
    http://paste.ubuntu.com/1261574/
    I see this:
    ARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.

    So open it with gparted.
    Go to System --> Administration --> gparted and make an screnshot

    if you don't have gparted installed:
    sudo apt-get install gparted

  5. #5
    Join Date
    Sep 2007
    Beans
    15

    Re: Hibernate (Win8) stopped working (grub2, 12.04, dual boot, dmraid, EFI)

    See attachment.

    GParted only shows 3 disks in the top right corner dropdown. The current raid array (mapper/isw....) and sda/sdb. Sda and sdb only show an error and unallocated space, because they are of no use by themselves, they are combined in a RAID0 array.

    edit: The first 4 partitions are created by Win8 and i shrinked the Win8 OS partition to create the ext4 and swap partitions for ubuntu.
    Attached Images Attached Images

  6. #6
    Join Date
    Nov 2008
    Location
    Lleida, Spain
    Beans
    1,157
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Hibernate (Win8) stopped working (grub2, 12.04, dual boot, dmraid, EFI)

    Ok, try setting the partition labeled as WIN8 to bootable.

  7. #7
    Join Date
    Sep 2007
    Beans
    15

    Re: Hibernate (Win8) stopped working (grub2, 12.04, dual boot, dmraid, EFI)

    I put the boot flag on the partition labeled as WIN8 and rebooted. Unfortunately i got a 'no operating system found' error. So there is no bootloader currently being loaded at boot.

    I can still access Ubuntu manually from the grub2 on my Ubuntu Live usb stick (c for command line: set root, linux..., initrd... boot). So i could remove the 'boot' flag.

  8. #8
    Join Date
    Nov 2008
    Location
    Lleida, Spain
    Beans
    1,157
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Hibernate (Win8) stopped working (grub2, 12.04, dual boot, dmraid, EFI)

    Ok I will try to replicate your configuration in a virtual machine to see what is happening.

  9. #9
    Join Date
    Sep 2007
    Beans
    15

    Re: Hibernate (Win8) stopped working (grub2, 12.04, dual boot, dmraid, EFI)

    Quote Originally Posted by albandy View Post
    Ok I will try to replicate your configuration in a virtual machine to see what is happening.
    Thanks in advance! I'm unable to make any sense of this too, hopefully you'll figure it out

  10. #10
    Join Date
    Jul 2011
    Beans
    9

    Re: Hibernate (Win8) stopped working (grub2, 12.04, dual boot, dmraid, EFI)

    Hello ! I have the same issue, but my windows is windows 7 x64.

    Same problem: can't get out from hibernation.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •