Results 1 to 6 of 6

Thread: eclude gvfs in copy?

  1. #1
    Join Date
    Jun 2008
    Beans
    553

    eclude gvfs in copy?

    I get the following error when running a backup:
    j-media-centre@jmediacentre-A880G:~$ sudo cp -rp /home/j-media-centre /mnt/mynewdrive/home/j-media-centre.backup
    cp: cannot stat `/home/j-media-centre/.gvfs': Permission denied


    What is gvfs and how can I exclude it in that command?

  2. #2
    Join Date
    Feb 2005
    Location
    Melbourne, Australia
    Beans
    13,505
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: eclude gvfs in copy?

    Quote Originally Posted by qwertyjjj View Post
    I get the following error when running a backup:
    j-media-centre@jmediacentre-A880G:~$ sudo cp -rp /home/j-media-centre /mnt/mynewdrive/home/j-media-centre.backup
    cp: cannot stat `/home/j-media-centre/.gvfs': Permission denied


    What is gvfs and how can I exclude it in that command?
    If the destination is not a Linux filesystem then issues can arise, also using sudo for copying /home data is not really valid.
    Regards, David.
    Please use the Forum search and Wiki search for immediate help
    Please mark your thread as Solved when appropriate
    New to technical forums?: How To Ask Questions The Smart Way

  3. #3
    Join Date
    Apr 2012
    Beans
    5,316

    Re: eclude gvfs in copy?

    afaik $HOME/.gvfs is a mount point for remote shares under the Gnome Virtual file System - so the files there aren't really the user's home files

    You could try adding the -x or --one-file-system flag (stay on this file system) to cp or maybe use rsync instead with --exclude

  4. #4
    Join Date
    Jun 2008
    Beans
    553

    Re: eclude gvfs in copy?

    Quote Originally Posted by steeldriver View Post
    afaik $HOME/.gvfs is a mount point for remote shares under the Gnome Virtual file System - so the files there aren't really the user's home files

    You could try adding the -x or --one-file-system flag (stay on this file system) to cp or maybe use rsync instead with --exclude
    tried deja dup instead and got the following error:
    could not backup:

    /etc/.pwd.lock
    /etc/NetworkManager/system-connections/Wired connection 1
    /etc/apparmor.d/cache/lightdm-guest-session
    /etc/apparmor.d/cache/sbin.dhclient
    /etc/apparmor.d/cache/usr.bin.evince
    /etc/apparmor.d/cache/usr.lib.telepathy
    /etc/apparmor.d/cache/usr.sbin.cupsd
    /etc/apparmor.d/cache/usr.sbin.tcpdump
    /etc/apt/trustdb.gpg
    /etc/at.deny
    /etc/chatscripts
    /etc/cups/ssl
    /etc/cups/subscriptions.conf
    /etc/cups/subscriptions.conf.O
    /etc/default/cacerts
    /etc/fuse.conf
    /etc/group-
    /etc/gshadow
    /etc/gshadow-
    /etc/mtab.fuselock
    /etc/passwd-
    /etc/ppp/chap-secrets
    /etc/ppp/pap-secrets
    /etc/ppp/peers
    /etc/security/opasswd
    /etc/shadow
    /etc/shadow-
    /etc/ssl/private
    /etc/sudoers
    /etc/sudoers.d/README
    /etc/transmission-daemon/settings.json
    /etc/ufw/after.rules
    /etc/ufw/after6.rules
    /etc/ufw/before.rules
    /etc/ufw/before6.rules

  5. #5
    Join Date
    Jun 2007
    Beans
    322

    Re: eclude gvfs in copy?

    Why are you backing up stuff in /etc? Check the Deja Dup settings...

    If you want to backup and are comfotable with command-line use rsync. There is Grsync if you want rsync with a UI...
    Intel C2D E7200 || Intel DG33FB mobo || 4 GB RAM || 64 bit Lucid/ Precise Desktops || WD Caviar Black 1TB, Green 2TB; Corsair Force 3 60GB
    Dell U2412M || Palit Sonic GT 240 (OC'd NVidia card) || Logitech Quickcam Connect || Acer 3300U Scanner

  6. #6
    Join Date
    Jun 2008
    Beans
    553

    Re: eclude gvfs in copy?

    Quote Originally Posted by shreepads View Post
    Why are you backing up stuff in /etc? Check the Deja Dup settings...

    If you want to backup and are comfotable with command-line use rsync. There is Grsync if you want rsync with a UI...
    in case I have to restore it in future.
    backing up /home and /etc

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •