Results 1 to 7 of 7

Thread: How to fix correct keyboard recognition in Virtual box guest OS!

  1. #1
    Join Date
    Jan 2007
    Location
    Amsterdam, Nederland
    Beans
    816
    Distro
    Ubuntu Development Release

    Lightbulb How to fix correct keyboard recognition in Virtual box guest OS!

    I've been struggeling with Virtualbox for months now. Although the install went fairly smooth there has always been one thing that bugged the shite out of me; the keyboard sometimes reacted well to some signs (e.g. ";?.><=+_-*~` etc.) after which it could somehow immediately change so that the signs that where on my keyboard did not display correctly anymore and I had to push all the special sign keys to find a simple questionmark.

    Today I found the solution which I just wanted to share with you guys. If you press the left shift and the left control at the same time, my keyboard switches from the normal (US) to some other layout (I think the belgium one).

    So; Ctrl + Shift!!

    I hope I could help people with this since I searched for it for ages but couldn't find the answer!

  2. #2
    Join Date
    Jun 2008
    Beans
    83

    Re: How to fix correct keyboard recognition in Virtual box guest OS!

    Nice one thanks for sharing !

    Out of interest what OS were you running virtually ?
    Is this shortcut for Virtualbox direct ? i.e. OS independent ?
    Would a more helpful partitioner make Ubuntu easier to install?
    http://brainstorm.ubuntu.com/idea/11122/
    What does Ubuntu mean to you ?
    http://brainstorm.ubuntu.com/idea/11214/

  3. #3
    Join Date
    Jan 2007
    Location
    Amsterdam, Nederland
    Beans
    816
    Distro
    Ubuntu Development Release

    Re: How to fix correct keyboard recognition in Virtual box guest OS!

    Ah yes, excuse me. The guest OS is Windows XP. I don't know about other OS's.

    I am currently writing my thesis for which I absolutely need MS Word and EndNote. Once my thesis is finished though, its gonna be bye bye Windows forever.

  4. #4
    Join Date
    Dec 2008
    Location
    Ottawa, Canada
    Beans
    249
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to fix correct keyboard recognition in Virtual box guest OS!

    AHA!!!! And here I thought it was just me. I am using a dual-boot, lucid and 7, with VB 4.06 and I installed a slipstreamed XP (that I made years ago on an old athlon desktop and no longer use), on my Dell 1545 and the keyboard special keys were all buggered. I was able to find most of the keys, and some weird ones, such as the euro and pound sign (quite useful, I suspect, if I was in Europe), but for the life of me, the "@" sign was no where to be found. The shift-ctrl keys didn't do anything, but the ctrl-alt keys did. Now to see if I can get everything I need working in XP, then nuke 7 and get another 100GB. One step closer.
    Last edited by colin.p; April 25th, 2011 at 01:05 PM.
    Colin
    Registered Linux User #318277
    The Ubuntu Counter Project - user number # 25648

  5. #5
    Join Date
    Oct 2012
    Beans
    2

    Re: How to fix correct keyboard recognition in Virtual box guest OS!

    I have a similar problem with ubuntu on virtual box on windows 7, but none of the suggestwed key presses fixes the issue for me. My UK keyboard is interpreted as US by Ubuntu.

    Any ideas?

    Many thanks in advance

  6. #6
    Join Date
    Oct 2012
    Beans
    2

    Re: How to fix correct keyboard recognition in Virtual box guest OS!

    ah fixed it - it was just system settings --> keyboard.

    Had to install the appropriate type - sorry to have bothered people

  7. #7
    Join Date
    Feb 2008
    Location
    Texas
    Beans
    15,657
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: How to fix correct keyboard recognition in Virtual box guest OS!

    Old thread! closed.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •