Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Installed, but now I'm stuck HELP!!!!!!!!

  1. #1
    Join Date
    Sep 2012
    Beans
    13

    Exclamation Installed, but now I'm stuck HELP!!!!!!!!

    Hey guys,
    Look, I am the newest of the new to come to Ubuntu. I have drooled over ubuntu for YEARS, Just never really got around to doing anything with it. Anyways. I just recently installed ubuntu 12.04. It was working GREAT! well.. up until i rebooted my machine. Now im confused and don't know where to go. I would greatly appreciate any help that can be given.

    Anyways, whenever I turn the machine on now, it wont detect my disk drive and sends me straight to this purple "GNU GRUB" screen (and yes i have gone through the bios and selected the disk drive to be my main boot drive.. still nothing)

    Heres a direct overlay of what im dealing with when at the purple "GNU GRUB" screen:

    GNU GRUB
    ---------------------------------------------------------------------------------------------------
    Ubuntu, with Linux 3.2.0-23- generic-pae
    Ubuntu, with Linux 3.2.0-23- generic-pae (recovery mode)
    Memory test (memtest86+)
    Memory test (memtest86+, serial console 115200)
    --------------------------------------------------------------------------------------------------

    Instinctively I select the first "Ubuntu, with Linux 3.2.0-23- generic-pae. That sends me to this command window:

    mount: mounting /dev/disk/by-uuid/8ef68434-a383-41a0-bfb2-0e491648ca3a on /root
    failed: Invalid argument
    mount: mounting /dev on /root/dev failed: No such file or directory
    mount: mounting /proc on /root/proc failed: No such file or directory
    Target filesystem doesn't have requested /sbin/init
    No init found. Try pressing init= bootarg

    BusyBox v1.18.5 (Ubuntu 1:1.18.5-1ubuntu4) built-in shell (ash)
    Enter 'help' for a list of built-in commands.

    (initramfs)

  2. #2
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,660
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Installed, but now I'm stuck HELP!!!!!!!!

    Double check in BIOS if your disk is recognized correctly there or not. I am not talking about the device boot order, look whether the actual disk is recognized. If it doesn't exist in BIOS, it's like it's not there so there is nothing to boot.

    If the disk is correctly in BIOS, when the grub2 boot menu shows, try pressing 'c' for command mode. At the prompt execute:
    Code:
    ls
    Does that list the disk and partitions like (hd0),(hd0,1),(hd0,2), etc?
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 12.04 LTS 64bit & Windows 7 Ultimate 64bit

  3. #3
    Join Date
    Sep 2012
    Beans
    13

    Exclamation Re: Installed, but now I'm stuck HELP!!!!!!!!

    Thanks for trying to help, but i still don't understand what your talking about. My disk drive is located in the bios. And in the command prompt I typed in Code: gave me the error of "invalid command prompt"

    Can you walk me through step by step?

  4. #4
    Join Date
    Sep 2012
    Beans
    13

    Re: Installed, but now I'm stuck HELP!!!!!!!!

    Also, your image of the Code that im sopposed to type in isnt showing up. just says "is"

  5. #5
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,660
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Installed, but now I'm stuck HELP!!!!!!!!

    That is the command you need to type, just two letters. The smallcase LS, it's not is, it's ls.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 12.04 LTS 64bit & Windows 7 Ultimate 64bit

  6. #6
    Join Date
    Oct 2005
    Location
    INDY
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Installed, but now I'm stuck HELP!!!!!!!!

    No it is a ls small L
    as in list.

    oops, too slow
    Castles Made of Sand,
    Fall in the Sea,
    Eventually!

  7. #7
    Join Date
    Sep 2012
    Beans
    13

    Re: Installed, but now I'm stuck HELP!!!!!!!!

    oh ahaha my bad Thanks for clearing that up. Yeah this is what i got:

    grub> ls
    (hd0) (hd0,msdos5) (hd0,msdos1)

  8. #8
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,660
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Installed, but now I'm stuck HELP!!!!!!!!

    OK. At that grub> prompt run these commands one by one and see if that boots it:
    Code:
    insmod part_msdos
    insmod ext2
    set root=(hd0,msdos1)
    linux vmlinuz root=/dev/sda1
    initrd initrd.img
    boot
    If that works, we can try sorting out grub2.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 12.04 LTS 64bit & Windows 7 Ultimate 64bit

  9. #9
    Join Date
    Sep 2012
    Beans
    13

    Re: Installed, but now I'm stuck HELP!!!!!!!!

    everything works up until the:

    linux vmlinuz root=/dev/sda1

    Command prompt, says: invalid filename "vmlinuz"

  10. #10
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,660
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Installed, but now I'm stuck HELP!!!!!!!!

    OK. Lets see what kernels do you have. If you can, copy paste, or write down, the output of:
    Code:
    ls (hd0,msdos1)/boot
    That should show all kernels present in the /boot folder. We need to see what's there so that we know what to try to boot.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 12.04 LTS 64bit & Windows 7 Ultimate 64bit

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •