Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: 12.04 won't automatically switch audio to bluetooth headset

  1. #11
    Join Date
    Jun 2008
    Beans
    30

    Re: 12.04 won't automatically switch audio to bluetooth headset

    My issue is more related to this bug

    https://bugs.launchpad.net/ubuntu/+s...4?comments=all

  2. #12
    Join Date
    Nov 2008
    Location
    Oita, Japan
    Beans
    424
    Distro
    Ubuntu

    Re: 12.04 won't automatically switch audio to bluetooth headset

    Quote Originally Posted by quequotion View Post
    Changing the configuration of pulseaudio (/etc/pulse/system.pa, additions only):
    Code:
    ### Automatically detect bluetooth devices
    load-module module-bluetooth-discover #Maybe this does more harm than good
    
    ### Automatically redirect to newly available sinks
    load-module module-switch-on-connect #Probably necessary... probably....
    After several weeks of testing, I came to the conclusion that module-bluetooth-discover indeed does more harm that good, if it does anything at all. I was never able to verify that this module assisted in the connection of bluetooth audio devices, but I did occasionally experience bluetooth crashing, pulseaudio crashing, and blueman crashing...

    In other news, still no word on bluez's bugtracker.

  3. #13
    Join Date
    Jun 2010
    Location
    Ireland
    Beans
    3

    Re: 12.04 won't automatically switch audio to bluetooth headset

    I know the thread has been inactive for few months, but maybe someone will read this.

    Add:

    Enable = Socket
    Disable = Media

    into "General" section of /etc/bluetooth/audio.conf

    The "Enable = Socket" makes no difference in my case anyway, but they recoment it on many forums.

    But "Disable = Media" is different coffee, with this all my bluetooth headsets connect again like a charm.

  4. #14
    Join Date
    Aug 2011
    Beans
    1

    Re: 12.04 won't automatically switch audio to bluetooth headset

    I read.

    Thanks

  5. #15
    Join Date
    Nov 2008
    Location
    Oita, Japan
    Beans
    424
    Distro
    Ubuntu

    Re: 12.04 won't automatically switch audio to bluetooth headset

    Quote Originally Posted by MiroDz View Post
    Enable = Socket
    Disable = Media
    I already had Enable = Socket. I will try a reboot with Disable = Media as well.

    I am concerned that neither option is well documented except to say they will be deprecated in the future (in the pulseaudio documentation).

    So far my best case scenario is this:

    0A. Replace (usless) gnome-bluetooth with (useful) blueman
    0B. Add module-switch-on-connect to pulseaudio's configuration

    1. Activate headset
    2. Select "Audio Sink" with blueman (this is the part that bluez should do automatically, but it doesn't)
    3. Use pavucontrol to specify A2DP or HSP/HFP
    Last edited by quequotion; August 20th, 2013 at 03:38 AM.

  6. #16
    Join Date
    Nov 2008
    Location
    Oita, Japan
    Beans
    424
    Distro
    Ubuntu

    Re: 12.04 won't automatically switch audio to bluetooth headset

    Quote Originally Posted by quequotion View Post
    I will try a reboot with Disable = Media as well.
    Well... that was interesting...

    This did enable bluetooth headsets to auto-select a profile on connect (HSP/HFP)* but it also scrambled the ALSA subsystem.

    - all soundcard indexes were randomly reorderd
    - ALSA-only applications could not detect certain audio devices

    Pulseaudio doesn't care if alsa is scrambled or not, so audio worked most everywhere, but I have some ALSA-only applications, like Mixxx, that started behaving very strangely.

    Why does this option scramble ALSA?

    *I think this is the default, there may be options to control which profile is auto-selected: module-bluetooth-device

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •