Results 1 to 7 of 7

Thread: Upgrade from Lubuntu to Studio

  1. #1
    Join Date
    Sep 2010
    Beans
    25

    Upgrade from Lubuntu to Studio [solved]

    I had Lubuntu 12.04 installed and I installed the Studio meta packages following this guide.

    It all went fine and without a hitch. Going through the rest of the procedure, it seemed that all I needed to do is to include my user in the audio and video groups. All the rest of the instructions seemed to have been for older versions and was not necessary to do in 12.04.

    Basic testing seems to go well and I have no problems, I'd just like to make sure I'm not missing something obvious.

    Thanks!
    Last edited by furtom; October 14th, 2012 at 03:51 PM. Reason: mark solved

  2. #2
    Join Date
    Jun 2008
    Beans
    1,155
    Distro
    Ubuntu Studio

    Re: Upgrade from Lubuntu to Studio

    Just make shure that you have RT priority set.
    Code:
    cat /etc/security/limits.d/audio.conf

  3. #3
    Join Date
    Aug 2012
    Location
    Hong Kong
    Beans
    160
    Distro
    Ubuntu Development Release

    Re: Upgrade from Lubuntu to Studio

    Quote Originally Posted by jejeman View Post
    Just make shure that you have RT priority set.
    Code:
    cat /etc/security/limits.d/audio.conf
    furtom: Make sure you install the linux-lowlatency package
    As the Ubuntu Studio release manager and a Kubuntu developer, I do a lot of ISO testing and packaging.
    Make Ubuntu 13.10 awesome~!

  4. #4
    Join Date
    Sep 2010
    Beans
    25

    Re: Upgrade from Lubuntu to Studio

    Thanks guys. I haven't had a chance to do anything yet, but I'll be sure to post the result of

    Code:
    cat /etc/security/limits.d/audio.conf
    soon.

    What I can tell you so far is that I certainly installed the lowlatency package along with the rest of the studio stuff, but the funny thing is, grub still only offers to boot the generic kernel. I even checked the older kernels on the menu to be sure. Not there.

    I know I installed it and the install seemed to work fine as I got the RT dialog when dpkg was installing it. Shouldn't there be a lowlatency kernel to boot now in grub or am I missing something?

  5. #5
    Join Date
    Sep 2010
    Beans
    25

    Re: Upgrade from Lubuntu to Studio

    Here's cat /etc/security/limits.d/audio.conf

    I admit, It's not what I expected.

    Code:
    # Provided by the jackd package.
    #
    # Changes to this file will be preserved.
    #
    # If you want to enable/disable realtime permissions, run
    #
    #    dpkg-reconfigure -p high jackd
    
    @audio   -  rtprio     95
    @audio   -  memlock    unlimited
    #@audio   -  nice      -19

  6. #6
    Join Date
    Jun 2008
    Beans
    1,155
    Distro
    Ubuntu Studio

    Re: Upgrade from Lubuntu to Studio

    Limits are set ok.

    Try updateing GRUB again. It should list all kernels.
    Code:
    sudo update-grub
    Give us output from
    Code:
    ls /boot
    Code:
    cat /boot/grub/grub.cfg | grep menuentry

  7. #7
    Join Date
    Sep 2010
    Beans
    25

    Re: Upgrade from Lubuntu to Studio

    Well, I finally had a chance to take a look. Odd thing was, no rt or lowlatency kernel was installed. I could have sworn I installed it!

    Stranger still, I found the latest lowlatency headers, but no image. Did I install the headers only? I'll chalk it up to old age... I would have thought the headers depend on the image, but perhaps not.

    I installed the meta package and all is good to go.

    In any case, everything is working as it should, pending detailed testing. Thanks for the advice.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •