Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: After upgrading from 11.04 to 12.04, Wireless works intermidantly...

  1. #21
    Join Date
    Jun 2011
    Beans
    40

    Re: After upgrading from 11.04 to 12.04, Wireless works intermidantly...

    Okay, nope, we are back to square one, still the same behavior, although I must admit, everything I tried that you all suggested seemed to make things run better and for longer, but that may just be the fact that I reset the computer each time. Reseting the computer always makes the wireless run uninterrupted or longer periods.

    -TMundo

  2. #22
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,351
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: After upgrading from 11.04 to 12.04, Wireless works intermidantly...

    Hi,
    I consulted a much more knowledgeable senior of mine and he immediately caught a very big mistake I made -
    Quote Originally Posted by varunendra View Post
    Code:
    echo "nohwcrypt=1" | sudo tee  /etc/modprobe.d/carl9170.conf
    It should have been "options carl9170 nohwcrypt=1". I feel really embarassed how I made that mistake (not that I don't do it often, but that I got caught in clear daylight.. ), and how I kept overlooking it for so long.

    Please correct it immediately. You can do it in one step by (you may simply copy-paste in terminal) -
    Code:
    sudo sed -i 's/^nohwcr/options carl9170 &/' /etc/moprobe.d/carl9170.conf
    If doing this alone doesn't help, there is another advice based on dmesg indication in your very first post -
    [201772.688413] ieee80211 phy0: rx stream does not start with a first_mpdu frame tag.
    To take care of above, please try (only if the above correction doesn't help)-
    Code:
    sudo modprobe -rfv carl9170
    sudo modprobe -v carl9170 noht=1
    If it seems to help, we can include it in permanent options.

    And.. there is yet another advice to try 'G' channel in your router instead of 'N', plus make sure the encryption is set to WPA2 only, not WPA/WPA2 mix mode.

    Let us hope for miracles this time, but to be honest, the only person I could find happy with this chip was the poster of this post I linked to earlier. I hope you become the next one!
    Last edited by varunendra; November 17th, 2012 at 02:18 PM. Reason: changed WPA to WPA2
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  3. #23
    Join Date
    Jun 2011
    Beans
    40

    Re: After upgrading from 11.04 to 12.04, Wireless works intermidantly...

    After entering code:
    Code:
    sudo sed -i 's/^nohwcr/options carl9170 &/' /etc/moprobe.d/carl9170.conf
    Output is:
    Code:
    sed: can't read /etc/moprobe.d/carl9170.conf: No such file or directory
    Not sure why, but I assume that didn't work (shrugs)

    So I input the other codes:
    Code:
    sudo modprobe -rfv carl9170
    Output:
    Code:
    rmmod /lib/modules/3.2.0-24-generic/kernel/drivers/net/wireless/ath/carl9170/carl9170.ko
    rmmod /lib/modules/3.2.0-24-generic/kernel/net/mac80211/mac80211.ko
    rmmod /lib/modules/3.2.0-24-generic/kernel/drivers/net/wireless/ath/ath.ko
    rmmod /lib/modules/3.2.0-24-generic/kernel/net/wireless/cfg80211.ko
    Code:
    sudo modprobe -v carl9170 noht=1
    Output:
    Code:
    insmod /lib/modules/3.2.0-24-generic/kernel/net/wireless/cfg80211.ko 
    insmod /lib/modules/3.2.0-24-generic/kernel/drivers/net/wireless/ath/ath.ko 
    insmod /lib/modules/3.2.0-24-generic/kernel/net/mac80211/mac80211.ko 
    insmod /lib/modules/3.2.0-24-generic/kernel/drivers/net/wireless/ath/carl9170/carl9170.ko noht=1
    With the second codes, after the first line it shut the wireless off and after the second one it turned the wireless back on again. We will see what happens in the next few days.

    Thanks again

    -TMundo

  4. #24
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,351
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: After upgrading from 11.04 to 12.04, Wireless works intermidantly...

    Quote Originally Posted by TMundo View Post
    Code:
    sed: can't read /etc/moprobe.d/carl9170.conf: No such file or directory
    Which means either the file was not created at all, or it might have been mis-named. To confirm, please post -
    Code:
    ls  -l /etc/moprobe.d/
    [Edit : repeated typo. It should have been "modprobe", not moprobe]
    If it is not there, we can create it now with the correct command this time (you may copy-paste commands to avoid errors) -
    Code:
    echo "options carl9170 nohwcrypt=1" | sudo tee  /etc/modprobe.d/carl9170.conf
    Quote Originally Posted by TMundo View Post
    Code:
    insmod /lib/modules/3.2.0-24-generic/kernel/drivers/net/wireless/ath/carl9170/carl9170.ko noht=1
    Had the .conf file been in effect, the above line would have looked like -
    Code:
    insmod /lib/modules/3.2.0-24-generic/kernel/drivers/net/wireless/ath/carl9170/carl9170.ko nohwcrypt=1 noht=1
    Which is what I was expecting. As per the description on linuxwireless.org, the nohwcrypt=1 option is more important. So please create the .conf file as suggested above, then retry the last two modprobe commands to see if it goes as expected. I doubt if the noht=1 option alone can make it any better.
    Last edited by varunendra; November 24th, 2012 at 09:10 AM. Reason: correcting typo
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  5. #25
    Join Date
    Jun 2011
    Beans
    40

    Re: After upgrading from 11.04 to 12.04, Wireless works intermidantly...

    Okay:

    I confirmed that the file is not there

    After:

    Code:
     echo "options carl9170 nohwcrypt=1" | sudo tee  /etc/modprobe.d/carl9170.conf
    There is no output

    I then ran:

    Code:
    sudo modprobe -rfv carl9170
    and got output:

    Code:
    rmmod /lib/modules/3.2.0-24-generic/kernel/drivers/net/wireless/ath/carl9170/carl9170.ko
    rmmod /lib/modules/3.2.0-24-generic/kernel/net/mac80211/mac80211.ko
    rmmod /lib/modules/3.2.0-24-generic/kernel/drivers/net/wireless/ath/ath.ko
    rmmod /lib/modules/3.2.0-24-generic/kernel/net/wireless/cfg80211.ko
    Wireless signal shuts off:

    Then I input:

    Code:
    sudo modprobe -v carl9170 noht=1
    Output is:
    Code:
    insmod /lib/modules/3.2.0-24-generic/kernel/net/wireless/cfg80211.ko 
    insmod /lib/modules/3.2.0-24-generic/kernel/drivers/net/wireless/ath/ath.ko 
    insmod /lib/modules/3.2.0-24-generic/kernel/net/mac80211/mac80211.ko 
    insmod /lib/modules/3.2.0-24-generic/kernel/drivers/net/wireless/ath/carl9170/carl9170.ko nohwcrypt=1 noht=1
    so it looks like the: nohwcrypt=1 is in there, however after putting in the command:

    Code:
    ls  -l /etc/moprobe.d/
    The file is still not found, I then realized there was a typo in the code,

    so I entered:


    Code:
    ls  -l /etc/modprobe.d/
    not really sure if the .d is supposed to be there or if it is part of the typo, but the results were:


    Code:
    total 44
    -rw-r--r-- 1 root root 2507 May  5  2011 alsa-base.conf
    -rw-r--r-- 1 root root  325 Jun 15  2011 blacklist-ath_pci.conf
    -rw-r--r-- 1 root root 1603 Jun 15  2011 blacklist.conf
    -rw-r--r-- 1 root root  210 Jun 15  2011 blacklist-firewire.conf
    -rw-r--r-- 1 root root  661 Jun 15  2011 blacklist-framebuffer.conf
    -rw-r--r-- 1 root root  156 May  5  2011 blacklist-modem.conf
    lrwxrwxrwx 1 root root   41 May  5  2012 blacklist-oss.conf -> /lib/linux-sound-base/noOSS.modprobe.conf
    -rw-r--r-- 1 root root  583 Jun 15  2011 blacklist-rare-network.conf
    -rw-r--r-- 1 root root 1077 Jun 15  2011 blacklist-watchdog.conf
    -rw-r--r-- 1 root root   29 Nov 23 19:29 carl9170.conf
    -rw-r--r-- 1 root root  127 Apr 22  2012 dkms.conf
    -rw-r--r-- 1 root root   30 May 18  2012 vmwgfx-fbdev.conf
    and so, it looks like we are now getting somewhere, although I am not sure where.
    it is also necessary to note that even though the previous time I entered the two modprobe codes the file was not even there, connectivity was still running uninterrupted for a few days, I now beleive this is regardless of reseting the computer. Whenever we try to mess with it in the manner we have been using, it seems to jolt the system in such a way as to make the connectivity work uninterrupted for about 3 days. Not sure if this info is pertinent, but it seemed worth mentioning. As usual, will see what happens in the next few days.

    Thanx again

  6. #26
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,351
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: After upgrading from 11.04 to 12.04, Wireless works intermidantly...

    Hmm.., looks like I'm on my way to create some kind of record of 'Making Typos' this month ! Funny and embarrassing at the same time. I wonder if yet another sorry is sufficient.

    Anyway, now that it's fixed, I'd prefer to shamelessly move on.

    Although this sounds a bit odd to me -
    Quote Originally Posted by TMundo View Post
    Code:
     echo "options carl9170 nohwcrypt=1" | sudo tee  /etc/modprobe.d/carl9170.conf
    There is no output
    Well, I just copy-pasted the above command to verify, and I did see an output - "options carl9170 nohwcrypt=1".

    So I think that string would have appeared on the terminal, you just didn't notice it. Although it doesn't really matter if the string is returned or not on the screen as long as it is written correctly in the target file, but just for your info, this is how 'tee' command works. It both displays the supplied string on the terminal, AND drops it in the target file.

    But anyway, we don't need to worry about it since the output of modprobe -v shows that everything has been done correctly this time -
    Code:
    insmod /lib/modules/3.2.0-24-generic/kernel/drivers/net/wireless/ath/carl9170/carl9170.ko nohwcrypt=1 noht=1
    Oh, one more thing, not very important though -
    not really sure if the .d is supposed to be there or if it is part of the typo,
    It IS supposed to be there. The 'modprobe.d' is a directory we had to put the .conf file in.


    By the way, now that you seem to care about these things (and I'm getting worse on typos), may I give you a tip to avoid some mistakes while typing commands or addresses (and make it easier too!) -

    While typing a command, just type a few initial characters, then press 'Tab' key. The rest of the command will be auto-completed. Same goes for typing addresses. For example, if you only type -
    /et
    and press 'Tab', it will automatically be completed to -
    /etc/ (because terminal knows there is one and only one object at location '/' that starts with 'et', and that it is a folder - "etc")
    Now after /etc/, type only "mo" like this -
    /etc/mo
    and press 'Tab' again, it will auto-complete to -
    /etc/modprobe.d/ (because again, there is one and only one object in "etc" directory that starts with "mo" and it again is a folder)
    Again, if immediately after that (where the terminal's cursor is - waiting for more input) you type "ca" and press 'Tab' I hope you've already guessed what will happen Of course, it'll become -
    /etc/modprobe.d/carl9170.conf (unless there are more than one objects that start with "ca")
    But this time the terminal's cursor will also put a 'space' after the completed address. Why?? Because it knows that carl9170.conf is a file, and so you can not go "into" it.
    But it does expect that you may want to type another filename or a command option or a parameter 'After' the filename, which are things that are typed after a space.

    But if, after /etc, you type "de" and press 'Tab' -
    /etc/de
    Nothing will happen, although there is a directory named -"default". Why?? Because there is another directory in /etc/ that starts with "de", that is - "depmod.d". So you'll have to type more characters until it becomes a unique pattern to look for. In this example, typing just one more character "f" is sufficient -
    /etc/def
    press 'Tab' and you'll have /etc/default/ auto-completed on your terminal.

    If you don't know how many files/directories/commands exist that start with the pattern you have typed so far, just press 'Tab' twice. Unless they are in hundreds, terminal will immediately suggest you the available options by displaying them in a new line/paragraph, and will again return in a new line to wait for your further input. Like this -
    :~$ /etc/ap
    apache2/ apm/ apparmor/ apparmor.d/ apport/ apt/
    :~$ /etc/ap
    where -
    * the first line was when you pressed tab (twice),
    * the second line is available options that the terminal suggested to you,
    * the third line is where terminal immediately moved its input prompt after suggesting the available options, waiting for you to type more characters.

    However, if by mistake you type -
    /etc/mop
    and press 'Tab', guess what....... Nothing will happen, no matter you press 'Tab' two times or two-hundred times. Why ?? Because there is nothing at location /etc/ that starts with "mop" !! And so you immediately realize - "Eureka !! We have a T-Y-P-O..! "

    Hope that compensates the yet another typo on my part
    (Phew....!! Mommy ! A glass .. BIG Jug of water please..!!..)

    If the connection gets finally stable this time, we can really consider it a great achievement - given how disheartening the driver/chip's description on linuxwireless.org was -
    Users should be aware that these devices might go mad from time to time. Because these BUGs seem to occur too randomly to be identified, but happen often enough to be really annoying, the firmware and driver come with some convenient features to keep the overall downtime at a minimum and without requiring any user intervention. But as mention before there is a caveat: The user has to setup everything properly!
    Shall very curiously await your feedback, hoping for the best !
    Last edited by varunendra; November 24th, 2012 at 09:39 AM.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •