Results 1 to 3 of 3

Thread: Mount disk on remote machine using

  1. #1
    Join Date
    Aug 2010
    Location
    Amsterdam
    Beans
    10
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Mount disk on remote machine using

    (machines A and B both 10.04)
    First /dev/sda1 is mounted in /media/big on machine A through fstab
    Then it's shared through "Sharing options" which makes it available on machine B: Places > Network > A > Windows Shares > Big
    Now I'd rather have it mounted in B on startup. I'm assuming this should be an entry in fstab but I can't find a decent example.

    Putting this line in /etc/fstab:
    //192.168.2.1/media/big /media/scratch cifs user=admin01,password=***********
    Then:
    sudo mount -a
    Gives me:
    mount: //192.168.2.1/media/big is not a valid block device
    Last edited by rjvencken; October 8th, 2012 at 10:19 PM.

  2. #2
    Join Date
    Jul 2008
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Mount disk on remote machine using

    Quote Originally Posted by rjvencken View Post
    (machines A and B both 10.04)
    First /dev/sda1 is mounted in /media/big on machine A through fstab
    Then it's shared through "Sharing options" which makes it available on machine B: Places > Network > A > Windows Shares > Big
    Now I'd rather have it mounted in B on startup. I'm assuming this should be an entry in fstab but I can't find a decent example.

    Putting this line in /etc/fstab:
    //192.168.2.1/media/big /media/scratch cifs user=admin01,password=***********
    Then:
    sudo mount -a
    Gives me:
    mount: //192.168.2.1/media/big is not a valid block device
    Since you are mounting the share remotely; the format for all smb (cifs) resources is //ip_address/SHARE_NAME. Use the share name not the /path to the share. The path is only relevant to the local host OS.

  3. #3
    Join Date
    Aug 2010
    Location
    Amsterdam
    Beans
    10
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Mount disk on remote machine using

    Quote Originally Posted by redmk2 View Post
    Since you are mounting the share remotely; the format for all smb (cifs) resources is //ip_address/SHARE_NAME. Use the share name not the /path to the share. The path is only relevant to the local host OS.
    Yes!! It's working. Thank you!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •