Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Wired network can't connect, Wireless fine

  1. #11
    Join Date
    Oct 2012
    Beans
    11

    Re: Wired network can't connect, Wireless fine

    Still no success. Tried all of the above methods all resulting in the network trying to connect for a minute than getting a popup saying Wired Network Disconnected. ifconfig was the same as last time after each method.

    Any other ideas?

  2. #12
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,587
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wired network can't connect, Wireless fine

    Quote Originally Posted by mattjones701 View Post
    ifconfig was the same as last time after each method.
    ..meaning no IP address even after manually assigning one? That's strange!

    Please retry with:
    Code:
    sudo ifconfig eth0 192.168.0.80
    then post the outputs of:
    Code:
    ifconfig
    ping -c 4 192.168.0.1
    ping -c 4 192.168.0.3
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  3. #13
    Join Date
    Oct 2012
    Beans
    11

    Re: Wired network can't connect, Wireless fine

    Code:
     sudo ifconfig eth0 192.168.0.80
    matt@matt:~$ ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
              inet addr:192.168.0.80  Bcast:192.168.0.255  Mask:255.255.255.0
              inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:8782 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1334 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:748470 (748.4 KB)  TX bytes:146008 (146.0 KB)
              Interrupt:48 Base address:0xa000 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:6637 errors:0 dropped:0 overruns:0 frame:0
              TX packets:6637 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:1916136 (1.9 MB)  TX bytes:1916136 (1.9 MB)
    
    wlan0     Link encap:Ethernet  HWaddr 00:21:6b:35:df:9c  
              inet addr:192.168.0.3  Bcast:192.168.0.255  Mask:255.255.255.0
              inet6 addr: fe80::221:6bff:fe35:df9c/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:2487239 errors:0 dropped:0 overruns:0 frame:0
              TX packets:3940313 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:932102260 (932.1 MB)  TX bytes:1072597217 (1.0 GB)
    Code:
    matt@matt:~$ ping -c 4 192.168.0.1
    connect: Network is unreachable
    matt@matt:~$ ping -c 4 192.168.0.3
    connect: Network is unreachable

  4. #14
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,587
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wired network can't connect, Wireless fine

    So the IP sticks, but still no communication. Try these now, only one at a time, with cable connected and wireless disabled (after each attempt, retry the 'ifconfig up/down' commands and see if you can ping your router or wifi access point):
    1. Edit your 'Wired Connection' (click nm-applet > Edit Connections... > Double-click your connection listed under 'Wired' tab) > Goto 'IPv6' tab > set 'Method' to 'Ignore' (it is safe to leave IPv6 as 'ignored' even if it doesn't help).
    2. Check your physical connection. Are any of the lights (usually orange/green) on the ethernet port lit? Are they stable or blinking? Usually one is stable (indicating a physical connection), and the other is blinking (indicating data transfer). If none is lit, or only one is lit but blinking, then it indicates a physical problem in the connection.
    3. Make sure the firewall is disabled:
      Code:
      sudo ufw status

    Right now, I can't think of anything else. Please check these and post back the status. If possible also try changing the cable you are using to connect with a fresh or tested one. Although the 'Link=yes' in lshw output suggest it 'should' be ok, but just to make sure...
    Last edited by varunendra; October 11th, 2012 at 05:13 PM.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  5. #15
    Join Date
    Jul 2011
    Beans
    4

    Re: Wired network can't connect, Wireless fine

    are you using a router. Get the IP of router, and try following commands
    Code:
    sudo ifconfig eth0 192.168.0.80 netmask 255.255.255.0
    sudo route add default gw 192.168.0.xxx
    ping 8.8.8.8
    192.168.0.xxx is your router IP

  6. #16
    Join Date
    Oct 2012
    Beans
    2

    Re: Wireless network can't connect, Wired fine

    vanuenda i saw your posts and i liked so much, and i thought that you can help me, my situation is this:

    my hard disk had a issue then i formated and i've installed ubuntu 12.04 LTS but when the installation end, wireless already not work the laptop reference is: hp g5000.

    please help.

  7. #17
    Join Date
    Oct 2012
    Beans
    11

    Re: Wired network can't connect, Wireless fine

    Quote Originally Posted by varunendra View Post
    So the IP sticks, but still no communication. Try these now, only one at a time, with cable connected and wireless disabled (after each attempt, retry the 'ifconfig up/down' commands and see if you can ping your router or wifi access point):
    1. Edit your 'Wired Connection' (click nm-applet > Edit Connections... > Double-click your connection listed under 'Wired' tab) > Goto 'IPv6' tab > set 'Method' to 'Ignore' (it is safe to leave IPv6 as 'ignored' even if it doesn't help).
    2. Check your physical connection. Are any of the lights (usually orange/green) on the ethernet port lit? Are they stable or blinking? Usually one is stable (indicating a physical connection), and the other is blinking (indicating data transfer). If none is lit, or only one is lit but blinking, then it indicates a physical problem in the connection.
    3. Make sure the firewall is disabled:
      Code:
      sudo ufw status

    Right now, I can't think of anything else. Please check these and post back the status. If possible also try changing the cable you are using to connect with a fresh or tested one. Although the 'Link=yes' in lshw output suggest it 'should' be ok, but just to make sure...
    Finally got around to trying these methods out. Nothing worked
    Tried with a different cable still with same results. IPV6 is set to ignore. Firewall is set to inactive. And there is a steady Green light and a blinking orange one on the laptop connection. I'm plugging into a netgear n600 router/modem which another housemate is using for a windows pc and it works fine.

    Thanks for all your help. Let me know if you have any other ideas?
    Last edited by mattjones701; October 14th, 2012 at 03:25 AM. Reason: Forgot to add something

  8. #18
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,587
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wired network can't connect, Wireless fine

    Hmm.. these kind of issues keep reminding me that it's a huge mistake to take things for granted in networking stuff!

    Well.. at least the port lights confirm the physical connection status to be ok. But I wonder why that orange light is blinking if there is no communication between the router and laptop. You also had a considerable amount of transferred and received data packets (in ifconfig output) even when eth0 was not assigned any IP(v4) address. Although there hasn't been any large amount of data transfers so far, yet still considerable enough to make me suspicious if IPv6 is causing or adding to the problem. So let's first force-disable it by adding a few rules in sysctl file. Open it as super-user:
    Code:
    gksu gedit /etc/sysctl.conf
    Then add the following lines at its end:
    # force-disable IPv6
    net.ipv6.conf.all.disable_ipv6=1
    net.ipv6.conf.default.disable_ipv6=1
    net.ipv6.conf.lo.disable_ipv6=1
    Proofread, save and close the file. Now apply these changes by-
    Code:
    sudo sysctl -p
    Afterwards, another 'sounding-stupid' but 'may-help' thing to do is to power off your router > wait for a couple of minutes (usually 20-30 sec is enough though, to allow the router to completely unload its firmware from memory by discharging) > then power it on again. [Although this weird exercise is related to some firmware incompatibility, especially between Linux kernel and some d-link routers, that possibly existed waayyyy.. back in the past, and I haven't seen it again for at least since Ubuntu 10.10] Then on your laptop, (while the wireless is disabled) redo-
    Code:
    sudo ifconfig eth0 down
    sudo ifconfig eth0 up
    Then post back the overall current status:
    Code:
    ifconfig -a
    nm-tool
    sudo lshw -C network
    lsmod | grep r81
    dmesg | grep r81
    cat /etc/NetworkManager/NetworkManager.conf
    cat /etc/network/interfaces
    cat /etc/nsswitch.conf
    cat /var/lib/NetworkManager/NetworkManager.state
    As a side note, can you boot from the live cd/usb and see how's the connection there? Usually it works even with the default r8169 driver.

    If all of these turned out to be normal, then I guess the next thing to try would be to re-install the driver.

    I hope you won't give it up yet as it is not usually such a big problem, and despite this one being unusual, we look close. (even those who have problem with r8169 driver, report 'intermittent' connections with it, not a complete black-out).
    Last edited by varunendra; October 14th, 2012 at 08:54 AM. Reason: to correct 'rt8' to 'r81' in dmesg & lsmod commands
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  9. #19
    Join Date
    Oct 2012
    Beans
    11

    Re: Wired network can't connect, Wireless fine

    Still no luck Tried everything but the live CD as I don't have it atm. Haven't reinstalled drivers either. Should we try a different/earlier one perhaps?

    Code:
    ifconfig -a
    eth0      Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:724 errors:0 dropped:0 overruns:0 frame:0
              TX packets:36 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:86827 (86.8 KB)  TX bytes:12312 (12.3 KB)
              Interrupt:48 Base address:0xe000 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:8533 errors:0 dropped:0 overruns:0 frame:0
              TX packets:8533 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:1922621 (1.9 MB)  TX bytes:1922621 (1.9 MB)
    
    wlan0     Link encap:Ethernet  HWaddr 00:21:6b:35:df:9c  
              inet addr:192.168.0.3  Bcast:192.168.0.255  Mask:255.255.255.0
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:484205 errors:0 dropped:0 overruns:0 frame:0
              TX packets:572246 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:319035884 (319.0 MB)  TX bytes:250866784 (250.8 MB)
    Code:
    nm-tool
    
    NetworkManager Tool
    
    State: connected (global)
    
    - Device: eth0 -----------------------------------------------------------------
      Type:              Wired
      Driver:            r8168
      State:             disconnected
      Default:           no
      HW Address:        00:00:00:00:00:00
    
      Capabilities:
        Carrier Detect:  yes
        Speed:           1000 Mb/s
    
      Wired Properties
        Carrier:         on
    
    
    - Device: wlan0  [SlowNet] -----------------------------------------------------
      Type:              802.11 WiFi
      Driver:            iwlwifi
      State:             connected
      Default:           yes
      HW Address:        00:21:6B:35:DF:9C
    
      Capabilities:
        Speed:           150 Mb/s
    
      Wireless Properties
        WEP Encryption:  yes
        WPA Encryption:  yes
        WPA2 Encryption: yes
    
      Wireless Access Points (* = current AP)
        Shiann:          Infra, 4C:60:DE:F2:3F:4E, Freq 2437 MHz, Rate 54 Mb/s, Strength 45 WPA2
        Hoot Hoot:       Infra, 74:44:01:4A:AF:3D, Freq 2412 MHz, Rate 54 Mb/s, Strength 37 WPA2
        BigPond4D1635:   Infra, 00:26:44:4D:16:35, Freq 2462 MHz, Rate 54 Mb/s, Strength 19 WPA WPA2
        *SlowNet:        Infra, 4C:60:DE:F2:3F:4F, Freq 5180 MHz, Rate 54 Mb/s, Strength 76 WPA2
    
      IPv4 Settings:
        Address:         192.168.0.3
        Prefix:          24 (255.255.255.0)
        Gateway:         192.168.0.1
    
        DNS:             192.168.0.1
    Code:
    sudo lshw -C network
      *-network               
           description: Wireless interface
           product: PRO/Wireless 5100 AGN [Shiloh] Network Connection
           vendor: Intel Corporation
           physical id: 0
           bus info: pci@0000:02:00.0
           logical name: wlan0
           version: 00
           serial: 00:21:6b:35:df:9c
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
           configuration: broadcast=yes driver=iwlwifi driverversion=3.2.0-31-generic firmware=8.83.5.1 build 33692 ip=192.168.0.3 latency=0 link=yes multicast=yes wireless=IEEE 802.11abgn
           resources: irq:49 memory:de200000-de201fff
      *-network
           description: Ethernet interface
           product: RTL8111/8168B PCI Express Gigabit Ethernet controller
           vendor: Realtek Semiconductor Co., Ltd.
           physical id: 0
           bus info: pci@0000:03:00.0
           logical name: eth0
           version: 02
           size: 1Gbit/s
           capacity: 1Gbit/s
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=r8168 driverversion=8.032.00-NAPI duplex=full latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
           resources: irq:48 ioport:6000(size=256) memory:d4010000-d4010fff memory:d4000000-d400ffff memory:d4020000-d402ffff
    Code:
    lsmod | grep rt8
    dmesg | grep rt8
    Code:
    cat /etc/NetworkManager/NetworkManager.conf
    [main]
    plugins=ifupdown,keyfile
    #dns=dnsmasq
    
    no-auto-default=00:00:00:00:00:00,00:00:00:00:00:00
    
    [ifupdown]
    managed=false
    Code:
    cat /etc/network/interfaces
    auto lo
    iface lo inet loopback
    Code:
    cat /etc/nsswitch.conf
    # /etc/nsswitch.conf
    #
    # Example configuration of GNU Name Service Switch functionality.
    # If you have the `glibc-doc-reference' and `info' packages installed, try:
    # `info libc "Name Service Switch"' for information about this file.
    
    passwd:         compat
    group:          compat
    shadow:         compat
    
    hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4
    networks:       files
    
    protocols:      db files
    services:       db files
    ethers:         db files
    rpc:            db files
    
    netgroup:       nis
    Code:
    cat /var/lib/NetworkManager/NetworkManager.state
    
    [main]
    NetworkingEnabled=true
    WirelessEnabled=true
    WWANEnabled=true
    WimaxEnabled=true

  10. #20
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,587
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wired network can't connect, Wireless fine

    I've been constantly ignoring one more thing, that is the state of your wlan0. All of your ifconfig outputs (and now nm-tool also) are showing it as 'UP' and connected. Did you try to disable it while trying to connect via ethernet?

    Disable it physically if your laptop has a physical switch or a 'Fn+<some key>' combination for doing so. Since both connect to the same network, the system may not even try the eth0 interface while it 'sees' wlan0 as connected.

    If you don't have a physical switch, nor a 'Fn' key combination to disable it, just clear the tick-mark from "Enable Wireless" section in nm-applet drop-down menu. This will 'soft-block' the wlan0 interface.


    PS:
    Correction - it should have been 'r81' (not rt8 ) in both dmesg and lsmod commands. I'm correcting that in my original post above.
    Last edited by varunendra; October 14th, 2012 at 09:05 AM.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •