Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: nVidia 304.43 spoofing 304.51 ?!?!?

  1. #1
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,809
    Distro
    Ubuntu Development Release

    Question nVidia 304.43 spoofing 304.51 ?!?!?

    Gotta say, in all my years of testing, I've never seen this one before...

    Code:
    vindsl@Zuul:~$ dpkg --status nvidia-current | grep Version | cut -f 1 -d '-'
    Version: 304.51.really.304.43
    Er...

    Can anyone explain how/why 'they' did this?
    Intel ® P4 Extreme Edition 3.4 (Gallatin) || DFI ® LanParty PRO875B rev B1
    Crucial ® Ballistix Tracer PC4000 1GB || Mountain Mods U2-UFO Opti-1203
    XFX 7600GT 560M AGP (PV-T73A-UDF3) || Corsair HX520W Modular PSU

  2. #2
    Join Date
    Apr 2010
    Beans
    212

    Re: nVidia 304.43 spoofing 304.51 ?!?!?

    Because they claimed 304.51 is buggy in Unity, I found it works very well though.
    304.43 is a Beta. 304.51 is NOT.

  3. #3
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,809
    Distro
    Ubuntu Development Release

    Re: nVidia 304.43 spoofing 304.51 ?!?!?

    Understood, but...

    nVidia is being reported as "304.51.really.304.43"

    How are we supposed to cut code around that?
    Intel ® P4 Extreme Edition 3.4 (Gallatin) || DFI ® LanParty PRO875B rev B1
    Crucial ® Ballistix Tracer PC4000 1GB || Mountain Mods U2-UFO Opti-1203
    XFX 7600GT 560M AGP (PV-T73A-UDF3) || Corsair HX520W Modular PSU

  4. #4
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,809
    Distro
    Ubuntu Development Release

    Re: nVidia 304.43 spoofing 304.51 ?!?!?

    Let's play "Magic 8-Ball".

    Hrm...

    I wonder what version of nvidia-current I'm running. Let's parse it out...

    Code:
    vindsl@Zuul:~$ dpkg --status nvidia-current | grep Version
    Version: 304.51.really.304.43-0ubuntu1
    Who?
    Code:
    vindsl@Zuul:~$ dpkg --status nvidia-current | grep Version | cut -f 1 -d '-'
    Version: 304.51.really.304.43
    What?
    Code:
    vindsl@Zuul:~$ dpkg --status nvidia-current | grep Version | cut -f 1 -d '-' | sed 's/[^.,0-9]//g'
    304.51..304.43
    Huh?

    What are we supposed to do with output like that? LoL!
    Last edited by VinDSL; October 7th, 2012 at 12:38 AM. Reason: Clarification
    Intel ® P4 Extreme Edition 3.4 (Gallatin) || DFI ® LanParty PRO875B rev B1
    Crucial ® Ballistix Tracer PC4000 1GB || Mountain Mods U2-UFO Opti-1203
    XFX 7600GT 560M AGP (PV-T73A-UDF3) || Corsair HX520W Modular PSU

  5. #5
    Join Date
    Apr 2010
    Beans
    212

    Re: nVidia 304.43 spoofing 304.51 ?!?!?

    yes, this naming rule is ridiculous. and u can find another example:
    nautilus 1:3.5.90.really.3.4.2-0ubuntu4

    and I found xxx.really.yyy is taken as a higher version than xxx itself. That's even more ridiculous, when xxx is larger than yyy.


    Quote Originally Posted by VinDSL View Post
    Understood, but...

    nVidia is being reported as "304.51.really.304.43"

    How are we supposed to cut code around that?

  6. #6
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: nVidia 304.43 spoofing 304.51 ?!?!?

    I'm still using 304.51 here:

    Code:
    dpkg --status nvidia-current-updates | grep Version
    Version: 304.51-0ubuntu1

  7. #7
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,809
    Distro
    Ubuntu Development Release

    Re: nVidia 304.43 spoofing 304.51 ?!?!?

    Just found this...

    SOURCE: https://launchpad.net/ubuntu/quantal...04.43-0ubuntu1
    Format: 1.8
    Date: Fri, 05 Oct 2012 18:52:59 +0200
    Source: nvidia-graphics-drivers
    Binary: nvidia-current nvidia-current-dev
    Architecture: source
    Version: 304.51.really.304.43-0ubuntu1
    Distribution: quantal
    Urgency: low
    Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss@lists.ubuntu.com>
    Changed-By: Alberto Milone <alberto.milone@canonical.com>
    Description:
    nvidia-current - NVIDIA binary Xorg driver, kernel module and VDPAU library
    nvidia-current-dev - NVIDIA binary Xorg driver development files
    Launchpad-Bugs-Fixed: 950963 1057000
    Changes:
    nvidia-graphics-drivers (304.51.really.304.43-0ubuntu1) quantal; urgency=low
    .
    * Revert to 304.43 (LP: #1057000).
    * debian/nvidia-current.dirs.in:
    - Add /usr/share/applications. This should fix
    nvidia-cuda-toolkit FTBFS (LP: #950963).
    * debian/nvidia-current.{postinst|prerm}.in,
    debian/rules:
    - Make sure that the packaging knows how to deal with
    reverted versions such as this one.
    Checksums-Sha1:
    feb1c6fd7df18ea34d8bb01401617bb713303e42 1623 nvidia-graphics-drivers_304.51.really.304.43-0ubuntu1.dsc
    53cedb5ebf0100918cab9cac667c9718064cabfc 77197913 nvidia-graphics-drivers_304.51.really.304.43.orig.tar.gz
    6974a5dfc1446338c0c8dac62c216fef083e7d7d 159205 nvidia-graphics-drivers_304.51.really.304.43-0ubuntu1.diff.gz
    Checksums-Sha256:
    7cacfe74655ef1b6806ba1c8c25b0ef896528ad4e16f2fdce3 d52959dacc8a91 1623 nvidia-graphics-drivers_304.51.really.304.43-0ubuntu1.dsc
    5342507f6c9e3221dc4f5b085c290a53791b69d026749e825b 1502c91bd4b6a8 77197913 nvidia-graphics-drivers_304.51.really.304.43.orig.tar.gz
    8c37769ec06a9c52a064e2c364439d2ecb7414bca3e8f0de8a 17c67b6eba2f47 159205 nvidia-graphics-drivers_304.51.really.304.43-0ubuntu1.diff.gz
    Files:
    b5c0a450e93ed93fa6283ad7a049e4d8 1623 restricted/misc optional nvidia-graphics-drivers_304.51.really.304.43-0ubuntu1.dsc
    7ecd1ad6b41dd29c1d9d82f42865cf44 77197913 restricted/misc optional nvidia-graphics-drivers_304.51.really.304.43.orig.tar.gz
    406379567b2a1f0b605bd99f43c1e961 159205 restricted/misc optional nvidia-graphics-drivers_304.51.really.304.43-0ubuntu1.diff.gz
    If they were going to revert back to 304.43, fine, but why did they spoof the name?

    Either it's "really" 304.43 or 304.51. yes?

    Heh! This one has me scratching my head!
    Intel ® P4 Extreme Edition 3.4 (Gallatin) || DFI ® LanParty PRO875B rev B1
    Crucial ® Ballistix Tracer PC4000 1GB || Mountain Mods U2-UFO Opti-1203
    XFX 7600GT 560M AGP (PV-T73A-UDF3) || Corsair HX520W Modular PSU

  8. #8
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,809
    Distro
    Ubuntu Development Release

    Re: nVidia 304.43 spoofing 304.51 ?!?!?

    Quote Originally Posted by cariboo907 View Post
    I'm still using 304.51 here:

    Code:
    dpkg --status nvidia-current-updates | grep Version
    Version: 304.51-0ubuntu1
    That's what I'm going to do, too... revert back to the "really real 304.51" version.

    This is silly...
    Intel ® P4 Extreme Edition 3.4 (Gallatin) || DFI ® LanParty PRO875B rev B1
    Crucial ® Ballistix Tracer PC4000 1GB || Mountain Mods U2-UFO Opti-1203
    XFX 7600GT 560M AGP (PV-T73A-UDF3) || Corsair HX520W Modular PSU

  9. #9
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,809
    Distro
    Ubuntu Development Release

    Re: nVidia 304.43 spoofing 304.51 ?!?!?

    OK, that works (still sitting in my cache).

    Code:
    vindsl@Zuul:~$ dpkg --status nvidia-current | grep Version
    Version: 304.51-0ubuntu1~xedgers~quantal1
    Forced/pinned...
    Intel ® P4 Extreme Edition 3.4 (Gallatin) || DFI ® LanParty PRO875B rev B1
    Crucial ® Ballistix Tracer PC4000 1GB || Mountain Mods U2-UFO Opti-1203
    XFX 7600GT 560M AGP (PV-T73A-UDF3) || Corsair HX520W Modular PSU

  10. #10
    Join Date
    Apr 2010
    Beans
    212

    Re: nVidia 304.43 spoofing 304.51 ?!?!?

    I use apt-fast. Before genuine upgrade I found nvidia-current is in the list, hence held it. Just waste 64MB flow and 500J electricity, I'm glad not be an environmentalist.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •