Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: panels classic and xfce

  1. #11
    Join Date
    Aug 2005
    Location
    Northern Michigan USA
    Beans
    1,757
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: panels classic and xfce

    Ok there are a bunch of panel files in there probably because I tried so many fixes lately. I am attaching a screenshot of the folder items and the error I get when I try to open one to modify. Which file should I modify and how do I open it. Thank you
    Attached Images Attached Images

  2. #12
    Join Date
    Oct 2008
    Location
    Ottawa, Canada
    Beans
    804
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: panels classic and xfce

    I didn't tell you to launch it, I told you to open it inside a text editor, like gedit.
    husband@wife$ make sandwich
    Permission denied
    husband@wife$ sudo make sandwich

  3. #13
    Join Date
    Aug 2005
    Location
    Northern Michigan USA
    Beans
    1,757
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: panels classic and xfce

    That's what I tried to do and why I posted the error screenshot I get when I try to open it.

  4. #14
    Join Date
    Aug 2005
    Location
    Northern Michigan USA
    Beans
    1,757
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: panels classic and xfce

    OK I used thunar to pick gedit to open it-that option is gone from nautilus and added it as you said, no change I still get the gnome panels. If this helps, when I restart the xfce panels flash up for a second then they are replaced by the gnome panels.I can kill the gnome-panel in system monitor but it instantly reappears.
    Last edited by cmcanulty; October 7th, 2012 at 05:31 PM.

  5. #15
    Join Date
    Oct 2008
    Location
    Ottawa, Canada
    Beans
    804
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: panels classic and xfce

    I don't have GNOME Classic or gnome-panel installed so I cannot fully test this. However, I created a dummy startup application in Xfce. It appended
    OnlyShowIn=XFCE;
    to the desktop file contents which makes sense, and it does launch. If I change =XFCE to =GNOME, it no longer launches at login. So the trick does work.

    Did you keep only one gnome-panel autostart .desktop file?
    In any case, you can disable it temporarily if you just want to test out Xfce. In GNOME, just execute gnome-panel to get it back. Once you have made up your mind, clean up everything.
    husband@wife$ make sandwich
    Permission denied
    husband@wife$ sudo make sandwich

  6. #16
    Join Date
    Aug 2005
    Location
    Northern Michigan USA
    Beans
    1,757
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: panels classic and xfce

    OK I added that to the .config/autostart/gnome-panel.desktop. How do I create a dummy startup application in xfce? Thank you.No change I still get gnome panels in front of xfce panels but I haven't done the dummy startup app until I find out how to do it.And still as xfce opoens I see the xfce panels then they are immediately covered by the gnome panels.
    Last edited by cmcanulty; October 8th, 2012 at 03:23 PM.

  7. #17
    Join Date
    Oct 2008
    Location
    Ottawa, Canada
    Beans
    804
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: panels classic and xfce

    The dummy entry was for me, for testing the OnlyShowIn method. If you want to test drive Xfce either disable all gnome-panel entries or find how it gets autostarted and edit the .desktop file accordingly. This should be straightforward, I can provide no more help.
    husband@wife$ make sandwich
    Permission denied
    husband@wife$ sudo make sandwich

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •