Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 36

Thread: AirLive WL 1600 USB - problem

  1. #21
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,277
    Distro
    Ubuntu Development Release

    Re: AirLive WL 1600 USB - problem

    [ 1.536273] hub 1-0:1.0: USB hub found
    [ 1.536282] hub 1-0:1.0: 6 ports detected
    Is your AirLive attached to a hub? Have you tried with it attached directly to the USB port?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  2. #22
    Join Date
    Oct 2012
    Beans
    18

    Re: AirLive WL 1600 USB - problem

    Nope, AirLive is attached directly to the USB port.

  3. #23
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,277
    Distro
    Ubuntu Development Release

    Re: AirLive WL 1600 USB - problem

    I'm sorry. I haven't a single further idea. There is nothing, aside from the iRQs, that I can see wrong to fix. If you'd care to troubleshoot the native driver rtl8187 or use the internal device, I'd be glad to continue.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  4. #24
    Join Date
    Oct 2012
    Beans
    18

    Re: AirLive WL 1600 USB - problem

    Ok, what do you say to reinstall Mint and try to fix native driver ?

  5. #25
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,277
    Distro
    Ubuntu Development Release

    Re: AirLive WL 1600 USB - problem

    I doubt there is any need to reinstall. I'd remove the ndiswrapper file:
    Code:
    sudo ndiswrapper -e netrtuw_x64
    Then I'd amend the blacklist file to remove rtl8187:
    Code:
    sudo gedit /etc/modprobe.d/blacklist.conf
    Reboot and see what you get:
    Code:
    iwconfig
    If neither the internal Atheros works, nor the USB with either rtl8187 or ndiswrapper, then there is a bigger problem at work here: IRQs?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  6. #26
    Join Date
    Oct 2012
    Beans
    18

    Re: AirLive WL 1600 USB - problem

    I did what You said. I rebooted and my card wasn't working.
    I wrote in console :
    Code:
    modprobe rtl8187
    and the card started working.
    Code:
    lo        no wireless extensions.
    
    wlan1     IEEE 802.11bg  ESSID:"masteras-Chuck"  
              Mode:Managed  Frequency:2.432 GHz  Access Point: 00:90:CC:D7:09:FA   
              Bit Rate=36 Mb/s   Tx-Power=20 dBm   
              Retry  long limit:7   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=40/70  Signal level=-70 dBm  
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:37  Invalid misc:24   Missed beacon:0
    
    eth0      no wireless extensions.

  7. #27
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,277
    Distro
    Ubuntu Development Release

    Re: AirLive WL 1600 USB - problem

    Awesome! Let's get rtl8187 to load automatically.
    Code:
    sudo su
    echo rtl8187 >> /etc/modules
    exit
    Is everything working as expected now?
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  8. #28
    Join Date
    Oct 2012
    Beans
    18

    Re: AirLive WL 1600 USB - problem

    The pages are loading very long or I got an error. I cannot download files because speed falls to 0kb/s. That's why I wanted to install windows driver.

  9. #29
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,277
    Distro
    Ubuntu Development Release

    Re: AirLive WL 1600 USB - problem

    Let's see:
    Code:
    lsmd | grep -e ndis -e 818
    dmesg | grep 818
    Thanks.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  10. #30
    Join Date
    Oct 2012
    Beans
    18

    Re: AirLive WL 1600 USB - problem

    Code:
    lsmod | grep -e ndis -e 818
    rtl8187                57035  0 
    mac80211              506816  1 rtl8187
    cfg80211              205544  2 rtl8187,mac80211
    eeprom_93cx6           12725  1 rtl8187
    ndiswrapper           282628  0
    Code:
    dmesg | grep 818
    [    0.271818] PCI: pci_cache_line_size set to 64 bytes
    [    0.272226] hpet0: 4 comparators, 32-bit 14.318180 MHz counter
    [   20.026762] ieee80211 phy0: hwaddr 00:4f:78:00:2d:c0, RTL8187vB (default) V1 + rtl8225z2, rfkill mask 2
    [   20.038760] rtl8187: Customer ID is 0xFF
    [   20.038814] Registered led device: rtl8187-phy0::radio
    [   20.038839] Registered led device: rtl8187-phy0::tx
    [   20.038861] Registered led device: rtl8187-phy0::rx
    [   20.039229] rtl8187: wireless switch is on
    [   20.039283] usbcore: registered new interface driver rtl8187

Page 3 of 4 FirstFirst 1234 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •