Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: How to unhide the auto-hide launcher?

  1. #11
    Join Date
    Jun 2007
    Beans
    12,999

    Re: How to unhide the auto-hide launcher?

    Quote Originally Posted by funicorn View Post
    So this means nvidia driver cannot get the actual size of the display. That's funny.
    Nothing to do with ^
    Option "ConstrainCursor" "boolean"

    When this option is enabled, the mouse cursor will be constrained to the region of the desktop that is visible within the union of all displays' panning domains in the current MetaMode. When it is disabled, it may be possible to move the cursor to regions of the X screen that are not visible on any display.

    Note that if this would make display's panning domain is inaccessible (in other words, if the union of all panning domains is disjoint), then the cursor will not be constrained, so that it is still possible to move the cursor to each display.

    Default: on, if the X server supports it. The cursor will be constrained to the panning domain of each monitor, when possible.
    The changelog does mention a bug fix for panning that possibly has created this which will no doubt be fixed

    Fixed a bug that prevented panning from working correctly
    after a modeswitch on some X servers with support for
    cursor constraining.

  2. #12
    Join Date
    Aug 2008
    Beans
    1,835
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to unhide the auto-hide launcher?

    Quote Originally Posted by mc4man View Post
    Well both the .48 & .51 ones are in the repos

    Anyway this should return the unhiding of launcher with the .51
    Code:
    sudo nano  /etc/X11/xorg.conf
    Code:
    Section "Device"
      Identifier "NVIDIA GeForce"
      Driver     "nvidia"
      Option     "ConstrainCursor" "no"  
    EndSection
    c&p above, ctrl+o, enter, ctrl+x, restart
    Thanks mc4man. Adding

    Code:
    Option     "ConstrainCursor" "no"
    to the xorg.conf Device section worked for me.

  3. #13
    Join Date
    Oct 2012
    Beans
    5

    Re: How to unhide the auto-hide launcher?

    Bug report #1060511 covers this.

  4. #14
    Join Date
    Apr 2006
    Beans
    184

    Re: How to unhide the auto-hide launcher?

    Thx Prowlcat. I came here to see if anyone knew of an existing bug when I experienced the same. I'll go mark it as affecting me right now.

    Edit: https://bugs.launchpad.net/ubuntu/+s...r/+bug/1060511

  5. #15
    Join Date
    Jun 2007
    Beans
    12,999

    Re: How to unhide the auto-hide launcher?

    current bug on is actually here -
    https://bugs.launchpad.net/unity/+bug/1057000

    Fix released by for the moment reverting back to the .43

  6. #16
    Join Date
    Apr 2010
    Beans
    212

    Re: How to unhide the auto-hide launcher?

    When it is disabled, it may be possible to move the cursor to regions of the X screen that are not visible on any display.
    I have only one display and the visible region is the whole region of X screen. Hence it doesn't matter this option is disabled or not, if xserver correctly recognizes X screen size. However this options does matter now, I have good reason to suspect xserver fails to do that.

  7. #17
    Join Date
    Oct 2012
    Beans
    5

    Re: How to unhide the auto-hide launcher?

    This is now fixed with both .48 and .51, Unity comes out of hiding as it should.

  8. #18
    Join Date
    Aug 2009
    Beans
    3,203
    Distro
    Ubuntu Development Release

    Re: How to unhide the auto-hide launcher?

    304.51 definitely works better on my system. With 304.43 Compiz crashed at nearly every bootup. Had to logout and back it to fix it.
    I uninstalled nvidia-current and installed nvidia-current-updates. It got an error and didn't install some dependant files.
    Fixed that with Synaptic.
    Check Java Version | Install Java via WEB UPD8 PPA
    Creating a Custom Maintenance Free GRUB2 Screen Community Wiki
    Ubuntu 12.04 | 14.04 | 14.10 | Mint 13 | Mint 17 | Windows 7 | All 64 bit

  9. #19
    Join Date
    Apr 2010
    Beans
    212

    Re: How to unhide the auto-hide launcher?

    @Prolcat, do you mean the bug is fixed by NVIDIA or by Unity ?

    Quote Originally Posted by Prowlcat View Post
    This is now fixed with both .48 and .51, Unity comes out of hiding as it should.

  10. #20
    Join Date
    Aug 2009
    Beans
    3,203
    Distro
    Ubuntu Development Release

    Re: How to unhide the auto-hide launcher?

    Wait a minute... I have been using Gnome Classic but, when I logged into Unity and had the bar hide, it still did not show up for me.
    When I did a mouse over on the left just a line barely appeared, no Unity bar though.
    But, I am happy with Gnome classic and 304.51 works well with that.

    If you wish to unhide the auto-hide Unity launcher I would not be quick to jump on 304.51.
    Check Java Version | Install Java via WEB UPD8 PPA
    Creating a Custom Maintenance Free GRUB2 Screen Community Wiki
    Ubuntu 12.04 | 14.04 | 14.10 | Mint 13 | Mint 17 | Windows 7 | All 64 bit

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •