Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Won't boot after installing proprietary video drivers

  1. #11
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Won't boot after installing proprietary video drivers

    Quote Originally Posted by Rukiri View Post
    Amd doesn't know how to write decent drivers
    Pardon the expression, but ... Bull! The drivers work very well. What AMD has not yet done is expose the APIs for more hardware acceleration via the xvba back end for VA-API. NVIDIA uses what used to be its own proprietary VDPAU (which has been open sourced), which works only with NVIDIA GPUs. But given the fact that AMD, unlike NVIDIA, works with open source developers to create the open source Radeon driver, it's hard to get too unhappy with them -- although they really need to expose those APIs. The flame wars really need to stop. NVIDIA and AMD both produce good hardware and they both take the Linux community seriously. Considering that the drivers work at all for a segment that comprises 2 or 3% of the market and that it takes roughly the same amount of effort and resources to create the Linux driver as the Windows driver, I'd say both companies are giving Linux more than a fair shake.

    AMD also has a very close relationship with Canonical, too close according to some in the industry.

    The issue with Quantal is that the AMD 12.10 driver, which will handle the new xorg, is not in the Ubuntu repo yet -- AMD releases the xx.4 and xx.10 drivers to Canonical before the rest of the general Linux public.

    The 12.9 "Ubuntu Preview Beta" currently in the repo from AMD is close, but still has some problems with artifacts even when it works.

    AMD is working on their 12.10 driver and, if the last four years are any indication, it will be released to the Canonical repo shortly -- and before anyone else gets it. Phoronix whines about Ubuntu "getting the candy before anyone else" every April and October.

    In short: The 12.9 "Ubuntu Preview Beta" is a preview and a Beta. The 12.10 driver is expected to work every bit as well with Ubuntu as any xx.4 or xx.10 driver.

    Uninstall the proprietary driver and use the Radeon driver until Catalyst 12.10 drops into the Canonical repo.
    Last edited by QIII; October 9th, 2012 at 04:56 AM.
    The Community Java Wiki * The Community ATI Driver Wiki * Find what you need in the Ubuntu Community wikis

    And seeing the terror on the faces of the people, QIII did speak to them, saying "Fear not the Terminal, for it is a road both swift and secure to the Great Mysteries of Linux without passing through the dangers of The Land of Ten Thousand Competing Desktop Environments."

  2. #12
    Join Date
    Mar 2010
    Beans
    32

    Re: Won't boot after installing proprietary video drivers

    sorry I haven't been on in about a week, I've been really busy. I still haven't figured out how to fix this problem, I've tried everything listed here. My main problem is that I can't get to a usable command prompt that doesn't mount the filesystem as read-only. Probably just going to reinstall, and wait until AMD gets the 12.10 drivers out.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •