Results 1 to 7 of 7

Thread: Hotkeys not working in Cyrillic layout.

  1. #1
    Join Date
    Apr 2010
    Beans
    98

    Hotkeys not working in Cyrillic layout.

    Hi! I have installed an English version of Ubuntu 12.04.1 and added a Russian keyboard layout to it. The problem is that when I switch to that layout none of the hotkeys seem to work.

    Looks like it has something to do with key mapping, but I have no idea from where to start. As well as the default Unity hotkeys, the ones in browser games don't work as well, which looks funny to me.

    As far as I know there are no problems of such kind in Windows. Hotkeys work no matter what layout is used. Is there a human-friendly way to achieve the same in Ubuntu?

    Will be thankful for any help.
    Last edited by s.v.z; October 5th, 2012 at 06:16 PM.

  2. #2
    Join Date
    Aug 2006
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Hotkeys not working in Cyrillic layout.

    If the hotkeys are in English, why would they work with the Russian layout? Switch back to English, and use hotkeys, or perhaps I don't quite understand the problem.

  3. #3
    Join Date
    Apr 2010
    Beans
    98

    Re: Hotkeys not working in Cyrillic layout.

    Quote Originally Posted by mikewhatever View Post
    If the hotkeys are in English, why would they work with the Russian layout? Switch back to English, and use hotkeys, or perhaps I don't quite understand the problem.
    Well, yes. The hotkeys are english. But it is really annoying to have to switch keyborad layout every time I want to use a hotkey. I'm not sure about how it works on Windows, but there seem to be no problems with DM hotkeys binded to a single layout. It just works, no matter what kind of a layout you use.

    What I need is a hint on how to achieve same behaviour in Ubuntu.

  4. #4
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    5,945
    Distro
    Ubuntu Development Release

    Re: Hotkeys not working in Cyrillic layout.

    First of all, what kind of a Russian keyboard layout did you select? I see 15 different types of Russian keyboard layout. You may have chosen a layout that has limited functions for hotkey combinations.

    Second, go to System Settings>Keyboard>Shortcuts and see if you can get what you want there.

    Third, what actions are you trying to accomplish? What programs do you want to do these actions in.

    Fourth, you may need to switch not just the keyboard layout to Russian but the whole operating system to get what you want. So, go to System>Settings>Language.

    Fifth, we get what we pay for. Linux distributions, of which Ubuntu is one, are developed by a Community and distributed without charge but not without cost. In the Linux community when we see something that does not work as well as we like we have the opportunity to get involved and work to make things better.

    Regards.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  5. #5
    Join Date
    Apr 2010
    Beans
    98

    Re: Hotkeys not working in Cyrillic layout.

    Quote Originally Posted by grahammechanical View Post
    First of all, what kind of a Russian keyboard layout did you select? I see 15 different types of Russian keyboard layout. You may have chosen a layout that has limited functions for hotkey combinations.
    I chose the first one. The one that says just Russian. Not sure if it has any limitations.

    Quote Originally Posted by grahammechanical View Post
    Second, go to System Settings>Keyboard>Shortcuts and see if you can get what you want there.
    After I go there and try to change, for example, the "lock screen" command hotkey, it is changed to "Ctrl+Alt+Cyrillic de" and thus stops working in English layout.

    Quote Originally Posted by grahammechanical View Post
    Third, what actions are you trying to accomplish? What programs do you want to do these actions in.
    Well, it's standard Unity hotkeys, like Ctrl+Alt+L to lock the screen and so on. The VLC fullscreen key ("F") doesn't work either. Somehow key-binded controls also stop working in browser applications when I switch to RU.

    Quote Originally Posted by grahammechanical View Post
    Fourth, you may need to switch not just the keyboard layout to Russian but the whole operating system to get what you want. So, go to System>Settings>Language.
    Probably it might help, but I don't want the whole system translated into Russian.

    Quote Originally Posted by grahammechanical View Post
    Fifth, we get what we pay for. Linux distributions, of which Ubuntu is one, are developed by a Community and distributed without charge but not without cost. In the Linux community when we see something that does not work as well as we like we have the opportunity to get involved and work to make things better.

    Regards.
    That's why I'm asking this question here. Wish I could be of any help, but unfortunately I have no idea what to do.
    Last edited by s.v.z; October 5th, 2012 at 07:03 PM.

  6. #6
    Join Date
    Aug 2006
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Hotkeys not working in Cyrillic layout.

    Quote Originally Posted by s.v.z View Post
    Well, yes. The hotkeys are english. But it is really annoying to have to switch keyborad layout every time I want to use a hotkey. I'm not sure about how it works on Windows, but there seem to be no problems with DM hotkeys binded to a single layout. It just works, no matter what kind of a layout you use.

    What I need is a hint on how to achieve same behaviour in Ubuntu.
    I am pretty sure it works the same in Windows XP - the only one I can test. For example, if I switch to a non-latin language, Super-e, or Super-d no longer work, because the system doesn't get the expected values.

  7. #7
    Join Date
    Jul 2012
    Beans
    1

    Re: Hotkeys not working in Cyrillic layout.

    @mikewhatever, this is absolutely untrue! In all Windows OS hotkeys work flawlessly on any layout, without any changes or problems! In many Linux distributions that I've tried also there aren't any problems at all.
    Last edited by mozart27; July 5th, 2013 at 06:00 PM. Reason: typo

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •