Results 1 to 2 of 2

Thread: Problem running alacarte as root

  1. #1
    Join Date
    Dec 2008
    Location
    Research Triangle, NC
    Beans
    Hidden!
    Distro
    Xubuntu

    Question Problem running alacarte as root

    Getting the following error, anyone have any ideas?

    Code:
    $ sudo xfce4-panel 
    [sudo] password for egriffin: 
    
    (xfce4-panel:23028): GLib-WARNING **: (/build/buildd/glib2.0-2.32.3/./glib/gerror.c:390):g_error_new_valist: runtime check failed: (domain != 0)
    xfce4-panel: Failed to connect to session manager: Verbindung zur Sitzungsverwaltung fehlgeschlagen: SESSION_MANAGER environment variable not defined
    Traceback (most recent call last):
      File "/usr/bin/alacarte", line 37, in <module>
        main()
      File "/usr/bin/alacarte", line 33, in main
        app = MainWindow(datadir, version, sys.argv)
      File "/usr/share/alacarte/Alacarte/MainWindow.py", line 49, in __init__
        self.editor = MenuEditor()
      File "/usr/share/alacarte/Alacarte/MenuEditor.py", line 36, in __init__
        self.__loadMenus()
      File "/usr/share/alacarte/Alacarte/MenuEditor.py", line 44, in __loadMenus
        self.applications.path = os.path.join(util.getUserMenuPath(), self.applications.tree.get_menu_file())
      File "/usr/lib/python2.7/posixpath.py", line 66, in join
        if b.startswith('/'):
    AttributeError: 'NoneType' object has no attribute 'startswith'
    ^C
    (xfce4-panel:23028): xfconf-CRITICAL **: xfconf_cache_old_item_end_call: assertion `old_item->call' failed
    My path is set to:
    Code:
    PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
    and there is no PERLLIB setting.
    from nowhere, and yes it hurts
    ASUS M3A32MVP wifi, Thermalake BigO2/760i
    AMD Phenom 9850 (black) Quad 3.2GHz, full SSD
    4GB RAM, 4TB, APC, in Thermaltake Level 10 GT ATX

  2. #2
    rai4shu2 is offline Extra Foam Sugar Free Ubuntu
    Join Date
    Jun 2006
    Beans
    Hidden!
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Problem running alacarte as root

    Maybe use gksudo instead of sudo (although why you'd run as root...)?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •