Results 1 to 4 of 4

Thread: 12.04 (64-bit) doesn't run on battery - HP8740w

  1. #1
    Join Date
    Nov 2009
    Beans
    19

    12.04 (64-bit) doesn't run on battery - HP8740w

    I've had an HP EliteBook 8740w for about 2 years, running various releases of Ubuntu. I'm currently running 12.04, and just noticed that Ubuntu won't run (for more than a few minutes) on batteries. The laptop is normally in a dock, on AC power. I recently took it on the road, and the system would log me off without warning. Today I did a test, and got it to log me off several times on battery (session never lasted more than 2 minutes without a crash). The same test on AC showed no reboots.

    I looked through syslog and matched up the logoffs, and while I don't see it every time, most of them generate something like:
    Code:
    kernel: [  820.887144] pcieport 0000:00:03.0: AER: Multiple Uncorrected (Non-Fatal) error received: id=0018
    kernel: [  820.887159] pcieport 0000:00:03.0: PCIe Bus Error: severity=Uncorrected (Non-Fatal), type=Transaction Layer, id=0018(Requester ID)
    kernel: [  820.887166] pcieport 0000:00:03.0:   device [8086:d138] error status/mask=00004000/00000000
    kernel: [  820.887173] pcieport 0000:00:03.0:    [14] Completion Timeout     (First)
    kernel: [  820.887180] pcieport 0000:00:03.0: broadcast error_detected message
    kernel: [  820.887184] pcieport 0000:00:03.0: broadcast mmio_enabled message
    kernel: [  820.887187] pcieport 0000:00:03.0: broadcast resume message
    kernel: [  820.887191] pcieport 0000:00:03.0: AER driver successfully recovered
    gnome-session[4967]: Gdk-WARNING: gnome-session: Fatal IO error 11 (Resource temporarily unavailable) on X server :3.#012
    Does this look like something that would cause a sudden log-off? Any idea why it doesn't happen on AC power?

  2. #2
    Join Date
    Nov 2009
    Beans
    19

    Re: 12.04 (64-bit) doesn't run on battery - HP8740w

    So, it appears as if no one has a suggestion for a solution. I guess the next step is to see if this is a common problem? Does anyone else have an HP 8740w or similar system with 12.04, and if so, does it run fine on batteries?

  3. #3
    Join Date
    Nov 2009
    Beans
    19

    Re: 12.04 (64-bit) doesn't run on battery - HP8740w

    Last night, I believe I saw the same problem on AC power. This was after the system was on for a couple of days, and I don't believe there was a power failure that put the system on battery.

    I'm still no closer to a solution. Suggestions are welcome.

  4. #4
    Join Date
    Nov 2009
    Beans
    19

    Re: 12.04 (64-bit) doesn't run on battery - HP8740w

    I decided to upgrade to Quantal. I was able to run for a few minutes, but then got knocked off, and syslog showed the same error. It seems a bit more stable than 12.04, but when your system kicks you off every minute, getting it to kick you off every 10 minutes doesn't really make it a lot better.

    I found other 8540w users who are complaining about reboots on windows, and those errors seem to be logged as non-fatal pcie root port problems.

    I didn't see this until I installed 12.04. Is it time to downgrade?

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •