Results 1 to 4 of 4

Thread: Hi guys newbie samba question

  1. #1
    Join Date
    Oct 2012
    Beans
    3

    Hi guys newbie samba question

    Hi fellas

    I am setting up a samba server at work to be a fileserver for our windows network. It's all very basic, we have a mix of laptops and desktops running mainly windows 7 and a few Vista. Some connect wirelessly to the router, and the desktop and Ubuntu Server are on Cat 5.

    I installed Ubuntu server yesterday and installed it with samba. I also installed the desktop and GADMIN-SAMBA.

    I can now see the server on the network, but if I try to access it from a windows PC it asks for a user name and password, and nothing I enter is accepted - the root, my server logon, or any of the users I added via GADMIN-SAMBA.

    We are all connected to windows via WORKGROUP ie default.

    Can anybody help me please?!

    many thanks

    RiotSloth (Robsa)

  2. #2
    Join Date
    May 2009
    Location
    Indiana
    Beans
    1,965
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Hi guys newbie samba question

    In the file /etc/samba/smb.conf, in the authentication section, do you have a line

    security = user
    not commented out? That would require anyone connecting to the server to have a user account on the server and to log in using those credentials.
    Jane, stop this crazy thing!

  3. #3
    Join Date
    Oct 2008
    Location
    colachel
    Beans
    513
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Hi guys newbie samba question

    Add and enable the samba user

    ex)
    useradd test
    smbpasswd -a test

  4. #4
    Join Date
    Oct 2008
    Location
    colachel
    Beans
    513
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Hi guys newbie samba question

    Add a user to a Samab share

    By default user gets access to /home/test from windows system. Let us say you want to give user "test" access to /data/samba (make sure directory /data/samba exists) directory. Open /etc/samba/smb.conf file and add/modify share called


    [accounts]
    comment = Accounts data directory
    path = /data/samba
    valid users = test sahab
    public = no
    writable = yes

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •