Results 1 to 7 of 7

Thread: rt2800pci cuts out after it can't take load.

Hybrid View

  1. #1
    Join Date
    Oct 2012
    Beans
    12

    Exclamation rt2800pci cuts out after it can't take load.

    I am currently using a wireless connection which uses the driver rt2800pci, I have read on the internet how it times out every now and then. I find when I'm downloading a file or have more than one youtube video open it decides just to stop loading the internet, however it shows it is still connected to my wireless it decides to stop. Is there a patch which fixes this problem or a different driver I could install which would work better than my current driver rt2800pci.

    I have searched all over google for a solved answer, however I have found threads which claim to be solved in the title but are not solved/ threads that make 100% no sense.

  2. #2
    Join Date
    Oct 2012
    Beans
    12

    Re: rt2800pci cuts out after it can't take load.

    I will just mention it didn't used to be a problem it has only come about in the last few months it's like it limits how much transfer of data is allowed and clocks out once it hits the bar.

  3. #3
    Join Date
    Jun 2006
    Location
    Goshen, IN
    Beans
    252
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: rt2800pci cuts out after it can't take load.

    I am also experiencing terrible problems with an rt3060-based device, using the rt2800pci driver.

    However, in my case it has nothing to do with heavy load. I am experiencing constant packet loss (around 5-20%) when pinging my router.

    I just installed the backports modules, which did change rt2800pci version numbers, but that has not helped.

    I don't believe I had this problem until relatively recently. I will try to do more testing.
    Last edited by james_xxx; October 12th, 2012 at 07:36 PM.
    Desktop: Kubuntu 12.10 64-bit Core 2 Quad Q9300 @ 2.5GHz 4GB DDR2 Nvidia GT440
    Nettop: Kubuntu 12.04 64-bit Atom D525 @ 1.8GHz 4GB DDR2 Nvidia ION2
    Laptop: Kubuntu 12.04 32-bit Core Duo @ 1.6Ghz 2GB DDR2
    Netbook: Lubuntu 12.04 Dell Mini 9 2GB RAM

  4. #4
    Join Date
    Jun 2006
    Location
    Goshen, IN
    Beans
    252
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: rt2800pci cuts out after it can't take load.

    I just spent some time in Windows 7, and pinged my router numerous times, doing 50 pings at a time, and experienced no packet loss at all. This influences me even more to believe that there is presently something wrong with the rt2800pci Linux driver.
    Desktop: Kubuntu 12.10 64-bit Core 2 Quad Q9300 @ 2.5GHz 4GB DDR2 Nvidia GT440
    Nettop: Kubuntu 12.04 64-bit Atom D525 @ 1.8GHz 4GB DDR2 Nvidia ION2
    Laptop: Kubuntu 12.04 32-bit Core Duo @ 1.6Ghz 2GB DDR2
    Netbook: Lubuntu 12.04 Dell Mini 9 2GB RAM

  5. #5
    Join Date
    Jun 2006
    Location
    Goshen, IN
    Beans
    252
    Distro
    Kubuntu 12.10 Quantal Quetzal

    Re: rt2800pci cuts out after it can't take load.

    Reporting back again...

    I just upgraded to the 3.5.0 kernel (from the xorg-edgers PPA), and although the problem has not completely disappeared, I'm experiencing MARKEDLY reduced packet loss.

    Each time I have tested since upgrading the kernel, I get 0 - 10% packet loss, pinging my home WAP.

    It's still ridiculous for there to be any packet loss at all, but this is a huge improvement.
    Last edited by james_xxx; October 13th, 2012 at 04:27 AM.
    Desktop: Kubuntu 12.10 64-bit Core 2 Quad Q9300 @ 2.5GHz 4GB DDR2 Nvidia GT440
    Nettop: Kubuntu 12.04 64-bit Atom D525 @ 1.8GHz 4GB DDR2 Nvidia ION2
    Laptop: Kubuntu 12.04 32-bit Core Duo @ 1.6Ghz 2GB DDR2
    Netbook: Lubuntu 12.04 Dell Mini 9 2GB RAM

  6. #6
    Join Date
    Oct 2009
    Beans
    13

    Re: rt2800pci cuts out after it can't take load.

    Just wanted to add my $.02...

    Noticed some bandwidth issues, so started fiddling around and noticed high packet loss (varies 5-15 % generally). This is happening on a desktop running a RT2790 (rt2800pci driver), and a laptop running a RT5390 (also rt2800pci driver).

    The laptop is a dual boot machine with Windows 7. Pinging on Windows repeatably gives 0 packets lost in over 1000 pings. Pinging on Ubuntu with the aforementioned driver predictably yields >5% packet loss.

    Dropped packets appear to occur in bursts of 1-5. At a glance, most are single dropped packets, but occur during periods of increased loss.

    I'm going to fiddle with gain, etc, and will post back if I have any luck.

    Edit:
    I played around with a few things... Compiling newer drivers per
    this askubuntu.com post by mywebslave
    helped quite a bit. I used the latest stable compat-wireless release (3.6.6-1). It may have actually been updated to 3.6.8-1 in the last few hours, so YMMV.

    The laptop now has drop rates approaching (but not quite equal to) the Win7 driver performance. The desktop still drops some packets, but that could be due to the card and location -- I do not have another OS to compare it to. Turning down the gain via
    sudo iwconfig wlan0 txpower 10
    may have helped slightly, but not a huge amount.
    Last edited by andymcca; November 29th, 2012 at 06:35 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •