Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Alt-SysRq-K is broken in QQ 12.10

  1. #1
    Join Date
    Nov 2007
    Location
    London, England
    Beans
    5,571
    Distro
    Xubuntu 14.10 Utopic Unicorn

    Alt-SysRq-K is broken in QQ 12.10

    I have found that Alt-SysRq-K (to kill the current X session) is broken in 12.10. Does anyone know how to recover this functionality?

  2. #2
    Join Date
    Jun 2007
    Beans
    13,442

    Re: Alt-SysRq-K is broken in QQ 12.10

    read here on how to re-enable in kernel
    http://ubuntuforums.org/showpost.php...38&postcount=6

  3. #3
    Join Date
    Nov 2007
    Location
    London, England
    Beans
    5,571
    Distro
    Xubuntu 14.10 Utopic Unicorn

    Re: Alt-SysRq-K is broken in QQ 12.10

    Thanks for the link, I wasn't aware of that setting. But /proc/sys/kernel/sysrq is already 1, and other SysRq sequences (e.g. B) still work. So I can brutally reboot the box easily, but cannot just kill X.

    Edit:
    This is rubbish. I forget myself and tried ot on a 12.04 system, not a 12.10 system.
    Last edited by The Cog; October 3rd, 2012 at 06:36 PM.

  4. #4
    Join Date
    Jul 2007
    Location
    UK
    Beans
    16,867
    Distro
    Ubuntu Development Release

    Question Re: Alt-SysRq-K is broken in QQ 12.10

    Not at my box but I seem to remember the ctrl alt del might log out.

  5. #5
    Join Date
    Nov 2007
    Location
    London, England
    Beans
    5,571
    Distro
    Xubuntu 14.10 Utopic Unicorn

    Re: Alt-SysRq-K is broken in QQ 12.10

    Thanks, but Ctrl-Alt-Del doesn't seem to work either. I have a feeling that even when it did, years ago, it was voluntary by X. Alt-SysRq-K is better because it works (used to) even when X was completely frozen.

  6. #6
    Join Date
    Jun 2007
    Beans
    13,442

    Re: Alt-SysRq-K is broken in QQ 12.10

    Have tried as Bazon posted & for the most part works here
    (haven't had a lock up to try on & in one test attempt didn't get back to login screen, just a black screen

    The default here is 176 -
    $ uname -a && cat /proc/sys/kernel/sysrq
    Linux doug-XPS-M1330 3.5.0-16-generic #25-Ubuntu SMP Fri Sep 28 22:31:15 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
    176

  7. #7
    Join Date
    Apr 2010
    Beans
    212

    Re: Alt-SysRq-K is broken in QQ 12.10

    It seems gnome3 refrains KBD from sending a XKB terminate signal to Xserver through terminate:ctrl_alt_bksp.

    But in the gnome-tweak-tool version 3.6.0-0ubuntu1~1 all, there is in the 'typing' tab a setting for 'terminate' action, click on the drop down list and u can find Ctrl + Alt + Bksp.

    I haven't tried it myself. Maybe later.

    Yeah, it works now. It seems gnome-tweak-tool is nicely making up for gnome3's xkb shortness
    Last edited by funicorn; October 3rd, 2012 at 06:00 PM.

  8. #8
    Join Date
    Nov 2007
    Location
    London, England
    Beans
    5,571
    Distro
    Xubuntu 14.10 Utopic Unicorn

    Re: Alt-SysRq-K is broken in QQ 12.10

    Solved.
    Sorry, mc4man. You were right. I was forgetting myself and trying it on a 12.04 machine.

    ON th e12.10 machine, /proc/sys/kernel/sysrq is indeed defaulted to 172, and setting it to 1 re-enables SysRq-K to kill the X server. Perfick.

  9. #9
    Join Date
    Jun 2007
    Beans
    13,442

    Re: Alt-SysRq-K is broken in QQ 12.10

    Quote Originally Posted by funicorn View Post
    It seems gnome3 refrains KBD from sending a XKB terminate signal to Xserver through terminate:ctrl_alt_bksp.

    But in the gnome-tweak-tool version 3.6.0-0ubuntu1~1 all, there is in the 'typing' tab a setting for 'terminate' action, click on the drop down list and u can find Ctrl + Alt + Bksp.

    I haven't tried it myself. Maybe later.

    Yeah, it works now. It seems gnome-tweak-tool is nicely making up for gnome3's xkb shortness
    If one wants to enable ctrl+alt+backspace it's avail. in system settings
    (keyboard > keyboard layout or keyboard layout directly > options ...

  10. #10
    Join Date
    Apr 2010
    Beans
    212

    Re: Alt-SysRq-K is broken in QQ 12.10

    No. keyboard layout setting is removed in gnome 3.60

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •