I'm now using 12.04. Thanks!