Results 1 to 6 of 6

Thread: server does not boot: I/O error; cciss TUR failed in CCISS_GETLUNINFO

  1. #1
    Join Date
    Nov 2004
    Beans
    560
    Distro
    Ubuntu 12.04 Precise Pangolin

    server does not boot: I/O error; cciss TUR failed in CCISS_GETLUNINFO

    hello

    i have a server with ubuntu precise installed. up to now it booted perfectly well but after the last upgrade it does not anymore.

    during the boot process i see error messages like

    Code:
    - end_request: I/O error, dev dm-0, sector 123456
    - Error: inappropriate ioctl for device
    - cciss TUR failed in CCISS_GETLUNINFO: inaproppriate ioctl for device
    the server boots and i see the login prompt. when i enter the username and hit 'return', i see several end_request error messages and get a fresh login prompt. i can not log in!

    the filesystem is ok; i can boot into the rescue mode without any problem.

    i also booted with a live system (i use FAI and can log in via ssh). i checked all the filesystems and they are ok.

    i saw a similar post but without any answer.

    any ideas how to fix this?

  2. #2
    Join Date
    Oct 2011
    Beans
    26

    Re: server does not boot: I/O error; cciss TUR failed in CCISS_GETLUNINFO

    What is the hardware specs? Are you using RAID?

  3. #3
    Join Date
    Nov 2004
    Beans
    560
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: server does not boot: I/O error; cciss TUR failed in CCISS_GETLUNINFO

    it's a hp blade system. i do not use any raid.

    (i can get you more details about the hardware; what are you interested in?)

  4. #4
    Join Date
    Nov 2004
    Beans
    560
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: server does not boot: I/O error; cciss TUR failed in CCISS_GETLUNINFO

    i just saw a new error message:
    Code:
    device-mapper: table: 252:0: multipath: error getting device
    does anyone know what that means? and more importantly: how i can fix it?

  5. #5
    Join Date
    Nov 2004
    Beans
    560
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: server does not boot: I/O error; cciss TUR failed in CCISS_GETLUNINFO

    ok, it was a multipath issue. i had to blacklist the local disks:
    Code:
    # /etc/multipath.conf
    
    blacklist {
    
        devnode "^sd[a-c]"
    
    }
    that did the trick.

  6. #6
    Join Date
    Oct 2011
    Beans
    26

    Re: server does not boot: I/O error; cciss TUR failed in CCISS_GETLUNINFO

    I hope you'll get better soon. interesting problem

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •