Quote Originally Posted by vasa1 View Post
When you click on the link that OP provided and then on the "backoffice button", there's this error message:
Sorry. You need a browser that supports XDK. Please use IE
Unfortunately, many sites in India are (still) IE-specific or don't render well with other browsers. In some cases, it's just a matter of spoofing the user-agent string but I didn't look into the matter. In other cases, spoofing doesn't work.

Market forces will teach them a lesson. It's a matter of time.

BTW, it's not uncommon to still encounter several Indian sites carrying the "This site works best with IE6". Yes, IE6.
I've seen that on U.S. sites as well, along with "requires Windows ME , Windows 2000, Netscape 4......" I have no idea when those sites were last revised.