Results 1 to 4 of 4

Thread: sdpif is muted on restart

  1. #1
    Join Date
    Dec 2008
    Beans
    25

    sdpif is muted on restart

    Hi

    Thanks to the help on this board I have been able to get sound out of HDMI from Mythbuntu 12.04. I'm wondering if anybody can help me keep my spdif unmuted on restart. After each restart, I have to open a terminal, run alsamixer, and unmute it again. It's not a big deal but its hard to teach the 2 year old how to do this. Is there a way around unmuting it each restart?

    Thanks again...

  2. #2
    Join Date
    Mar 2007
    Location
    Christchurch, NZ
    Beans
    3,239

    Re: sdpif is muted on restart

    Quote Originally Posted by tdcarlo View Post
    Hi

    Thanks to the help on this board I have been able to get sound out of HDMI from Mythbuntu 12.04. I'm wondering if anybody can help me keep my spdif unmuted on restart. After each restart, I have to open a terminal, run alsamixer, and unmute it again. It's not a big deal but its hard to teach the 2 year old how to do this. Is there a way around unmuting it each restart?

    Thanks again...
    don't restart?

    seriously, set them how you want them, then run

    Code:
    sudo alsactl store
    Should save the settings to be applied on restart.

    If for some reason that doesn't work, you could use alsactl to umute it in a script in /etc/rc.local, which gets run at the end of the startup sequence.

  3. #3
    Join Date
    Dec 2008
    Beans
    25

    Re: sdpif is muted on restart

    Thanks...that worked.

    I owe you a beer or something!

  4. #4
    Join Date
    Mar 2007
    Location
    Christchurch, NZ
    Beans
    3,239

    Re: sdpif is muted on restart

    I'll have one for you tonight.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •