Results 1 to 10 of 10

Thread: Alt+Print+k doesn't work anymore

  1. #1
    Join Date
    Mar 2006
    Location
    europe/germany
    Beans
    230
    Distro
    Ubuntu 12.04 Precise Pangolin

    Alt+Print+k doesn't work anymore

    Has anybody an idea how to make it work again?

  2. #2
    Join Date
    Jun 2007
    Beans
    13,101

    Re: Alt+Print+k doesn't work anymore

    Quote Originally Posted by Bazon View Post
    Has anybody an idea how to make it work again?
    Use a kernel where it's enabled ??

    Here just enable ctrl+alt+backspace in keyboard options for the occasional need..

  3. #3
    Join Date
    Mar 2006
    Location
    europe/germany
    Beans
    230
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Alt+Print+k doesn't work anymore

    This is really implemented in kernel level? Thanks, interesting to know.
    Does anyone know, why it has been disabled? I thought it was so much "cleaner" than just killing X by Ctrl+Alt+Backspace?

  4. #4
    Join Date
    Apr 2008
    Beans
    10,790

    Re: Alt+Print+k doesn't work anymore

    I've noticed a lot of the Alt+SysReq+whatever key sequences no longer work. REISUB used to be really cool way to try and save work if something crashed but we seem to be losing that option.

  5. #5
    Join Date
    Apr 2010
    Beans
    212

    Re: Alt+Print+k doesn't work anymore

    It can be enabled in the running level, i.e., tuning some value in /proc/sys/kernel/sysrq. The wierd thing is it's not by default disabled in my case.
    Quote Originally Posted by kansasnoob View Post
    I've noticed a lot of the Alt+SysReq+whatever key sequences no longer work. REISUB used to be really cool way to try and save work if something crashed but we seem to be losing that option.

  6. #6
    Join Date
    Mar 2006
    Location
    europe/germany
    Beans
    230
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Alt+Print+k doesn't work anymore

    OK, it works this way:

    check state:
    Code:
    cat /proc/sys/kernel/sysrq
    (echos 1 if activated)

    set on for this session:
    Code:
    echo 1 | sudo tee /proc/sys/kernel/sysrq
    set on permanently:
    in /etc/sysctl.conf add
    Code:
    kernel.sysrq = 1

  7. #7
    Join Date
    Apr 2010
    Beans
    212

    Re: Alt+Print+k doesn't work anymore

    It'd better to set here: 10-magic-sysrq.conf

    I checked and found it's set kernel.sysrq=176

    176= 128 + 32 +16

    Quote Originally Posted by Bazon View Post
    OK, it works this way:

    check state:
    Code:
    cat /proc/sys/kernel/sysrq
    (echos 1 if activated)

    set on for this session:
    Code:
    echo 1 | sudo tee /proc/sys/kernel/sysrq
    set on permanently:
    in /etc/sysctl.conf add
    Code:
    kernel.sysrq = 1

  8. #8
    Join Date
    Mar 2006
    Location
    europe/germany
    Beans
    230
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Alt+Print+k doesn't work anymore

    Quote Originally Posted by funicorn View Post
    It'd better to set here: 10-magic-sysrq.conf
    Interesting. But why?
    And do you mean /etc/sysctl.d/10-magic-sysrq.conf or do you propose to add it in the home directory (as leaving out the path implies.)

    Quote Originally Posted by funicorn View Post
    I checked and found it's set kernel.sysrq=176
    176= 128 + 32 +16
    Yes, it had the same value for me. But what does this value mean?
    At least I can say, if it is set to 1, Alt+Print+k works.

    This may be interesting as well:
    https://launchpad.net/ubuntu/+source...3.3.3-2ubuntu2

    Changelog

    procps (1:3.3.3-2ubuntu2) quantal; urgency=low

    * Add debian/sysctl.d/10-magic-sysrq.conf: disable the magic sysrq key
    by default, since it's not needed for the average system, and exposes
    security issues such as memory disclosure and killing arbitrary
    processes including the screen lock. (LP: #194676)
    -- Marc Deslauriers <marc.deslauriers@ubuntu.com> Thu, 21 Jun 2012 08:19:56 -0400

  9. #9
    Join Date
    Mar 2006
    Location
    europe/germany
    Beans
    230
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Alt+Print+k doesn't work anymore

    Ah, OK:
    /etc/sysctl.d/10-magic-sysrq.conf:
    # The magic SysRq key enables certain keyboard combinations to be
    # interpreted by the kernel to help with debugging. The kernel will respond
    # to these keys regardless of the current running applications.
    #
    # In general, the magic SysRq key is not needed for the average Ubuntu
    # system, and having it enabled by default can lead to security issues on
    # the console such as being able to dump memory or to kill arbitrary
    # processes including the running screen lock.
    #
    # Here is the list of possible values:
    # 0 - disable sysrq completely
    # 1 - enable all functions of sysrq
    # >1 - enable certain functions by adding up the following values:
    # 2 - enable control of console logging level
    # 4 - enable control of keyboard (SAK, unraw)
    # 8 - enable debugging dumps of processes etc.
    # 16 - enable sync command
    # 32 - enable remount read-only
    # 64 - enable signalling of processes (term, kill, oom-kill)
    # 128 - allow reboot/poweroff
    # 256 - allow nicing of all RT tasks
    #
    # For example, to enable both control of console logging level and
    # debugging dumps of processes: kernel.sysrq = 10
    #
    kernel.sysrq = 176
    so the default setting is:
    128 - allow reboot/poweroff
    16 - enable sync command
    32 - enable remount read-only

  10. #10
    Join Date
    Apr 2010
    Beans
    212

    Re: Alt+Print+k doesn't work anymore

    # Here is the list of possible values:
    # 0 - disable sysrq completely
    # 1 - enable all functions of sysrq
    # >1 - enable certain functions by adding up the following values:
    # 2 - enable control of console logging level
    # 4 - enable control of keyboard (SAK, unraw)
    # 8 - enable debugging dumps of processes etc.
    # 16 - enable sync command
    # 32 - enable remount read-only
    # 64 - enable signalling of processes (term, kill, oom-kill)
    # 128 - allow reboot/poweroff
    # 256 - allow nicing of all RT tasks
    #
    # For example, to enable both control of console logging level and
    # debugging dumps of processes: kernel.sysrq = 10

    I think it's clear enough. 176 means enable sync command, enable remount read-only and allow reboot/poweroff

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •