Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Initilazation failed after upgrading from 10.04 to 12.04

  1. #1
    Join Date
    Nov 2010
    Beans
    3

    Post Initilazation failed after upgrading from 10.04 to 12.04

    After upgrading and restarting system I get following message when Ubuntu is booting:
    Command line 'dbus-launch-autolaunch=a0fd8441ac91a7ec2ff97e394f185fab -- binary-syntax --close -stderr' exited with non-zero status 1: Autolaunch error: X11 initialization failed.
    udevd[401]:specified group 'colord' unknown

    After that message asks me would I like to skip mounting or manual mount for every partition.

  2. #2
    Join Date
    Nov 2010
    Beans
    3

    Re: Initilazation failed after upgrading from 10.04 to 12.04

    Does anyone know what is the problem?
    I tried changing /boot/grub/grub.cfg and /etc/default/grub
    (changed every "quiet splash" into "quiet text") but still get the same error massage.
    Is it problem with Plymouth or something else?

  3. #3
    Join Date
    Nov 2010
    Beans
    3

    Re: Initilazation failed after upgrading from 10.04 to 12.04

    Any solutions?

  4. #4
    Join Date
    Jun 2012
    Beans
    1

    Re: Initilazation failed after upgrading from 10.04 to 12.04

    I had the same problem. In my case Precise actually didn't install completely before asking to reboot after setup. After rebooting I saw old grub menu and no new kernel in it.
    May be you have another problem but anyway try to fix installation:
    1) Boot from Live CD
    2) Mount linux system partition (where your system installed) to /mnt:
    Code:
    sudo mount /dev/sdaX /mnt
    3) mount virtual filesystems:
    Code:
    for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
    4) chroot into the system device
    Code:
    sudo chroot /mnt
    5)
    Code:
    apt-get install -f
    Steps 1-4 I got from https://help.ubuntu.com/community/Grub2/Installing

  5. #5
    Join Date
    Jul 2012
    Beans
    1

    Re: Initilazation failed after upgrading from 10.04 to 12.04

    Hey there,

    I can confirm that this bug , which happend to me as well after i upgraded from 10.04 to 12.04.

    In my case i was not required to start a live CD. It was enough to choose M for manual recovery, remount the root filesystem, start the network interface and continue the installation using the follwing commands:

    mount -o remount,rw /

    ifconfig up eth0

    dhclient eth0

    apt-get install -f

    If more people run into this problem, we should submit a bug report - i think its a serious one - especially as it seams to happen for people that do LTS upgrades only...


    cheers,
    Sebastian

  6. #6
    Join Date
    Jun 2008
    Location
    France
    Beans
    14
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Initilazation failed after upgrading from 10.04 to 12.04

    Thank you Sebastian, your commands helped a lot. I had the same problem.

    Cheers.

  7. #7
    Join Date
    Feb 2009
    Beans
    14

    Re: Initilazation failed after upgrading from 10.04 to 12.04

    Hi all,

    I experienced the same problem during upgrading from 10.04 to 12.04.
    A long list of error messages occured during the upgrading process, which continued despite of this until a certain point when it stopped, messaging "Processing was halted because there were too many errors." Restarting the system was no longer possible, and the same error message about "...X11 initialisation failed.\n" as mentioned in the previous posts appeared. Thereafter the option "S" or "M" to deal with the unmounted disk appeared. However, the system was dead after this, so did not react on keyboard entries.

    Does anyone know how to solve this.

  8. #8
    Join Date
    Oct 2012
    Beans
    1

    Exclamation Re: Initilazation failed after upgrading from 10.04 to 12.04

    Just one comment:

    Not
    Code:
    ifconfig up eth0
    but
    Code:
    ifconfig eth0 up

  9. #9
    Join Date
    Oct 2008
    Beans
    44

    Re: Initilazation failed after upgrading from 10.04 to 12.04

    Kudos and thanks to sfeu & say42 for the helpful suggestions!

    This is a major bug! I frankly considered just wiping my whole HD after the event and installing Fedora. How come it's happening on a LTS?

    Anyway.

    I had some problems with the 'apt-get install -f', with libphonon1-dev not installing. I solved it by use of 'apt-get download <package>' and 'dpkg -i <package>' and when needed adding in '--force-all'. That way I got a machine that can boot again! Now I have a broken kde, but at least I can do a full backup before I re-install everything.

    I was at my wits end. Many thanks again to the participants of this thread.

  10. #10
    Join Date
    Apr 2006
    Beans
    5

    Re: Initilazation failed after upgrading from 10.04 to 12.04

    Thanks. Helped me.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •