Results 1 to 2 of 2

Thread: Anyone using ToupViewX with AmScope cameras?

  1. #1
    Join Date
    Jun 2008
    Beans
    44

    Anyone using ToupViewX with AmScope cameras?

    Has anyone successfully used ToupViewX with the Amscope cameras; specifically, the MU300 camera? Or, has anyone been able to get an Amscope camera to work under Ubuntu with any software?

  2. #2
    Join Date
    Dec 2012
    Beans
    1

    Re: Anyone using ToupViewX with AmScope cameras?

    Quote Originally Posted by twgray View Post
    Has anyone successfully used ToupViewX with the Amscope cameras; specifically, the MU300 camera? Or, has anyone been able to get an Amscope camera to work under Ubuntu with any software?
    I just got ToupViewX running with an MU130 on Ubuntu 10.04 LTS.

    My first attempt failed like so:
    $ sudo ./ToupViewX
    ./ToupViewX: error while loading shared libraries: libbz2.so.1: cannot open shared object file: No such file or directory
    And ldd confirmed:
    $ ldd ./ToupViewX
    linux-gate.so.1 => (0xf7716000)
    libbz2.so.1 => not found
    libXext.so.6 => /usr/lib32/libXext.so.6 (0xf76e0000)
    libX11.so.6 => /usr/lib32/libX11.so.6 (0xf75c3000)
    <snip>
    What I had in place was:
    $ cd /usr/lib32
    $ ls -l libbz*
    lrwxrwxrwx 1 root root 15 2011-12-28 17:51 libbz2.so.1.0 -> libbz2.so.1.0.4
    -rw-r--r-- 1 root root 70076 2011-12-12 17:40 libbz2.so.1.0.4
    So I added the missing symbolic link:
    $ sudo ln -s libbz2.so.1.0.4 libbz2.so.1
    After which ToupViewX ran fine.

    Too bad it's a really degenerate version of the Windows software. And too bad you need to run it with sudo. But you can shoot some nice stills and I think I prefer using it over an eyepiece.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •