Results 1 to 9 of 9

Thread: 12.04 how to (really) disable screensaver / screen blanker?

  1. #1
    Join Date
    Jun 2011
    Beans
    25

    [solved] 12.04 how to (really) disable screensaver / screen blanker?

    I'm on Ubuntu 12.04 and I can't seem to be able to disble the screen blanker. After maybe 5 minutes of inactivity, the screen blanks out and goes to power saving mode. I run awesome window manager and it happens there but also in Gnome Classic mode. (haven't tried unity but I imagine its there too)

    Things I've tried:

    disabling in gnome-control-center: 'Don't Suspend', Turn off screen Never
    gconftool-2 -s /apps/gnome-screensaver/idle_activation_enabled --type=bool false
    gconftool-2 -s /apps/gnome-power-manager/ac_sleep_display --type=int 0
    gconftool-2 -s /apps/gnome-power-manager/timeout/sleep_display_ac --type=int 0
    gnome-screensaver-command -d
    gsettings set org.gnome.desktop.screensaver idle-activation-enabled false
    gsettings set org.gnome.desktop.screensaver lock-enabled false
    xset s off
    xset s noblank
    setterm -blank 0 -powerdown 0

    I believe a work-around would be to install caffeine, but I'd rather find a solution without having to add third-party apt repos and install a daemon or whatever just to stop a screen blanker
    Last edited by bonuswhore; September 25th, 2012 at 06:05 PM.

  2. #2
    Join Date
    Jun 2011
    Beans
    25

    Re: 12.04 how to (really) disable screensaver / screen blanker?

    Option "BlankTime" "0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime" "0"

    added ^ to xorg.conf in ServerLayout and now I get no more screen blanking

  3. #3
    Join Date
    Jul 2012
    Location
    Illinois, USA
    Beans
    500
    Distro
    Ubuntu 12.04 Precise Pangolin

    Smile Re: 12.04 how to (really) disable screensaver / screen blanker?

    Perfect, this appeared to resolve my issue. Thanks!

    http://ubuntuforums.org/showthread.php?t=2098422
    Last edited by Kirk Schnable; December 26th, 2012 at 09:28 PM.

  4. #4
    Join Date
    Jan 2013
    Beans
    1

    Re: 12.04 how to (really) disable screensaver / screen blanker?

    Will this work in Ubuntu 12.10 also. Am I correct that I should create a file /etc/X11/xorg.conf and populate the file with the following code:

    Section "ServerFlags" Option "blanktime" "0" Option "standbytime" "0" Option "suspendtime" "0" Option "offtime" "0" EndSection
    Just want to make sure I'm doing this correctly.

    Many thanks.

  5. #5
    Join Date
    Sep 2009
    Location
    Cascadia
    Beans
    29
    Distro
    Ubuntu Studio 8.04 Hardy Heron

    Re: 12.04 how to (really) disable screensaver / screen blanker?

    Quote Originally Posted by blumcr View Post
    Will this work in Ubuntu 12.10 also. Am I correct that I should create a file /etc/X11/xorg.conf and populate the file with the following code:

    Section "ServerFlags" Option "blanktime" "0" Option "standbytime" "0" Option "suspendtime" "0" Option "offtime" "0" EndSection
    Just want to make sure I'm doing this correctly.

    Many thanks.
    There's a lot more on xorg.conf here, particularly in specific reference to doing exactly this:

    http://shallowsky.com/linux/x-screen-blanking.html

    Basically all these interfaces (unity, gnome, w/e) run atop basic xwindows. Sooner or later, you get down to x, and a lot of things can be set in xorg.conf as kind of a last resort. (This is how I got my multimonitor xinema setup working. Yes, it took that. But it works and is awesome.)

  6. #6
    Join Date
    Oct 2008
    Beans
    63

    Re: 12.04 how to (really) disable screensaver / screen blanker?

    I think the fix is to go to 'Brightness and Lock' in the 'system settings' and put 'Turn screen off' to 'never' and then turn 'Lock' to 'OFF'.

    This screen blanking Unix legacy has plagued me a lot over the years, so very happy to share it !

    No need to go into BASH and do things to the OS.

    Occam was right ! *LOL*

    : )))

    Tim
    Last edited by Tim036; April 27th, 2013 at 06:13 AM.

  7. #7

    Re: 12.04 how to (really) disable screensaver / screen blanker?

    My 12.04 with Gnome has no "System Settings" "Brightness and Lock" menu.
    Also, there is no "etc/X11/xorg.conf".

    arv@Workstation:/etc/X11$ ls
    app-defaults
    ja_JP.UTF-8 Xreset
    Xsession.options
    cursors
    rgb.txt
    Xreset.d
    Xwrapper.config
    default-display-manager
    X
    Xresources
    fonts
    xinit
    Xsession
    ja_JP.eucJP
    xkb
    Xsession.d

    arv@Workstation:/etc/X11$

    This seems to be a recurring problem for many users.
    There are several threads with this topic/question.
    Many of the replies look like good information, but apparently do not apply to the 12.04 release.
    We need a definitive answer that is specific to this release of Ubuntu, and maybe specific to each window manager.
    Thanks,
    Last edited by arvevans; June 14th, 2013 at 08:18 PM. Reason: fix typo's
    POSIX

  8. #8

    Re: 12.04 how to (really) disable screensaver / screen blanker?

    Gave up and upgraded to Ubuntu 13.04 release.
    Still the same problem. It seems that the old tool to prevent CRT screen-burn is still with us
    and apparently cannot be disabled, even thought we now use LCD screens which do hot
    have the screen-burn phenomena.
    POSIX

  9. #9
    Join Date
    Aug 2013
    Beans
    1

    Lightbulb Re: 12.04 how to (really) disable screensaver / screen blanker?

    Hacking X11 will work but, will require restarting the XSession for all. If you want to restart the machine? Just goto the BIOS and disable screen blanking under acpi settings.

    If you don't want to restart the machine you can accomplish the same thing by:

    Code:
    sudo chmod -x /etc/acpi/screenblank.sh
    sudo service acpid restart

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •