Results 1 to 4 of 4

Thread: For those experiencing lagging graphics with ATI cards.

  1. #1
    Join Date
    Jul 2012
    Beans
    172
    Distro
    Ubuntu 13.10 Saucy Salamander

    Exclamation For those experiencing lagging graphics with ATI cards.

    I recent Ubuntu update has caused a performance issue with my (and most likely many other's) ATI graphics card. This issue is only present with the proprietary drivers downloaded from ATI's site. To solve the problem, you must revert to the repository drivers until either Ubuntu or ATI Catalyst is updated.

    Here's how you do it:
    Code:
    sudo apt-get install fglrx fglrx-amdcccle
    
    sudo aticonfig --initial
    Then reboot and you're done.
    Last edited by sienile; September 27th, 2012 at 02:15 PM.

  2. #2
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: For those experiencing lagging graphics with ATI cards.

    Umm...

    That installs and initializes the proprietary ATI Catalyst driver available in the Ubuntu repo at the time of the version release. If you are using Precise, that would be the ATI 12.4 Catalyst driver.

    The Radeon driver is the open source one.
    Last edited by QIII; September 25th, 2012 at 05:09 AM.

  3. #3
    Join Date
    Feb 2010
    Location
    White Plume Mountain
    Beans
    8,222
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: For those experiencing lagging graphics with ATI cards.

    I've had the best experience by installing the latest driver for my card from ATI.
    Thank you for your contributions. "So long and thanks for the fish!"

  4. #4
    Join Date
    Jul 2012
    Beans
    172
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: For those experiencing lagging graphics with ATI cards.

    Didn't know those were proprietary drivers, I'll change the post.

    The drivers that I was referring to giving trouble were the ones downloaded from the ATI site. It may only affect some cards, such as my Radeon 2600 Pro. The update on the 23rd caused the lagging.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •