Page 5 of 5 FirstFirst ... 345
Results 41 to 46 of 46

Thread: Error message on screen due to monitor Ubuntu 12.04

  1. #41
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Error message on screen due to monitor Ubuntu 12.04

    I don't understand that. The Grub menu option should appear long before anything to do with the monitor has been loaded. Maybe it is keeping the settings from the previous boot?

    Try:
    1) Turning the computer (and monitor) off before rebooting and holding the shift key.
    2) Running the following command in a terminal:
    Code:
    sudo update-grub
    and then rebooting and holding the shift key.
    3) Continuously tap the shift key: http://ubuntuforums.org/showthread.php?p=11073718
    4) Use the installation CD, and at the very first screen, at the "boot:" prompt type "rescue" and next follow the instructions that are given.
    Last edited by Favux; September 25th, 2012 at 05:01 PM.

  2. #42
    Join Date
    Jun 2008
    Location
    Right behind you stalking
    Beans
    126
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Error message on screen due to monitor Ubuntu 12.04

    The first 3 didn't work.

    Do I really need to use that rescue command first?

    Or should I wait until Wim looks over the xorg.conf files and xrandr settings?

  3. #43
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Error message on screen due to monitor Ubuntu 12.04

    I think there is an option that shows up on the screen that'll do the same thing. Whatever.

    The point is you need to be able to access a root command line in order to restore your xorg.conf from backup or to edit it with the nano editor (nano /etc/X11/xorg.conf). Otherwise you can't experiment with modifying the xorg.conf because if you break X you are stuck again.

    And yes wait for Wim's thoughts. So while waiting for that figure out how to get to the command line.

  4. #44
    Join Date
    Jun 2008
    Location
    Right behind you stalking
    Beans
    126
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Error message on screen due to monitor Ubuntu 12.04

    Bump

  5. #45
    Join Date
    Jan 2005
    Location
    South Africa
    Beans
    2,098
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Error message on screen due to monitor Ubuntu 12.04

    There seem to be two problems; first one is that grub does not show a menu or a garbled screen; the second one is that you don't have the correct resolution in the graphical environment. Which resolution / refresh rate do you get by default?

    Can you post the contents of /var/log/Xorg.0.log (either using code tags or by attaching the file)? That will tell us which driver is actually used.

    Have you tried the 'nomodeset' option in grub's kernel line as I described earlier? That might solve the issue regarding the second point; maybe in combination with a proper xorg.conf.

    If 'nomodeset' does not give the required result, please provide Xorg.0.log for that situation as well.

    If there is an xorg.conf generated by nVidia, please post / attach as well.

    I don't have much time till the weekend, so any possible help will probably have to wait till then and it's a 'spouse permitting' situation
    If you don't make backups of your important data, your data is obviously not important to you.

  6. #46
    Join Date
    Jan 2005
    Location
    South Africa
    Beans
    2,098
    Distro
    Ubuntu 12.04 Precise Pangolin

    grub menu

    Edit /etc/default/grub (you need root permissions so use sudo or gksudo)

    There is a line like the red italic the line below. It has a number at the end (10 if I recall correctly); remove it so the line looks like the shown one.
    Code:
    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    The result of this change will be that you don't have to keep <shift> pressed while booting to get to the menu.

    The next change is to stop grub from using fancy stuff. Find the below line in red italic.
    Code:
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    And remove the '#' in the beginning.
    Code:
    # Uncomment to disable graphical terminal (grub-pc only)
    GRUB_TERMINAL=console
    Save the file and run sudo update-grub

    Code:
    wim@i3-2120:~$ sudo update-grub
    [sudo] password for wim: 
    Generating grub.cfg ...
    Found linux image: /boot/vmlinuz-3.2.0-31-generic
    Found initrd image: /boot/initrd.img-3.2.0-31-generic
    Found linux image: /boot/vmlinuz-3.2.0-30-generic
    Found initrd image: /boot/initrd.img-3.2.0-30-generic
    Found linux image: /boot/vmlinuz-3.2.0-29-generic
    Found initrd image: /boot/initrd.img-3.2.0-29-generic
    Found memtest86+ image: /boot/memtest86+.bin
    Found Windows 7 (loader) on /dev/sda1
    done
    wim@i3-2120:~$
    Next reboot your system and see if you get the grub menu. There should not be a reason to press any key for a normal boot.
    If you don't make backups of your important data, your data is obviously not important to you.

Page 5 of 5 FirstFirst ... 345

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •