Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Installation problem

  1. #1
    Join Date
    Feb 2012
    Beans
    63

    Installation problem

    When i try to install a package i get this error:
    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
     gnustep : Depends: systempreferences.app but it is not going to be installed
               Depends: gworkspace.app but it is not going to be installed
               Depends: terminal.app but it is not going to be installed
               Depends: preview.app but it is not going to be installed or
                        price.app but it is not going to be installed
               Depends: zipper.app but it is not going to be installed
               Depends: textedit.app but it is not going to be installed
               Depends: charmap.app but it is not going to be installed
               Recommends: gnumail.app but it is not going to be installed
               Recommends: talksoup.app but it is not going to be installed
               Recommends: viewpdf.app but it is not going to be installed
               Recommends: wmaker but it is not going to be installed
               Recommends: gnustep-icons but it is not going to be installed
               Recommends: gnustep-examples but it is not going to be installed
     nepenthes:i386 : Depends: libadns1:i386 (>= 1.4) but it is not going to be installed
                      Depends: libc6:i386 (>= 2.8) but it is not going to be installed
                      Depends: libcap2:i386 (>= 2.10) but it is not going to be installed
                      Depends: libcurl3-gnutls:i386 (>= 7.16.2-1) but it is not going to be installed
                      Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
                      Depends: libmagic1:i386 but it is not going to be installed
                      Depends: libpcap0.8:i386 (>= 0.9.8) but it is not going to be installed
                      Depends: libpcre3:i386 (>= 8.10) but it is not going to be installed
                      Depends: libstdc++6:i386 (>= 4.6) but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    What to do?

  2. #2
    Join Date
    Sep 2009
    Location
    Poland
    Beans
    110
    Distro
    Xubuntu 12.10 Quantal Quetzal

    Re: Installation problem

    Do u try
    Code:
     apt-get -f install
    ?
    Przemysław Suszek - Analityk IT, Tani nocleg zakopane
    AMD Athlon XP 2500+ | 2 GB DDR 400Mhz | NVidia GeForce 6800 GT | Barracuda 80GB 7200 rpm 8MB cache | LCD LG W2252S ~ 1680x1050

  3. #3
    Join Date
    Nov 2008
    Beans
    Hidden!

    Re: Installation problem

    apt-get -f install This command does the same thing as Edit->Fix Broken Packages in Synaptic. Do this if you get complaints about packages with "unmet dependences".

    more here on apt-get

    https://help.ubuntu.com/community/AptGet/Howto

  4. #4
    Join Date
    Feb 2012
    Beans
    63

    Re: Installation problem

    Code:
    root@ip-10-252-62-231:~# apt-get -f install
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... failed.
    The following packages have unmet dependencies:
     nepenthes:i386 : Depends: libadns1:i386 (>= 1.4) but it is not installed
                      Depends: libc6:i386 (>= 2.8) but it is not installed
                      Depends: libcap2:i386 (>= 2.10) but it is not installed
                      Depends: libcurl3-gnutls:i386 (>= 7.16.2-1) but it is not installed
                      Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
                      Depends: libmagic1:i386 but it is not installed
                      Depends: libpcap0.8:i386 (>= 0.9.8) but it is not installed
                      Depends: libpcre3:i386 (>= 8.10) but it is not installed
                      Depends: libstdc++6:i386 (>= 4.6) but it is not installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    E: Unable to correct dependencies
    And what now?

  5. #5
    Join Date
    Aug 2012
    Beans
    58

    Re: Installation problem

    Quote Originally Posted by AADAS View Post
    Code:
    root@ip-10-252-62-231:~# apt-get -f install
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... failed.
    The following packages have unmet dependencies:
     nepenthes:i386 : Depends: libadns1:i386 (>= 1.4) but it is not installed
                      Depends: libc6:i386 (>= 2.8) but it is not installed
                      Depends: libcap2:i386 (>= 2.10) but it is not installed
                      Depends: libcurl3-gnutls:i386 (>= 7.16.2-1) but it is not installed
                      Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
                      Depends: libmagic1:i386 but it is not installed
                      Depends: libpcap0.8:i386 (>= 0.9.8) but it is not installed
                      Depends: libpcre3:i386 (>= 8.10) but it is not installed
                      Depends: libstdc++6:i386 (>= 4.6) but it is not installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    E: Unable to correct dependencies
    And what now?

    I would apt-get each dependency see what happens?

  6. #6
    Join Date
    Nov 2008
    Beans
    Hidden!

    Re: Installation problem

    Do you have your "universal sources" enabled?

    If you are not sure, please post the the output of:

    gedit /etc/apt/sources.list

  7. #7
    Join Date
    Feb 2012
    Beans
    63

    Re: Installation problem

    Note, this file is written by cloud-init on first boot of an instance
    ## modifications made here will not survive a re-bundle.
    ## if you wish to make changes you can:
    ## a.) add 'apt_preserve_sources_list: true' to /etc/cloud/cloud.cfg
    ## or do the same in user-data
    ## b.) add sources in /etc/apt/sources.list.d
    ## c.) make changes to template file /etc/cloud/templates/sources.list.tmpl
    #

    # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
    # newer versions of the distribution.
    deb http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ precise main
    deb-src http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ precise main

    ## Major bug fix updates produced after the final release of the
    ## distribution.
    deb http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ precise-updates main
    deb-src http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ precise-updates main

    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team. Also, please note that software in universe WILL NOT receive any
    ## review or updates from the Ubuntu security team.
    deb http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ precise universe
    deb-src http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ precise universe
    deb http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ precise-updates universe
    deb-src http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ precise-updates universe

    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team, and may not be under a free licence. Please satisfy yourself as to
    ## your rights to use the software. Also, please note that software in
    ## multiverse WILL NOT receive any review or updates from the Ubuntu
    ## security team.
    # deb http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ precise multiverse
    # deb-src http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ precise multiverse
    # deb http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ precise-updates multiverse
    # deb-src http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ precise-updates multiverse

    ## Uncomment the following two lines to add software from the 'backports'
    ## repository.
    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Ubuntu security team.
    # deb http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
    # deb-src http://us-west-2.ec2.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse

    ## Uncomment the following two lines to add software from Canonical's
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    # deb http://archive.canonical.com/ubuntu precise partner
    # deb-src http://archive.canonical.com/ubuntu precise partner

    deb http://security.ubuntu.com/ubuntu precise-security main
    deb-src http://security.ubuntu.com/ubuntu precise-security main
    deb http://security.ubuntu.com/ubuntu precise-security universe
    deb-src http://security.ubuntu.com/ubuntu precise-security universe
    # deb http://security.ubuntu.com/ubuntu precise-security multiverse
    # deb-src http://security.ubuntu.com/ubuntu precise-security multiverse

  8. #8
    Join Date
    Sep 2012
    Location
    Virginia, USA
    Beans
    209
    Distro
    Ubuntu Development Release

    Re: Installation problem

    These are my "go to" steps if I encounter dependency issues/broken packages, so you might try them.

    First, try:

    Code:
    sudo dpkg --configure -a
    sudo apt-get install -f
    If that still doesn't fix the issue, try clearing APT's cache, updating your repo data, and then running the above commands again, like so:

    Code:
    sudo apt-get autoremove
    sudo apt-get autoclean
    sudo apt-get clean
    sudo apt-get update
    sudo dpkg --configure -a
    sudo apt-get install -f
    sudo apt-get dist-upgrade
    If that doesn't fix it, then answering some of the other things requested of you in this thread may help. For example, can we see your /etc/apt/sources.list file? (EDIT: Sorry, posted at the same time that you posted sources.list above; will check it now, but still try the commands listed here.)

  9. #9
    Join Date
    Feb 2012
    Beans
    63

    Re: Installation problem

    ubuntu@ip-10-252-62-231:~$ sudo apt-get autoremove
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these.
    The following packages have unmet dependencies:
    nepenthes:i386 : Depends: libadns1:i386 (>= 1.4) but it is not installed
    Depends: libc6:i386 (>= 2.8) but it is not installed
    Depends: libcap2:i386 (>= 2.10) but it is not installed
    Depends: libcurl3-gnutls:i386 (>= 7.16.2-1) but it is not installed
    Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
    Depends: libmagic1:i386 but it is not installed
    Depends: libpcap0.8:i386 (>= 0.9.8) but it is not installed
    Depends: libpcre3:i386 (>= 8.10) but it is not installed
    Depends: libstdc++6:i386 (>= 4.6) but it is not installed
    E: Unmet dependencies. Try using -f.

  10. #10
    Join Date
    Sep 2012
    Location
    Virginia, USA
    Beans
    209
    Distro
    Ubuntu Development Release

    Re: Installation problem

    Quote Originally Posted by AADAS View Post
    ubuntu@ip-10-252-62-231:~$ sudo apt-get autoremove
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these.
    The following packages have unmet dependencies:
    nepenthes:i386 : Depends: libadns1:i386 (>= 1.4) but it is not installed
    Depends: libc6:i386 (>= 2.8) but it is not installed
    Depends: libcap2:i386 (>= 2.10) but it is not installed
    Depends: libcurl3-gnutls:i386 (>= 7.16.2-1) but it is not installed
    Depends: libgcc1:i386 (>= 1:4.1.1) but it is not installed
    Depends: libmagic1:i386 but it is not installed
    Depends: libpcap0.8:i386 (>= 0.9.8) but it is not installed
    Depends: libpcre3:i386 (>= 8.10) but it is not installed
    Depends: libstdc++6:i386 (>= 4.6) but it is not installed
    E: Unmet dependencies. Try using -f.
    You can safely skip that step, then. Try the rest.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •