Results 1 to 7 of 7

Thread: Getting poor perfomance in 12.04

  1. #1
    Join Date
    Sep 2012
    Beans
    4

    Getting poor perfomance in 12.04

    I am getting really poor performance while using Ubuntu 12.04 even though i have the latest drivers installed and can run fedora 16 without a hitch. The launcher takes 15 - 30 seconds to respond, switching between workspaces provides poor framerates, basic applications jitter a lot etc.

    I am unable to discern the cause for this.

    My config is:

    Biostar T5XE motherboard
    Intel Core i7 860
    AMD Radeon HD 5770
    4GB ram.

  2. #2
    Join Date
    Jan 2009
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Getting poor perfomance in 12.04

    Have you tried using Unity 2D? You can pick that when logging in, by clicking the gear over your username.

  3. #3
    Join Date
    Sep 2012
    Beans
    4

    Re: Getting poor perfomance in 12.04

    Most apps(Eclipse, Rhythmbox, Ninja-IDE, firefox etc) don't perform well in gnome classic either.

    If it helps, I am unable to run gnome 3 on Ubuntu although it runs on fedora.
    Last edited by dead5; September 20th, 2012 at 12:08 PM.

  4. #4
    Join Date
    Feb 2012
    Location
    el_GR
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Getting poor perfomance in 12.04

    Hi ,
    is this a regular installation or wubi ? (from inside windows)

    I can imagine two things . First the installation went wrong , or something with graphics driver went wrong.
    But you must provide more info.

    Code:
    lspci -nnk | grep -iA2 vga
    Run boot-repair and give here the pastebin link . https://help.ubuntu.com/community/Boot-Repair
    second option from a liveCD/Usb.

    also
    Code:
    dpkg -l | grep fglrx
    would be helpful .

    and
    Code:
    env|grep DESK
    Thanks

  5. #5
    Join Date
    Sep 2012
    Beans
    4

    Re: Getting poor perfomance in 12.04

    I am running a regular installation of Ubuntu.

    lspci -nnk | grep -iA2 vga gives
    Code:
    01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Juniper [Radeon HD 5700 Series] [1002:68b8]
        Subsystem: PC Partner Limited Device [174b:1482]
        Kernel driver in use: radeon
    dpkg -l | grep fglrx does nothing.

    env|grep desk gives
    Code:
    DESKTOP_SESSION=ubuntu
    GNOME_DESKTOP_SESSION_ID=this-is-deprecated
    XDG_CURRENT_DESKTOP=Unity

  6. #6
    Join Date
    Feb 2012
    Location
    el_GR
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Getting poor perfomance in 12.04

    Quote Originally Posted by dead5 View Post
    I am getting really poor performance while using Ubuntu 12.04 even though i have the latest drivers installed
    Quote Originally Posted by dead5 View Post
    lspci -nnk | grep -iA2 vga gives
    Code:
    01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Juniper [Radeon HD 5700 Series] [1002:68b8]
        Subsystem: PC Partner Limited Device [174b:1482]
        Kernel driver in use: radeon
    Hi ,
    If you had the latest drivers installed , the section in bold should be like this
    Code:
    Kernel driver in use: fglrx_pci
    Try to install the AMD's driver . First try from additional drivers (jockey-gtk , from terminal). And try to activate (install) the normal fglrx driver . Not this with updates.

    Thanks

  7. #7
    Join Date
    Sep 2012
    Beans
    4

    Re: Getting poor perfomance in 12.04

    Thanks man. It worked.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •