Page 3 of 10 FirstFirst 12345 ... LastLast
Results 21 to 30 of 93

Thread: vdpau black screen (monitor off) in mythTV

  1. #21
    Join Date
    Jun 2008
    Beans
    647

    Re: vdpau black screen (monitor off) in mythTV

    The strange gui fuzzy-ness is gone (whatever that was) and I'm at driver 270 rather than 3xx. But I just can't get vdpau to work.

  2. #22
    Join Date
    Mar 2007
    Location
    Christchurch, NZ
    Beans
    3,239

    Re: vdpau black screen (monitor off) in mythTV

    Quote Originally Posted by davidstoll View Post
    The strange gui fuzzy-ness is gone (whatever that was) and I'm at driver 270 rather than 3xx. But I just can't get vdpau to work.
    Have you tried another player, eg mplayer, with vdpau to see what happens?

  3. #23
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: vdpau black screen (monitor off) in mythTV

    Looking at post #3 or #4

    The OP does not look to have the libvdpau installed.
    The vdpau library is not part of the nvidia driver package since 2009.

    Makes sense to install vdpauinfo (as well).
    Run "vdpauinfo" in a terminal before & after installing libvdpau1.

  4. #24
    Join Date
    Mar 2007
    Location
    Christchurch, NZ
    Beans
    3,239

    Re: vdpau black screen (monitor off) in mythTV

    Quote Originally Posted by BicyclerBoy View Post
    Looking at post #3 or #4

    The OP does not look to have the libvdpau installed.
    what makes you say that? The package is NOT nividia-libvdpau, it is libvdpau1. The output in post #4 will not show libvdpau.

    But worth checking nonetheless.

  5. #25
    Join Date
    Jun 2008
    Beans
    647

    Re: vdpau black screen (monitor off) in mythTV

    Quote Originally Posted by BicyclerBoy View Post
    Looking at post #3 or #4

    The OP does not look to have the libvdpau installed.
    The vdpau library is not part of the nvidia driver package since 2009.

    Makes sense to install vdpauinfo (as well).
    Run "vdpauinfo" in a terminal before & after installing libvdpau1.
    before:
    Code:
    $ vdpauinfo 
    display: :0.0   screen: 0
    API version: 1
    Information string: NVIDIA VDPAU Driver Shared Library  270.41.06  Mon Apr 18 15:14:35 PDT 2011
    
    Video surface:
    
    name   width height types
    -------------------------------------------
    420     4096  4096  NV12 YV12 
    422     4096  4096  UYVY YUYV 
    
    Decoder capabilities:
    
    name               level macbs width height
    -------------------------------------------
    MPEG1                 0  8192  2048  2048
    MPEG2_SIMPLE          3  8192  2048  2048
    MPEG2_MAIN            3  8192  2048  2048
    H264_MAIN            41  8190  2032  2048
    H264_HIGH            41  8190  2032  2048
    VC1_SIMPLE            1  8190  2048  2048
    VC1_MAIN              2  8190  2048  2048
    VC1_ADVANCED          4  8190  2048  2048
    
    Output surface:
    
    name              width height nat types
    ----------------------------------------------------
    B8G8R8A8          8192  8192    y  Y8U8V8A8 V8U8Y8A8 
    R10G10B10A2       8192  8192    y  Y8U8V8A8 V8U8Y8A8 
    
    Bitmap surface:
    
    name              width height
    ------------------------------
    B8G8R8A8          8192  8192
    R8G8B8A8          8192  8192
    R10G10B10A2       8192  8192
    B10G10R10A2       8192  8192
    A8                8192  8192
    
    Video mixer:
    
    feature name                    sup
    ------------------------------------
    DEINTERLACE_TEMPORAL             y
    DEINTERLACE_TEMPORAL_SPATIAL     y
    INVERSE_TELECINE                 y
    NOISE_REDUCTION                  y
    SHARPNESS                        y
    LUMA_KEY                         y
    HIGH QUALITY SCALING - L1        -
    HIGH QUALITY SCALING - L2        -
    HIGH QUALITY SCALING - L3        -
    HIGH QUALITY SCALING - L4        -
    HIGH QUALITY SCALING - L5        -
    HIGH QUALITY SCALING - L6        -
    HIGH QUALITY SCALING - L7        -
    HIGH QUALITY SCALING - L8        -
    HIGH QUALITY SCALING - L9        -
    
    parameter name                  sup      min      max
    -----------------------------------------------------
    VIDEO_SURFACE_WIDTH              y         1     4096
    VIDEO_SURFACE_HEIGHT             y         1     4096
    CHROMA_TYPE                      y  
    LAYERS                           y         0        4
    
    attribute name                  sup      min      max
    -----------------------------------------------------
    BACKGROUND_COLOR                 y  
    CSC_MATRIX                       y  
    NOISE_REDUCTION_LEVEL            y      0.00     1.00
    SHARPNESS_LEVEL                  y     -1.00     1.00
    LUMA_KEY_MIN_LUMA                y  
    LUMA_KEY_MAX_LUMA                y

  6. #26
    Join Date
    Jun 2008
    Beans
    647

    Re: vdpau black screen (monitor off) in mythTV

    Code:
    $ sudo apt-get install libvdpau1 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    libvdpau1 is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

  7. #27
    Join Date
    Mar 2007
    Location
    Christchurch, NZ
    Beans
    3,239

    Re: vdpau black screen (monitor off) in mythTV

    I posted on the mailing list re this problem and got this suggestion
    Review the xorg.conf of both the good and bad atom machines. The bad one may be pushing the TV beyond it's limits for refresh rate or resolution.

  8. #28
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: vdpau black screen (monitor off) in mythTV

    Nick's right, post #3 did not show libvdpau1..

    Weren't the revo/ion boxes very picky about the RAM configuration/type?
    Can you change the RAM split between system & GPU ?

    Could download/compile "qvdpautest"
    https://github.com/robertmassaioli/qvdpautest
    But a vdpau decode failure would show in the MythTV logs..

    So it's probably the display's reported EDID..

    If you think the video mode needs investigating then set
    Option "ModeDebug" "True"
    in /etc/X11/xorg.conf..logout/login.

    Try different HDMI jack on TV (limited reliable specs on your TV on web).
    I know you are using DVI/HDMI..
    FYI The VGA jack supports 1080p only at 60Hz (59.9) reduced v blank timing.
    There are no 50Hz modes stated as supported over VGA.
    Last edited by BicyclerBoy; September 29th, 2012 at 02:13 AM.

  9. #29
    Join Date
    Jun 2008
    Beans
    647

    Re: vdpau black screen (monitor off) in mythTV

    I copied the xorg.conf from the frontend with vdpau working, but it didn't seem to help. It's quite a minimal file and I'm not sure why.

    xorg from frontend with vdpau not working:
    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 270.41.06  (buildmeister@swio-display-x86-rhel47-07.nvidia.com)  Mon Apr 18 15:15:12 PDT 2011
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0"
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Unknown"
        HorizSync       28.0 - 33.0
        VertRefresh     43.0 - 72.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection

    xorg from frontend with vdpau working:
    Code:
    Section "Screen"
    	Identifier	"Default Screen"
    	DefaultDepth	24
    EndSection
    
    Section "Device"
    	Identifier	"Default Device"
    	Driver	"nvidia"
    	Option	"DPI"	"100x100"
    	Option	"NoLogo"	"1"
    EndSection

  10. #30
    Join Date
    Jun 2008
    Beans
    647

    Re: vdpau black screen (monitor off) in mythTV

    I also tried another HDMI input.

Page 3 of 10 FirstFirst 12345 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •