Results 1 to 8 of 8

Thread: Wi-fi cannot be turned off

  1. #1
    Join Date
    Sep 2012
    Beans
    21

    Wi-fi cannot be turned off

    Hi,

    My inbuilt wireles is always on. I don't use it, I would like to turn it off. However, pressing the hardware wi-fi button doesn't do anything. The connection doesn't show in the
    'Network Connections' menu.

    It shows in the 'Network tools' app. The status is 'enabled'. When I open the 'Configure' option, it takes me to the 'Network Connection' app, and the wireless is not listed there, so I cannot configure it.

    I just want to turn it off permanently, I never use the inbuilt wireless, I just use the USB wireless connection.


    02:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
    Last edited by yogyakor; September 12th, 2012 at 03:35 AM.

  2. #2
    Join Date
    Apr 2012
    Beans
    5,968

    Re: Wireless connection cannot be turned off

    This has worked for me (assuming you are managing your interfaces via NetworkManager)

    1. find the MAC address of the card you want to disable, e.g. using

    Code:
    lshw -C
    (the MAC is listed as 'serial')

    2. edit /etc/NetworkManager/NetworkManager.conf, appending

    Code:
    [keyfile]
    unmanaged-devices=mac:xx:xx:xx:xx:xx:xx
    where xx:xx:xx:xx:xx:xx is the MAC (serial) from above

    3. restart the NetworkManager service

    Code:
    sudo service network-manager restart
    This should hard block the device i.e.

    Code:
    $ rfkill list all
    0: tpacpi_bluetooth_sw: Bluetooth
            Soft blocked: no
            Hard blocked: no
    1: phy0: Wireless LAN
            Soft blocked: no
            Hard blocked: yes
    14: hci0: Bluetooth
            Soft blocked: no
            Hard blocked: no

  3. #3
    Join Date
    Sep 2012
    Beans
    21

    Re: Wi-fi cannot be turned off

    For some reason

    lshw -C

    just brings a manual for lshw in my terminal. However I got the serial number from
    'Network tools' app and proceeded with your instructions.
    Worked like a charm!

    Thanks a lot, I really appreciate that.

  4. #4
    Join Date
    Apr 2012
    Beans
    5,968

    Re: Wi-fi cannot be turned off

    doh! I'm sorry, that should have been

    Code:
    lshw -C network
    Anyhow glad you figured it out

  5. #5
    Join Date
    Sep 2012
    Beans
    21

    Re: Wi-fi cannot be turned off

    Oh wait....

    After coming back from sleep my wi-fi button is still blue.

    However,

    ~$ rfkill list all
    0: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes
    1: hp-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: yes


    If I type ~$ lshw -C network

    I get the message that wi-fi is *Network disabled.

    So why is it still blue? The physical button is OK, I dual boot with another version of Linux and
    it shows orange when it's turned off.

    If I use the 'Network tools' app it shows ethernet as enabled. Any idea what's going on?
    Last edited by yogyakor; September 12th, 2012 at 05:17 AM.

  6. #6
    Join Date
    Sep 2012
    Beans
    21

    Re: Wi-fi cannot be turned off

    And after a system reboot it's off again ... Don't know whether I'm coming or going.
    I guess it OTT.

    It's disabled after boot but gets magically enabled every time after suspend.
    Last edited by yogyakor; September 12th, 2012 at 10:07 AM.

  7. #7
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    21,285
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Wi-fi cannot be turned off

    I suggest you blacklist its driver. Find out with:
    Code:
    sudo lshw -C network
    I believe yours is ath9k. If you confirm it is, do:
    Code:
    sudo su
    echo "blacklist ath9k" >> /etc/modprobe.d/blacklist.conf
    modprobe -r ath9k
    exit
    It should now be well and truly deceased.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  8. #8
    Join Date
    Sep 2012
    Beans
    21

    Re: Wi-fi cannot be turned off

    Going, going, gone.
    RIP ath9k.

    Thank you so much for your help.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •