Results 1 to 8 of 8

Thread: interfering processes

  1. #1
    Join Date
    Mar 2009
    Beans
    Hidden!

    interfering processes

    I am running an application which is very timing sensitive, and which has to be ran for quite a time just for precise [average] values to be determined.

    But, as I am aware of, there are interfering processes here and there in the background, which jobs are to enrich the experience of the user -- such as update notifications (happens once a day), backup-management reminders (happens once in a while), and screen-locking automatisms (default is set to 10 minutes).

    The question I am asking is, is there any practical way to "stop time," so as to speak, and make every such processes go to sleep? gnome-system-monitor reports CPU-usage fluctuations due to various factors. There is also Compiz for which the monitor seems to report background activities.

    Would there be a viable way for any such interfering process to be terminated? Ubuntu is really the OS of choice, and one would be sad moving to another distro as a solution -- as the real solution is to be located within the Ubuntu realm -- especially because one is such a Linux layman. In short, any solution piece, however strange, is more than welcomed, and I hope more than one can benefit from such a thread.

  2. #2
    Join Date
    Sep 2012
    Location
    Denver,Colorado
    Beans
    243
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: interfering processes

    Does your program have to run from a GUI? if not switch over to TTY1 ( ctrl+alt+f1 ) login to the console then type

    ps -A | grep gdm

    get the pid number xxxx

    then

    sudo kill -9 pid

    that should stop X and everything running from TTY7 then if it's possible just run your program from the TTY1 Console unless of course it's a GUI program then you could disable the services from gnome-startup-manager or something like that
    + Linux Mint 13 Cinnamon 64bit +
    Lubuntu 12.04 PPC 32bit G4 | Ubuntu 12.04 PPC 64bit G5

  3. #3
    Join Date
    Nov 2007
    Location
    London, England
    Beans
    5,519
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: interfering processes

    As Epodx64 says, our best bet (if possible) is to kill off the GUI and run from a tty console.

    In recent versions of Ubuntu the desktop manager is lightdm rather than gdm, and the command sudo service lightdm stop should stop it and drop you to a tty console.

    Also, you can run a task at a higher priority by running it with a reduced "niceness". This will give it more priority over CPU usage than other tasks, but it won't completely lock out other tasks, and may still be subject to pauses waiting for occasional disk I/O.

  4. #4
    Join Date
    Mar 2009
    Beans
    Hidden!

    Re: interfering processes

    Thanks for the answers.

    Unfortunately, the program seems to require a GUI to run, and segfaults if ran without lightdm or such.

    One might have more success trying the pointed-to way of managing startup elements, though "session and startup," available from the software centre, and tweaking from the "application autostart" tab.

    Then, the included "power statistics" application can display relevant info about processor-wakeup calls, which may be useful for diagnosis.

    On the whole, I believe this is a viable approach. If nobody else tries to disable every item listed on that tab before I do, I might try on quantal and report back, hopefully from the same computer if I am able to revert changes thereafter.

  5. #5
    Join Date
    Mar 2009
    Beans
    Hidden!

    Re: interfering processes

    It has happened to me that the "session and startup" application I had downloaded is designed to work with the Xfce desktop environment. Therefore, the solution might lie in using Xubuntu or Lubuntu instead of Ubuntu.

    For example, Lubuntu is quite lightweight and I have read one can manage startup element and monitor resources through the following: bum & lxtask;

    This looks as a viable approach to going real light. :)
    Last edited by twipley; September 8th, 2012 at 11:31 PM.

  6. #6
    Join Date
    Apr 2009
    Location
    Germany
    Beans
    2,134
    Distro
    Ubuntu Development Release

    Re: interfering processes

    depending on the required precision you have to install a realtime kernel for this task:
    http://en.wikipedia.org/wiki/Real-time_operating_system

    the default kernel shipped with ubuntu is not suitable for such a task as its scheduling methods and other stuff it does is non-deterministic and depends on the current state of the machine.

    the linux realtime patches are here:
    http://www.kernel.org/pub/linux/kernel/projects/rt/
    Last edited by MadCow108; September 8th, 2012 at 08:12 PM.

  7. #7
    Join Date
    Mar 2009
    Beans
    Hidden!

    Re: interfering processes

    Quote Originally Posted by MadCow108 View Post
    for such a task you have to install a realtime kernel
    http://en.wikipedia.org/wiki/Real-time_operating_system

    the default kernel shipped with ubuntu is not suitable for such a task as its scheduling methods and other stuff it does is non-deterministic and depends on the current state of the machine.
    that's nice info.

    edit: (lubuntu might be tried.) -- as it seems best suited for the task at hand;
    Last edited by twipley; September 9th, 2012 at 03:53 PM.

  8. #8
    Join Date
    Mar 2009
    Beans
    Hidden!

    Re: interfering processes

    Quote Originally Posted by twipley View Post
    there are interfering processes here and there in the background, which jobs are to enrich the experience of the user -- such as update notifications (happens once a day), backup-management reminders (happens once in a while), and screen-locking automatisms (default is set to 10 minutes).
    found the solution to disabling interfering processes -- marking thread as solved:

    Quote Originally Posted by kgarbutt View Post
    Cut & paste this into the terminal:

    sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/*.desktop

    After this, then reopen 'Startup Applications' and all will be good.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •