Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: uStudio 12.04 64 bit on Lenovo L420

  1. #1
    Join Date
    Jan 2008
    Beans
    147
    Distro
    Ubuntu Studio 12.10 Quantal Quetzal

    Exclamation uStudio 12.04 64 bit on Lenovo L420

    I recently installed Ubuntu Studio 12.04 64 bit on my laptop, installed all the updates, and started using it for basic stuff prior to using it for media production. Several issues have presented themselves, and I don't know what to do to proceed. Additional note: some of the problems mentioned below also happened when I tried to install regular Ubuntu 12.04 64bit.

    Sometimes when starting up, the boot hangs on the Ubuntu loading screen, never gets to the login screen.

    While using the computer, I have had several instances in which the computer completely freezes up. No keyboard or mouse input, including trying to switch to a TTY session (ctrl shift F1-6). I haven't tried it recently, but I think one time it locked up, I tried to connect to it via SSH, and it wouldn't respond.

    I cannot put the computer to sleep. Or more accurately, I can put it to sleep, but upon trying to wake it up, the speakers pop and the system restarts.

    When I try to restart the system, sometimes it will hang then, too. For instance, after I installed the updates, Ubuntu requested I restart the computer. I had to hard reboot it, because it got stuck.

    I very much miss Ubuntu/Linux, and I suspect Lenovo is to blame for a lot of my problems in the past year or so, but until I can get things stable, I can't use it.
    Ubuntu 14.04 LTS, Gnome3, ck-designed desktop
    (ASRock Z77 Extreme4 MB / 3.4GHz Intel i7-3770 / 16GB G.Skill RAM / Intel HD 4000)
    Ubuntu 14.04 LTS, Gnome3, Sony Vaio SVS151190X notebook
    (2.5GHz Intel i5-3210M / 6GB RAM / Intel HD 4000)

  2. #2
    Join Date
    Aug 2012
    Location
    Hong Kong
    Beans
    160
    Distro
    Ubuntu Development Release

    Re: uStudio 12.04 64 bit on Lenovo L420

    Quote Originally Posted by Ck.asdf View Post
    I recently installed Ubuntu Studio 12.04 64 bit on my laptop, installed all the updates, and started using it for basic stuff prior to using it for media production. Several issues have presented themselves, and I don't know what to do to proceed. Additional note: some of the problems mentioned below also happened when I tried to install regular Ubuntu 12.04 64bit.

    Sometimes when starting up, the boot hangs on the Ubuntu loading screen, never gets to the login screen.

    While using the computer, I have had several instances in which the computer completely freezes up. No keyboard or mouse input, including trying to switch to a TTY session (ctrl shift F1-6). I haven't tried it recently, but I think one time it locked up, I tried to connect to it via SSH, and it wouldn't respond.

    I cannot put the computer to sleep. Or more accurately, I can put it to sleep, but upon trying to wake it up, the speakers pop and the system restarts.

    When I try to restart the system, sometimes it will hang then, too. For instance, after I installed the updates, Ubuntu requested I restart the computer. I had to hard reboot it, because it got stuck.

    I very much miss Ubuntu/Linux, and I suspect Lenovo is to blame for a lot of my problems in the past year or so, but until I can get things stable, I can't use it.
    OK, wait, you can't just blame Lenovo for that.

    I think maybe your installation is corrupted. Or maybe even your installation media IS corrupted. Don't forget to verify the MD5 checksum of the ISO image. Use unetbootin to burn the image to your USB. Then install it again and see if it still has these problems.

    Also, you DID use the 12.04.1 images didn't you? Don't use the old 12.04 one.

    If then there is still the problem maybe it then WILL be Lenovo to blame for the hardware.

    Regards,
    Howard Chan
    Ubuntu Studio Team Member (Testing, documentation and support)
    As the Ubuntu Studio release manager and a Kubuntu developer, I do a lot of ISO testing and packaging.
    Make Ubuntu 13.10 awesome~!

  3. #3
    Join Date
    Jan 2008
    Beans
    147
    Distro
    Ubuntu Studio 12.10 Quantal Quetzal

    Re: uStudio 12.04 64 bit on Lenovo L420

    I appreciate the prompt response.

    I checked the MD5 checksum of the ISO against the checksum listed online, and used LinuxLive to copy the image to my flash drive.

    The problems happened with Ubuntu 12.04 standard as well as with Ubuntu Studio, and obviously they share a lot of the same core system stuff, so having many of the same issues seems to point to issues with Ubuntu 12.04 [all variants] correctly interfacing with my hardware.

    As to which image I used, not quite sure, I grabbed it from the main site. Reviewing my downloads folder, it appears neither the standard or studio versions include ".1" in the version.
    By installing all the updates, should that take care of it, or should I re-install by using the updated iso?
    Ubuntu 14.04 LTS, Gnome3, ck-designed desktop
    (ASRock Z77 Extreme4 MB / 3.4GHz Intel i7-3770 / 16GB G.Skill RAM / Intel HD 4000)
    Ubuntu 14.04 LTS, Gnome3, Sony Vaio SVS151190X notebook
    (2.5GHz Intel i5-3210M / 6GB RAM / Intel HD 4000)

  4. #4
    Join Date
    Jun 2008
    Beans
    1,175
    Distro
    Ubuntu Studio

    Re: uStudio 12.04 64 bit on Lenovo L420

    Quote Originally Posted by Ck.asdf View Post
    The problems happened with Ubuntu 12.04 standard as well as with Ubuntu Studio, and obviously they share a lot of the same core system stuff
    Ubuntu studio is ubuntu. There are no differences on system level, only on software selection (including the DE).
    Quote Originally Posted by Ck.asdf View Post
    By installing all the updates, should that take care of it,
    I agree on that.

  5. #5
    Join Date
    Aug 2012
    Location
    Hong Kong
    Beans
    160
    Distro
    Ubuntu Development Release

    Re: uStudio 12.04 64 bit on Lenovo L420

    Quote Originally Posted by jejeman View Post
    Ubuntu studio is ubuntu. There are no differences on system level, only on software selection (including the DE).I agree on that.
    You're wrong there. Ubuntu Studio uses a different kernel from Ubuntu Desktop. Ubuntu Desktop uses a generic kernel, whilst Ubuntu Studio uses a lowlatency kernel to enable rt.
    As the Ubuntu Studio release manager and a Kubuntu developer, I do a lot of ISO testing and packaging.
    Make Ubuntu 13.10 awesome~!

  6. #6
    Join Date
    Jan 2008
    Beans
    147
    Distro
    Ubuntu Studio 12.10 Quantal Quetzal

    Re: uStudio 12.04 64 bit on Lenovo L420

    My purpose in mentioning both installs is:
    *I used two different ISO images
    *I installed Ubuntu twice
    To have a corrupt ISO and/or install twice in a row seems unlikely.

    By the way, for what it's worth, Ubuntu standard was installed with online access so it could grab updates, while uStudio was installed offline, with updates obtained after installation.

    Smartboyhw, after downloading all updates available, would my install be considered 12.04.1, or do I need to reinstall with a newly obtained ISO?
    Ubuntu 14.04 LTS, Gnome3, ck-designed desktop
    (ASRock Z77 Extreme4 MB / 3.4GHz Intel i7-3770 / 16GB G.Skill RAM / Intel HD 4000)
    Ubuntu 14.04 LTS, Gnome3, Sony Vaio SVS151190X notebook
    (2.5GHz Intel i5-3210M / 6GB RAM / Intel HD 4000)

  7. #7
    Join Date
    Aug 2012
    Location
    Hong Kong
    Beans
    160
    Distro
    Ubuntu Development Release

    Re: uStudio 12.04 64 bit on Lenovo L420

    Quote Originally Posted by Ck.asdf View Post
    My purpose in mentioning both installs is:
    *I used two different ISO images
    *I installed Ubuntu twice
    To have a corrupt ISO and/or install twice in a row seems unlikely.

    By the way, for what it's worth, Ubuntu standard was installed with online access so it could grab updates, while uStudio was installed offline, with updates obtained after installation.

    Smartboyhw, after downloading all updates available, would my install be considered 12.04.1, or do I need to reinstall with a newly obtained ISO?
    NO. If you have the updates installed it is 12.04.1.
    As the Ubuntu Studio release manager and a Kubuntu developer, I do a lot of ISO testing and packaging.
    Make Ubuntu 13.10 awesome~!

  8. #8
    Join Date
    Jan 2008
    Beans
    147
    Distro
    Ubuntu Studio 12.10 Quantal Quetzal

    Re: uStudio 12.04 64 bit on Lenovo L420

    So what can I do from here to attempt to resolve these issues? When the system seizes up like that, would there be any log files or something I could provide to give some kind of clue what's happening?

    Thanks for all the help, by the way!
    Ubuntu 14.04 LTS, Gnome3, ck-designed desktop
    (ASRock Z77 Extreme4 MB / 3.4GHz Intel i7-3770 / 16GB G.Skill RAM / Intel HD 4000)
    Ubuntu 14.04 LTS, Gnome3, Sony Vaio SVS151190X notebook
    (2.5GHz Intel i5-3210M / 6GB RAM / Intel HD 4000)

  9. #9
    Join Date
    Apr 2008
    Location
    Alberta, Canada
    Beans
    7
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: uStudio 12.04 64 bit on Lenovo L420

    I have also experienced this same issue. Total system freeze up. This issue is not just in UStudio 64, but anything Ubuntu driven I have installed including Ubuntu 12.04 unity 64(even tried switching to gnome) and the new Linux Mint Maya 64. They all freeze within a 5 to 15 minute session. I have checked iso for errors, I have re-installed and re-downloaded the iso direct from either Ubuntu/UStudio/LMint sites. I've lost count how many attempts and I have been checking frequently for solutions. Very discouraging when I use UStudio for design work and have to use the release from two years ago since last years UStudio team split up gong show release was non existent.

    Equipment details...
    MSI GT70 Intel Core i7 laptop
    Nvidia Geforce GTX 670M 3GBDDR5

  10. #10
    Join Date
    Nov 2005
    Location
    Colorado USA
    Beans
    10

    Re: uStudio 12.04 64 bit on Lenovo L420

    Ck.asdf, do you have any updates on this? Did you ever get things to work?

    I'm just shooting in the dark bcuz I'm no guru here, but did you try a different distro? Maybe Debian or Fedora? Get any diff results? Did you try to disable the power manager?

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •