Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Update & Broken Packages

  1. #11
    Join Date
    Apr 2008
    Location
    Philippines
    Beans
    50
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Update & Broken Packages

    A libre-office update installed libexttextcat-data and removed the whole libreoffice suite. I removed that package but now can't install libreoffice anymore and get the same messages as above:


    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies.
    libreoffice: Depends: libreoffice-core (= 1:3.5.4-0ubuntu1~lucid1) but it is not going to be installed
    Depends: libreoffice-writer but it is not going to be installed
    Depends: libreoffice-calc but it is not going to be installed
    Depends: libreoffice-impress but it is not going to be installed
    Depends: libreoffice-draw but it is not going to be installed
    Depends: libreoffice-math but it is not going to be installed
    Depends: libreoffice-base but it is not going to be installed
    Depends: libreoffice-filter-mobiledev but it is not going to be installed
    Depends: libreoffice-java-common (>= 1:3.5.4~) but it is not going to be installed
    Recommends: libreoffice-gnome but it is not going to be installed or
    libreoffice-kde but it is not going to be installed
    E: Broken packages


    I tried a lot of suggestions but nothing helps. I am also beginning to think that there is something wrong with the ppa
    Prediction is very difficult, especially of the future

  2. #12
    Join Date
    Apr 2011
    Location
    UK
    Beans
    109
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Update & Broken Packages

    Well, if more people are reading this, and post similar symptoms then it does point towards a messed up libreoffice ppa
    Powered by a Samsung NC10 with 2Gb RAM, running Lucid 10.04

  3. #13
    Join Date
    Feb 2008
    Beans
    20

    Re: Update & Broken Packages

    same problem here on ubuntu 10.04. Libreoffice was running well, but somehow got removed, and can no longer be installed.

    it says unmet dependencies and broken packages. From the terminal:

    ~$ sudo apt-get -f install libreoffice
    Paketlisten werden gelesen... Fertig
    Abhängigkeitsbaum wird aufgebaut
    Status-Informationen einlesen... Fertig
    Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
    Sie eine unmögliche Situation angefordert haben oder dass, wenn Sie die
    Unstable-Distribution verwenden, einige erforderliche Pakete noch nicht
    erstellt wurden oder Incoming noch nicht verlassen haben.
    Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:

    Die folgenden Pakete haben nicht-erfüllte Abhängigkeiten:
    libreoffice: Hängt ab: libreoffice-core (= 1:3.5.4-0ubuntu1~lucid1) soll aber nicht installiert werden
    Hängt ab: libreoffice-writer soll aber nicht installiert werden
    Hängt ab: libreoffice-calc soll aber nicht installiert werden
    Hängt ab: libreoffice-impress soll aber nicht installiert werden
    Hängt ab: libreoffice-draw soll aber nicht installiert werden
    Hängt ab: libreoffice-math soll aber nicht installiert werden
    Hängt ab: libreoffice-base soll aber nicht installiert werden
    Hängt ab: libreoffice-filter-mobiledev soll aber nicht installiert werden
    Hängt ab: libreoffice-java-common (>= 1:3.5.4~) soll aber nicht installiert werden
    E: Kaputte Pakete
    Now what? I need the -calc. Like NOW!

  4. #14
    Join Date
    Apr 2011
    Location
    UK
    Beans
    109
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Update & Broken Packages

    Package Manager History shows:

    Code:
    Commit Log for Sun Sep  2 09:35:23 2012
    
    
    Removed the following packages:
    libexttextcat0
    libreoffice
    libreoffice-base
    libreoffice-base-core
    libreoffice-calc
    libreoffice-common
    libreoffice-core
    libreoffice-draw
    libreoffice-emailmerge
    libreoffice-filter-mobiledev
    libreoffice-gnome
    libreoffice-gtk
    libreoffice-help-en-gb
    libreoffice-impress
    libreoffice-java-common
    libreoffice-math
    libreoffice-style-human
    libreoffice-style-tango
    libreoffice-writer
    python-uno
    
    Upgraded the following packages:
    libexttextcat-data (3.2.0-1ubuntu1~lucid1) to 3.3.1-2~lucid1
    libgraphite2-2.0.0 (1.0.3.real-1~lucid1) to 1.1.3-1~lucid1
    libvisio-0.0-0 (0.0.17-1~lucid1) to 0.0.19-1~lucid2
    
    
    Commit Log for Sun Sep  2 12:28:00 2012
    
    
    Removed the following packages:
    libcmis-0.2-0
    libexttextcat-data
    libgraphite2-2.0.0
    libhsqldb-java
    libhunspell-1.3-0
    libmythes-1.2-0
    libservlet2.5-java
    libvisio-0.0-0
    libwpd-0.9-9
    libwpg-0.2-2
    libwps-0.2-2
    libxerces2-java
    ttf-dejavu
    
    Commit Log for Sun Sep  2 17:25:28 2012
    
    
    Removed the following packages:
    uno-libs3
    ure
    
    Commit Log for Sun Sep  2 18:20:51 2012
    
    
    Upgraded the following packages:
    ttf-opensymbol (1:3.2.0-7ubuntu4.4) to 2:102.2+LibO3.5.4-0ubuntu1~lucid1
    
    Installed the following packages:
    fonts-opensymbol (2:102.2+LibO3.5.4-0ubuntu1~lucid1)
    Powered by a Samsung NC10 with 2Gb RAM, running Lucid 10.04

  5. #15
    Join Date
    Feb 2008
    Beans
    20

    Re: Update & Broken Packages

    note this comment to my bug report https://bugs.launchpad.net/ubuntu/+s...e/+bug/1045433

    Please use the stable ppa for the 3.5 series: ppa:libreoffice/libreoffice-3-5
    You can indeed install libreoffice once this ppa is activated in your repositories

  6. #16
    Join Date
    Apr 2011
    Location
    UK
    Beans
    109
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Update & Broken Packages

    Thanks ullix!

    Using the ppa ppa:libreoffice/libreoffice-3-5 did the trick, managed to reinstall all the packages that the default ppa removed.

    Powered by a Samsung NC10 with 2Gb RAM, running Lucid 10.04

  7. #17
    Join Date
    Oct 2010
    Beans
    17

    Re: Update & Broken Packages

    An alternative solution (which worked for me) is suggested here

    "Solution is to force version of the package libexttextcat-data to 3.2.0-1ubuntu1 (not to 3.3.1-2~precise1 by default)."

    Thanks to original solution finder!

  8. #18
    Join Date
    Sep 2008
    Location
    Pennsylvania
    Beans
    114
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Update & Broken Packages

    I have the same problem, and now I don't have LibreOffice, and cannot install it either.
    It seems the change in libexttextcat version (from 0 to 1.0 ?) needs LibreOffice to be built again against the new library. The LibreOffice ppa here has the new libexttextcat, but the LibreOffice has not been built yet against this, it seems.

  9. #19
    Join Date
    May 2010
    Location
    Alaska
    Beans
    68
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Update & Broken Packages

    Quote Originally Posted by Condor Cluster View Post
    Well, if more people are reading this, and post similar symptoms then it does point towards a messed up libreoffice ppa
    This appears to be a common enough issue to point to the ppa being screwed up, however I followed the guide supplied by a fellow here. He offered two possible install options, one being the ppa route and the other using a WA state mirror (I'm assuming this directs to his own server or something of the sort in his home state). I tried both approaches and neither worked. I continually receive the following message from terminal:
    Code:
    ****@****-desktop:~$ sudo apt-get install libreoffice-common libreoffice-gnome libreoffice
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
      libreoffice: Depends: libreoffice-core (= 1:3.5.4-0ubuntu1~lucid1) but it is not going to be installed
                   Depends: libreoffice-writer but it is not going to be installed
                   Depends: libreoffice-calc but it is not going to be installed
                   Depends: libreoffice-impress but it is not going to be installed
                   Depends: libreoffice-draw but it is not going to be installed
                   Depends: libreoffice-math but it is not going to be installed
                   Depends: libreoffice-base but it is not going to be installed
      libreoffice-common: Depends: libreoffice-style-default or
                                   libreoffice-style
      libreoffice-gnome: Depends: libreoffice-core (= 1:3.5.4-0ubuntu1~lucid1) but it is not going to be installed
                         Depends: libreoffice-gtk but it is not going to be installed
    E: Broken packages
    Any advice?

    EDIT:

    Ok so I saw that I missed a couple posts, so I went in and tried ullix's fix. Added the new ppa (libreoffice/libreoffice-3-5), and deslected the previously used ppa (libreoffice/ppa) and tried again:
    Code:
    sudo apt-get update
    sudo apt-get install libreoffice-common libreoffice-gnome libreoffice
    Worked perfectly.

    Attached is my resources list. Make sure the one I highlighted is selected in your list as well or when you try to install, it won't know where to pull the file from.

    THANKS for everyone's help and I hope I helped some as well.
    Attached Images Attached Images
    Last edited by learning_; September 26th, 2012 at 08:45 PM. Reason: Missed something

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •