Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Korean input with Nabi ****

  1. #11
    Join Date
    Feb 2010
    Beans
    11

    Re: Korean input with Nabi ****

    I am having the same problem. I updated both of my computers to 10.04 and on one of them (the hp laptop)nabi is still working, but on the other (LGx130 netbook w/10.04 UNR) it's not working. I tried reinstalling the files for nabi and uninstalling and reinstalling the language support as well. I don't like SCIM that much and I've had problems with it not recognizing 3 character syllabic blocks, but I'm willing to deal now...

    Though I'd still like to keep nabi, cleaner and more efficient. Though as of now it doesn't work.

    Any help at all would be much appreciated.

  2. #12
    Join Date
    Jan 2007
    Beans
    428

    Re: Korean input with Nabi ****

    Previously I reported nabi worked on one machine but didn't on the other. I was mistaken. Nabi doesn't work on neither of 10.4 machines. I am going back to 9.10. If anyone found solution, please share. Thanks.

    PROBLEM SOLVED: Install new version of nabi outside Synaptic Package Manager. http://packages.debian.org/unstable/x11/nabi

    EDIT: The link now defaults to 0.99.9. It is not stable. Search for nabi, and you will get links to different versions. Select 0.99.7. June 8, 2011 10.04LTS

    EDIT: Install nabi that comes with 10.04 first. This will put the language box in the upper task bar. If you install 0.99.7 directly, the language box will be outside the top task bar, very annoying.
    Last edited by paker; June 10th, 2011 at 04:47 AM.

  3. #13
    Join Date
    Jun 2008
    Beans
    16

    Question Re: Korean input with Nabi ****

    I have done a fresh german language Ubuntu 10.4 install on a Korean keyboard laptop.

    I have tried all kinds of Korean input methods with uim, scim, nabi (with the .gnomerc proposed here previously) and ibus and I have never managed to enter a single Hangeul All but scim gave me a gnome taskbarlet which was never any use. When configuring the switch key they all recognized the hangul and hangul-hanja keys, but then the keys do nothing. Same goes for other keys like shift-space or control-space.

    Doesn't anybody have a clue?

    On a not quite related topic I have put the Zeichenpalette (character chooser) into the top menu bar. When hovering it gives me a (gibberish to laymen!) unicode char name and says it would insert that char. But when I click it, it only copies it, so I can then insert it with middle-mouse or ctrl-v. That's so cumbersome it's almost unusable! There doesn't seem to be an option for direct insertion.

  4. #14
    Join Date
    Mar 2008
    Beans
    29

    Re: Korean input with Nabi ****

    1. sudo apt-get install scim-hangul
    2. system > administration > language > keyboard input method system to scim-bridge
    3. sudo /etc/init.d/gdm restart

    solves similar problem.

  5. #15
    Join Date
    Jan 2007
    Beans
    428

    Re: Korean input with Nabi ****

    SOLUTION

    Download nabi 0.99.7 deb package.
    http://packages.debian.org/unstable/x11/nabi

    10.04 comes with nabi 0.99.6.

  6. #16
    Join Date
    May 2009
    Location
    Bucheon, South Korea
    Beans
    3
    Distro
    Kubuntu 10.10 Maverick Meerkat

    Kubuntu Directions

    For the Kubuntu people wondering if they can replace .gnomerc with .kderc -- in my experience that doesn't work.

    For Kubuntu I do the following (circa 10.10 Maverick):

    1. Copy Batang, Dotum, and Gulim fonts from Korean windows install to /usr/share/fonts/windows-fonts (create the windows-fonts directory). Run fc-cache to refresh the font cache. You could probably also download these fonts from the interwebs.

    2. Install the nabi package via your favored method. I prefer the trusty: sudo apt-get install nabi

    3. Now instead of modifying/creating .kderc you should create a script in ~/.kde/env called something like nabi.sh with the following:

    Code:
    export LC_TYPE=en_US.UTF-8
    export XMODIFIERS="@im=nabi"
    export XIM_PROGRAM=/usr/bin/nabi
    export GTK_IM_MODULE=xim
    export QT_IM_MODULE=xim
    nabi &
    chmod +x nabi.sh and restart kdm and X.

    You might have to fool around with the dpkg-reconfigure locales, but I think simply specifying a UTF-8 based locale is good enough. Hope that clears up any confusion. If I put the contents of nabi.sh into .kderc then nabi would go to the system try but I would not be able change into hangul.

  7. #17
    Join Date
    Apr 2008
    Beans
    12

    Re: Korean input with Nabi ****

    Quote Originally Posted by mikwig View Post
    You need to change between 2불 and 3불.

    I have switched back to scim again - in that it is stable again, and can also do Japanese.
    I have the exact same problem. How do I switch from 2불 to 3불?

  8. #18
    Join Date
    Jan 2007
    Beans
    428

    Re: Korean input with Nabi ****

    The OP instructions still work for 12.04 LTS.

  9. #19
    Join Date
    Jan 2007
    Beans
    428

    Re: Korean input with Nabi ****

    Same instructions work in 12.10.

  10. #20
    Join Date
    Jan 2007
    Beans
    428

    Re: Korean input with Nabi ****

    same procedure works for 13.04 64 bit

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •