Results 1 to 9 of 9

Thread: Grsync copies everything everytime

  1. #1
    Join Date
    Sep 2008
    Beans
    13

    Grsync copies everything everytime

    Im using Grsync to backup my home directory to an external FAT32 hard drive. Every time I sync, it syncs everything, not just the files that have changed.
    I know about the time difference problem with FAT drives, and tried the option "--window-modify=3600" to compensate for different timestamps. Also tried "size only" option, and "always checksum" option. No dice.
    The rsync command that's being created is:
    rsync -r -t -p -v --progress --delete -l -s /home/myname /media/Verbatim HD/Backup Folder
    I don't understand most of it. I'd be grateful for any suggestions.

  2. #2
    Join Date
    Feb 2005
    Location
    Melbourne, Australia
    Beans
    13,505
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Grsync copies everything everytime

    Quote Originally Posted by canek1 View Post
    Im using Grsync to backup my home directory to an external FAT32 hard drive.
    .........
    Total waste of time.

    Do not back up Linux to rubbish Windows filesystems, they are not compatible.

    Format the external drive with a Linux filesystem or just stop wasting your time as your backup will be partially useless.
    Regards, David.
    Please use the Forum search and Wiki search for immediate help
    Please mark your thread as Solved when appropriate
    New to technical forums?: How To Ask Questions The Smart Way

  3. #3
    Join Date
    Sep 2008
    Beans
    13

    Re: Grsync copies everything everytime

    The drive is full of other backups and I can't offload them now. Thanks for the thought though.

    Can anybody else help me out here?

  4. #4
    Join Date
    Sep 2006
    Beans
    7,568
    Distro
    Lubuntu Development Release

    Re: Grsync copies everything everytime

    I wouldn't keep anything you care about on FAT. So I echo dcstar's recommendation and move to a serious file system ASAP so you don't lose your files.

    About the rsync formula, it is important to remember closing slashes for the directories. Also, -a for archive is useful, it's the same as -rlptgoD

    Code:
     rsync -av --progress --delete /home/myname/ /media/Verbatim HD/Backup Folder/
    You can also use -n for dry run to see what it will update or copy.

  5. #5
    Dennis N's Avatar
    Dennis N is offline Iced Blended Vanilla Crème Ubuntu
    Join Date
    Jun 2007
    Location
    Arizona U.S.A.
    Beans
    1,633

    Re: Grsync copies everything everytime

    Quote Originally Posted by canek1 View Post
    I know about the time difference problem with FAT drives, and tried the option "--window-modify=3600" to compensate for different timestamps.
    To prevent all files copying due to the time stamp difference, a correct option is:

    --modify-window=1

    I've used this for a long time to do rsync to FAT filesystems including flash drives and it works. No problems.

  6. #6
    Join Date
    Sep 2008
    Beans
    13

    Re: Grsync copies everything everytime

    yes, i tried --modify-window=1 but no success. the problem might be the trailing / on the directories but I don't see why as long as the target and source don't change each time I run the program. I havent got my hard drive here to test at the moment, I'll try it out next week.

    thanks for warnings re. FAT32. I'll keep it in mind for my next drive but for now any solutions should take into account that thsi is what Im stuck with.

  7. #7
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Grsync copies everything everytime

    Just to add to why not FAT32.

    I was backing up to FAT32 but it was a compressed file. I wondered why it always was 4GB even as system seemed to grow. Then I learned 4GB is maximum that FAT32 can save. It also does not have a journal, so chkdsk is harder to run.

    Also any system files like the . files in /home will lose permission and ownership. Your data files if less than 4GB should be ok. So at least parts of your backup will be difficult to restore.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  8. #8
    Dennis N's Avatar
    Dennis N is offline Iced Blended Vanilla Crème Ubuntu
    Join Date
    Jun 2007
    Location
    Arizona U.S.A.
    Beans
    1,633

    Re: Grsync copies everything everytime

    Quote Originally Posted by oldfred View Post
    Just to add to why not FAT32.
    Linux filesystem on the rsync destination is best, but it depends on the situation. For example, the destination is a flash drive (or external HD) where the files are going to be also used with a Windows computer. Then, you don't want a Linux file system on that flash drive.

  9. #9
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Grsync copies everything everytime

    Unless it is a camera flash drive, mp3 player or other device that requires FAT32, then NTFS is better for compatibility with Windows. Not sure about Macs and what they might require.

    NTFS has a journal so chkdsk from a Windows repairCD can often repair it and it supports files over 4GB.

    But if Linux system files you need to be backing up to a Linux file system to preserve ownership and permissions.

    Data can be backed up to anything that works with your other systems. Permissions or ownership can be reset if required easily on data, but system files vary in ownership, not always root and permissions. So it can be very difficult to reset. Resetting permissions & ownership in /home is possible since the owner is the owner and permissions are 664 for files and 775 for folders, with only a couple of exceptions.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •