Results 1 to 5 of 5

Thread: ATI 6320 & flash

  1. #1
    Join Date
    Aug 2012
    Beans
    12

    Arrow ATI 6320 & flash

    Hello everyone,

    I can't get my HD Radeon 6320 work at its best with Ubuntu 12.04 I have a U32U-RX028V laptop.

    I can't play flash content in 720p or 1080p, even 480p in fullscreen lag.
    I've read this post : How to optimize Flash in Firefox but it did not work.
    I installed the drivers following Ubuntu Documentation. I used Ubuntu repositories and I have enabled hardware acceleration.

    --NO XORG.CONF--

    High definition videos with VLC is perfect (1080p)
    Browser is not very smooth and flash videos don't play smooth

    Code:
    fglrxinfo
    display: :0  screen: 0
    OpenGL vendor string: Advanced Micro Devices, Inc.
    OpenGL renderer string: AMD Radeon HD 6320 Graphics
    OpenGL version string: 4.2.11627 Compatibility Profile Context
    
    vainfo
    libva: VA-API version 0.32.0
    Xlib:  extension "XFree86-DRI" missing on display ":0".
    libva: va_getDriverName() returns 0
    libva: Trying to open /usr/lib/i386-linux-gnu/dri/fglrx_drv_video.so
    libva: va_openDriver() returns 0
    vainfo: VA-API version: 0.32 (libva 1.0.15)
    vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA-API - 0.7.8
    vainfo: Supported profile and entrypoints
          VAProfileH264High               :	VAEntrypointVLD
          VAProfileVC1Advanced            :	VAEntrypointVLD
    
    lsmod | grep fglrx
    fglrx                2909855  102
    
    glxgears
    299 frames in 5.0 seconds = 59.733 FPS
    300 frames in 5.0 seconds = 59.991 FPS
    300 frames in 5.0 seconds = 59.991 FPS
    --WITH XORG.CONF--

    Low definition videos with VLC lag a lot
    Browser is very smooth but flash videos don't play smooth
    The workspaces are bugged, I can't move an app to an other workspace

    I generated the xorg.conf in Recovery mode using Xorg -configure
    I get two errors :

    (++) Using config file: "/root/xorg.conf.new"
    (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    (II) [KMS] No DRICreatedPCIBusID symbol, no kernel modesetting.
    Number of created sreens does not match number of detected devices.
    Configuration failed.
    ddxSigGiveUp: Closing log
    Server terminated with errror (2). Closing log file.

    Code:
    fglrxinfo
    libva: VA-API version 0.32.0
    Xlib:  extension "XFree86-DRI" missing on display ":0".
    libva: va_getDriverName() returns -1
    vaInitialize failed with error code -1 (unknown libva error),exit
    
    vainfo
    display: :0  screen: 0
    OpenGL vendor string: VMware, Inc.
    OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x300)
    OpenGL version string: 1.4 (2.1 Mesa 8.0.2)
    
    lsmod | grep fglrx
    fglrx                2909855  0
    
    glxgears
    776 frames in 5.0 seconds = 154.054 FPS
    840 frames in 5.1 seconds = 165.597 FPS
    880 frames in 5.0 seconds = 174.829 FPS
    XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
          after 5752 requests (39 known processed) with 0 events remaining.
    xorg.conf
    Code:
    Section "ServerLayout"
    	Identifier     "X.org Configured"
    	Screen      0  "Screen0" 0 0
    	Screen      1  "Screen1" RightOf "Screen0"
    	Screen      2  "Screen2" RightOf "Screen1"
    	InputDevice    "Mouse0" "CorePointer"
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "Files"
    	ModulePath   "/usr/lib/xorg/modules"
    	FontPath     "/usr/share/fonts/X11/misc"
    	FontPath     "/usr/share/fonts/X11/cyrillic"
    	FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    	FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    	FontPath     "/usr/share/fonts/X11/Type1"
    	FontPath     "/usr/share/fonts/X11/100dpi"
    	FontPath     "/usr/share/fonts/X11/75dpi"
    	FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    	FontPath     "built-ins"
    EndSection
    
    Section "Module"
    	Load  "record"
    	Load  "extmod"
    	Load  "dbe"
    	Load  "dri"
    	Load  "dri2"
    	Load  "glx"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "auto"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "ZAxisMapping" "4 5 6 7"
    EndSection
    
    Section "Monitor"
    	Identifier   "Monitor0"
    	VendorName   "Monitor Vendor"
    	ModelName    "Monitor Model"
    EndSection
    
    Section "Monitor"
    	Identifier   "Monitor1"
    	VendorName   "Monitor Vendor"
    	ModelName    "Monitor Model"
    EndSection
    
    Section "Monitor"
    	Identifier   "Monitor2"
    	VendorName   "Monitor Vendor"
    	ModelName    "Monitor Model"
    EndSection
    
    Section "Device"
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
            ### <percent>: "<f>%"
            ### [arg]: arg optional
            #Option     "NoAccel"            	# [<bool>]
            #Option     "SWcursor"           	# [<bool>]
            #Option     "Dac6Bit"            	# [<bool>]
            #Option     "Dac8Bit"            	# [<bool>]
            #Option     "BusType"            	# [<str>]
            #Option     "CPPIOMode"          	# [<bool>]
            #Option     "CPusecTimeout"      	# <i>
            #Option     "AGPMode"            	# <i>
            #Option     "AGPFastWrite"       	# [<bool>]
            #Option     "AGPSize"            	# <i>
            #Option     "GARTSize"           	# <i>
            #Option     "RingSize"           	# <i>
            #Option     "BufferSize"         	# <i>
            #Option     "EnableDepthMoves"   	# [<bool>]
            #Option     "EnablePageFlip"     	# [<bool>]
            #Option     "NoBackBuffer"       	# [<bool>]
            #Option     "DMAForXv"           	# [<bool>]
            #Option     "FBTexPercent"       	# <i>
            #Option     "DepthBits"          	# <i>
            #Option     "PCIAPERSize"        	# <i>
            #Option     "AccelDFS"           	# [<bool>]
            #Option     "IgnoreEDID"         	# [<bool>]
            #Option     "CustomEDID"         	# [<str>]
            #Option     "DisplayPriority"    	# [<str>]
            #Option     "PanelSize"          	# [<str>]
            #Option     "ForceMinDotClock"   	# <freq>
            #Option     "ColorTiling"        	# [<bool>]
            #Option     "VideoKey"           	# <i>
            #Option     "RageTheatreCrystal" 	# <i>
            #Option     "RageTheatreTunerPort" 	# <i>
            #Option     "RageTheatreCompositePort" 	# <i>
            #Option     "RageTheatreSVideoPort" 	# <i>
            #Option     "TunerType"          	# <i>
            #Option     "RageTheatreMicrocPath" 	# <str>
            #Option     "RageTheatreMicrocType" 	# <str>
            #Option     "ScalerWidth"        	# <i>
            #Option     "RenderAccel"        	# [<bool>]
            #Option     "SubPixelOrder"      	# [<str>]
            #Option     "ClockGating"        	# [<bool>]
            #Option     "VGAAccess"          	# [<bool>]
            #Option     "ReverseDDC"         	# [<bool>]
            #Option     "LVDSProbePLL"       	# [<bool>]
            #Option     "AccelMethod"        	# <str>
            #Option     "DRI"                	# [<bool>]
            #Option     "ConnectorTable"     	# <str>
            #Option     "DefaultConnectorTable" 	# [<bool>]
            #Option     "DefaultTMDSPLL"     	# [<bool>]
            #Option     "TVDACLoadDetect"    	# [<bool>]
            #Option     "ForceTVOut"         	# [<bool>]
            #Option     "TVStandard"         	# <str>
            #Option     "IgnoreLidStatus"    	# [<bool>]
            #Option     "DefaultTVDACAdj"    	# [<bool>]
            #Option     "Int10"              	# [<bool>]
            #Option     "EXAVSync"           	# [<bool>]
            #Option     "ATOMTVOut"          	# [<bool>]
            #Option     "R4xxATOM"           	# [<bool>]
            #Option     "ForceLowPowerMode"  	# [<bool>]
            #Option     "DynamicPM"          	# [<bool>]
            #Option     "NewPLL"             	# [<bool>]
            #Option     "ZaphodHeads"        	# <str>
    	Identifier  "Card0"
    	Driver      "radeon"
    	BusID       "PCI:0:1:0"
    EndSection
    
    Section "Device"
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
            ### <percent>: "<f>%"
            ### [arg]: arg optional
            #Option     "ShadowFB"           	# [<bool>]
            #Option     "Rotate"             	# <str>
            #Option     "fbdev"              	# <str>
            #Option     "debug"              	# [<bool>]
    	Identifier  "Card1"
    	Driver      "fbdev"
    	BusID       "PCI:0:1:0"
    EndSection
    
    Section "Device"
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
            ### <percent>: "<f>%"
            ### [arg]: arg optional
            #Option     "ShadowFB"           	# [<bool>]
            #Option     "DefaultRefresh"     	# [<bool>]
            #Option     "ModeSetClearScreen" 	# [<bool>]
    	Identifier  "Card2"
    	Driver      "vesa"
    	BusID       "PCI:0:1:0"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Card0"
    	Monitor    "Monitor0"
    	SubSection "Display"
    		Viewport   0 0
    		Depth     1
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     4
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     8
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     15
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     16
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    Section "Screen"
    	Identifier "Screen1"
    	Device     "Card1"
    	Monitor    "Monitor1"
    	SubSection "Display"
    		Viewport   0 0
    		Depth     1
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     4
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     8
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     15
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     16
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    Section "Screen"
    	Identifier "Screen2"
    	Device     "Card2"
    	Monitor    "Monitor2"
    	SubSection "Display"
    		Viewport   0 0
    		Depth     1
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     4
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     8
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     15
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     16
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    --sudo aticonfig --initial && sudo reboot | XORG.CONF--

    High definition videos with VLC is perfect (1080p)
    Browser is not very smooth and flash videos don't play smooth

    Code:
    fglrxinfo
    display: :0  screen: 0
    OpenGL vendor string: Advanced Micro Devices, Inc.
    OpenGL renderer string: AMD Radeon HD 6320 Graphics
    OpenGL version string: 4.2.11627 Compatibility Profile Context
    
    vainfo
    libva: VA-API version 0.32.0
    Xlib:  extension "XFree86-DRI" missing on display ":0".
    libva: va_getDriverName() returns 0
    libva: Trying to open /usr/lib/i386-linux-gnu/dri/fglrx_drv_video.so
    libva: va_openDriver() returns 0
    vainfo: VA-API version: 0.32 (libva 1.0.15)
    vainfo: Driver version: Splitted-Desktop Systems XvBA backend for VA-API - 0.7.8
    vainfo: Supported profile and entrypoints
          VAProfileH264High               :	VAEntrypointVLD
          VAProfileVC1Advanced            :	VAEntrypointVLD
    
    lsmod | grep fglrx
    fglrx                2909855  98 
    
    glxgears
    298 frames in 5.0 seconds = 59.517 FPS
    300 frames in 5.0 seconds = 59.812 FPS
    300 frames in 5.0 seconds = 59.994 FPS
    Code:
    Section "ServerLayout"
    	Identifier     "aticonfig Layout"
    	Screen      0  "aticonfig-Screen[0]-0" 0 0
    EndSection
    
    Section "Module"
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]-0"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    EndSection
    
    Section "Device"
    	Identifier  "aticonfig-Device[0]-0"
    	Driver      "fglrx"
    	BusID       "PCI:0:1:0"
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]-0"
    	Device     "aticonfig-Device[0]-0"
    	Monitor    "aticonfig-Monitor[0]-0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    -- XORG.CONF MODIFIED--

    I added the following code at the end of the previous xorg.conf :
    Code:
    Section "DRI"
     Mode 0666
    EndSection
    
    Section "Extensions"
     Option "Composite" "Enable"
    EndSection
    This changed nothing :
    High definition videos with VLC is perfect (1080p)
    Browser is not very smooth and flash videos don't play smooth


    What can I do to play flash videos with no lag ?
    I hope someone will be so kind as to help me

  2. #2
    Join Date
    Aug 2012
    Beans
    12

    Re: ATI 6320 & flash

    Read on cchtml.com :
    Note that RadeonHD 6xx0 chips will need kernel 2.6.38 for open-source mode-setting, xf86-video-ati/radeon 6.14.0 for 2D acceleration (EXA/Xv), and Mesa 7.11 for 3D acceleration.
    Is this my solution ? If yes, how to do this

    Thanks

  3. #3
    Join Date
    Mar 2012
    Beans
    304

    Re: ATI 6320 & flash

    It's actually old news:

    http://forums.adobe.com/thread/911321
    GNU/Linux

  4. #4
    Join Date
    Aug 2012
    Beans
    12

    Re: ATI 6320 & flash

    I already tried the "OverrideGPUValidation=1" in /etc/adobe/mms.cfg file. No change

    What a shame Ubuntu & ATI drivers & Flash don't work correctly !
    I don't understand something, HTML5 is designed to replace Flash, yes ?

    So why is it WORSE with HTML5 than Flash ?!?! (using Chromium on Youtube for example)

    Thanks

  5. #5
    Join Date
    Sep 2011
    Beans
    3

    Re: ATI 6320 & flash

    Flash never worked fine in Linux, and AFAIK HTML5 is still a WIP project. You could download the flash video in h264 and play it using vlc with hardware acceleration on.

    Also, don't pm people asking for help, that is what the forum is for.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •