Results 1 to 3 of 3

Thread: Netatalk Failure to connect using avahi hostname

  1. #1
    Join Date
    Jun 2008
    Beans
    2

    Netatalk Failure to connect using avahi hostname

    Hello, I'm scratching my head with this problem.
    Using ubuntu 12.04 to try to share my home and other disk to my mac.
    Followed various guides with a strange result:
    AFP Shares work without problems if I access them with the IP address (on mac CMD+K and go to afp://192.168.1.3) but if I access the host from the finder automatic discovery I get a Connection failed error.
    This happens using Mountain Lion 10.8.1
    Any thought of this?
    After messing with avahi, the hosts file, I find that if I restart avahi and deactivate/reactivate airport sometimes it works...

  2. #2
    Join Date
    Jun 2012
    Location
    Long Beach, CA, U$
    Beans
    27
    Distro
    Ubuntu

    Re: Netatalk Failure to connect using avahi hostname

    we can't help you much unless you post configuration files. I'd start with posting the following files:

    /etc/avahi/services/afpd.service
    /etc/default/netatalk

    I'm able to access via hostname so you've probably just misconfigured something somewhere.

    -edit-
    Also, make sure you've set up local dns so the hostname can be resolved.. or at the very least, add the entry to /etc/hosts....
    Last edited by xdracco; September 20th, 2012 at 04:39 PM. Reason: Added name resolution reference

  3. #3
    Join Date
    Jan 2013
    Beans
    1

    Re: Netatalk Failure to connect using avahi hostname

    I just spent a lot of time tracking down an answer to this same problem. Turns out avahi by default doesn't publish an IPv4 A record on IPv6. I added the following line to my /etc/avahi/avahi-daemon.conf:
    Code:
    publish-a-on-ipv6=yes
    and restarted avahi-daemon and I could connect to my afp file share from the list in the Finder just fine.

    I'm not sure why this was necessary, I installed avahi-utils and looked at the afp shares currently available on the network:
    Code:
    avahi-browse -r _afpovertcp._tcp
    WIthout publish-a-on-ipv6 set to yes, the only record my server was publishing had my IPv6 address. Once I set that option it started publishing my IPv4 address in the address field.

    I also ran this command from my Mac, which told me the Mac couldn't find an IPv6 record for my fileserver either before or after that change:
    Code:
    dns-sd -G v4v6 servername

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •