Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Wifi seems to work but no internet (u12.04)

  1. #1
    Join Date
    Aug 2012
    Beans
    7

    Unhappy Wifi seems to work but no internet (u12.04)

    Hello,

    I'm new to this forum and quite new to Linux as well. I've been looking in various forums to find a solution to my problem but wasn't successful.

    My Problem:
    The internet is not working.

    I installed Ubuntu 12.04 on a Acer PRO73Vm. The wireless network seems to be connected but when I try to open firefox the internet doesn't work.

    It would be great if you could give me some guidance on what I could try to solve the problem.

    Thank you for reading and I hope somebody can help!

  2. #2
    Join Date
    Jun 2008
    Beans
    169

    Re: Wifi seems to work but no internet (u12.04)

    Hi,

    - does the internet work with other devices or with other OSs on that same computer?

    - open a terminal, run the following and post the output

    Code:
    ifconfig
    Code:
    route

  3. #3
    Join Date
    Aug 2012
    Beans
    7

    Re: Wifi seems to work but no internet (u12.04)

    Thank you for your quick help!

    The internet works with other devices including mac, win xp, win 7
    Before I installed Ubuntu 12.04 the laptop ran on windows vista and the internet worked.

    Code:
    eth0      Link encap:Ethernet  HWaddr 00:22:15:ee:5c:43  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
              Interrupt:46 Base address:0x6000 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:1425 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1425 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:89217 (89.2 KB)  TX bytes:89217 (89.2 KB)
    
    wlan0     Link encap:Ethernet  HWaddr 00:16:ea:8a:64:6e  
              inet addr:192.168.2.102  Bcast:192.168.2.255  Mask:255.255.255.0
              inet6 addr: fe80::216:eaff:fe8a:646e/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:1457 errors:0 dropped:0 overruns:0 frame:0
              TX packets:1760 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:235959 (235.9 KB)  TX bytes:167861 (167.8 KB)
    Code:
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    default         192.168.2.1     0.0.0.0         UG    0      0        0 wlan0
    link-local      *               255.255.0.0     U     1000   0        0 wlan0
    192.168.2.0     *               255.255.255.0   U     2      0        0 wlan0

  4. #4
    Join Date
    Feb 2008
    Location
    I'm lost ... HELP!
    Beans
    1,014
    Distro
    Xubuntu

    Re: Wifi seems to work but no internet (u12.04)

    Can you ping 192.168.2.1 ?
    Code:
    ping 192.168.2.1
    And does the gateway (the machine with 192.168.2.1) need to be configured to forward your machine to the internet?

  5. #5
    Join Date
    Jun 2008
    Beans
    169

    Re: Wifi seems to work but no internet (u12.04)

    i would check the connectivity with another device which u count-on.
    in addition restart the router is not a bad idea.
    (restart not reset, you don't want to configure it all again)

  6. #6
    Join Date
    Aug 2012
    Beans
    7

    Re: Wifi seems to work but no internet (u12.04)

    I forgot to mention that I have another laptop that runs ubuntu (11.04) and it can access the internet.

    @miegiel

    Thank you for your help!

    The ping output was:

    Code:
    PING 192.2.1 (192.168.2.1) 56(84) BYTES OF DATA.
    From 192.168.2.1 (192.168.2.1) 56(84) bytes of data.
    From 192.168.2.102 icmp_seq=67 Destination Host Unreachable
    From 192.168.2.102 icmp_seq=68 Destination Host Unreachable
    From 192.168.2.102 icmp_seq=69 Destination Host Unreachable
    From 192.168.2.102 icmp_seq=70 Destination Host Unreachable
    From 192.168.2.102 icmp_seq=71 Destination Host Unreachable
    From 192.168.2.102 icmp_seq=72 Destination Host Unreachable
    I don't think the gateway needs to be configured to forward the machine. (mot sure if I understand you correctly). Every machine can access the internet independently.

  7. #7
    Join Date
    Feb 2008
    Location
    I'm lost ... HELP!
    Beans
    1,014
    Distro
    Xubuntu

    Re: Wifi seems to work but no internet (u12.04)

    Quote Originally Posted by marketwizard View Post
    ...The ping output was:

    Code:
    PING 192.2.1 (192.168.2.1) 56(84) BYTES OF DATA.
    From 192.168.2.1 (192.168.2.1) 56(84) bytes of data.
    From 192.168.2.102 icmp_seq=67 Destination Host Unreachable
    From 192.168.2.102 icmp_seq=68 Destination Host Unreachable
    From 192.168.2.102 icmp_seq=69 Destination Host Unreachable
    From 192.168.2.102 icmp_seq=70 Destination Host Unreachable
    From 192.168.2.102 icmp_seq=71 Destination Host Unreachable
    From 192.168.2.102 icmp_seq=72 Destination Host Unreachable
    ...
    That's weird!? Did you make a typo?

    Also: Could you elaborate a bit on you home network and internet connection setup? Do you only have one of those modem+router+firewall+switch+access-point boxes that connect everything together and to the internet, or is there more hardware involved?

  8. #8
    Join Date
    Aug 2012
    Beans
    7

    Re: Wifi seems to work but no internet (u12.04)

    @sam1948

    I tried to restart the router but that didn't help. Other machines like the MacBookAir I'm writing this from are working fine.

    @miegiel
    You're right. It's a typo. I was typing it from the screen of the ubuntu machine.. May I ask what the ping output tells you?

    There is a single device which is connected to the telephone line that is responsible for the network.
    I hope that information is helpful.

  9. #9
    Join Date
    Mar 2008
    Beans
    88
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wifi seems to work but no internet (u12.04)

    open firefox and type

    http://74.125.224.72/

    if google loads it's a dns issue.
    Your first step, learn the command line man intro man man man bash

  10. #10
    Join Date
    Aug 2012
    Beans
    7

    Re: Wifi seems to work but no internet (u12.04)

    @nativehound:

    Unfortunately, google doesn't load.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •