Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Problems configuring eth0

  1. #1
    Join Date
    Jun 2012
    Beans
    8

    Problems configuring eth0

    Okay so I just installed ubuntu server 12.04. During install, I skipped the network setup and now cannot connect to the internet. Here's what I have tried so far:

    Editing the /etc/network/interfaces file to look like this:

    auto lo
    iface lo inet loopback

    auto eth0
    iface eth0 inet static
    address 192.168.0.100
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255
    gateway 192.168.2.1

    then edited the /etc/resolv.conf file to look like this:

    nameserver 208.67.222.222
    nameserver 208.67.220.220

    Afterwards, I ran sudo /etc/init.d/networking restart

    Nothing I have tried has fixed the problem. When I ping anything, it reads "unknown host". Here is my $ route and $ ifconfig output: http://paste.ubuntu.com/1020821/

    Can someone please help? thanks

  2. #2
    Join Date
    Jan 2009
    Location
    ::1
    Beans
    2,461

    Re: Problems configuring eth0

    Quote Originally Posted by leschandrew View Post
    O
    address 192.168.0.100
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255
    gateway 192.168.2.1
    That's wrong. With a mask like 255.255.255.0, all addresses should start with the three same bytes, so 192.168.0.x for example.

  3. #3
    Join Date
    Jun 2011
    Beans
    417
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Problems configuring eth0

    Hi

    Your network and broadcast addresses are wrong and they should be:

    network: 192.168.0.1
    broadcast: 192.168.0.255

  4. #4
    Join Date
    Nov 2008
    Location
    Metro Boston
    Beans
    8,837
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: Problems configuring eth0

    auto eth0
    iface eth0 inet static
    address 192.168.0.100
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255
    gateway 192.168.2.1
    The machine itself needs an address in the same IP subnet specified in the network and broadcast parameters. In your case that defines machines in the range 192.168.1.1-254. So either this machine should have the address 192.168.1.100 or something similar, or the network parameter needs to be 192.168.0.0.

    You're still not out of trouble yet, though. The gateway parameter tells the machine where to send packets that it has no other route for. If the machine joins an IP network, it can communicate with all the other machines on that network by broadcasting packets with the target machine's address. For all other traffic, there needs to be a router on the same network to forward the traffic along. Your machine can't "see" machines in 192.168.2.0/24, so the gateway cannot be 192.168.2.1. It needs to be in the same network subnet as this machine. If the machine is supposed to have 192.168.1.100 as its address, then the configuration would look like:

    Code:
    auto eth0
    iface eth0 inet static
    address 192.168.1.100
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255
    gateway 192.168.1.1
    where 192.168.1.1 is a router. If the machine is supposed to be 192.168.0.100, then change the values above accordingly. The gateway must be in the subnet defined by "network".
    Last edited by SeijiSensei; June 3rd, 2012 at 03:29 PM.

  5. #5
    Join Date
    Jun 2012
    Beans
    8

    Re: Problems configuring eth0

    Thanks everyone for the replies. However, the problem persists. Here's what I now have the /etc/network/interfaces file set to:

    auto lo
    iface lo inet loopback

    auto eth0
    iface eth0 inet static
    address 192.168.0.124
    netmask 255.255.255.0
    network 192.168.0.0
    broadcast 192.168.0.255
    gateway 192.168.0.1

    I tried pinging my router @ 192.168.0.1, but I can't even get a reply from that. Is it maybe a wrong setting with my router? Thanks

  6. #6
    Join Date
    Jan 2009
    Location
    ::1
    Beans
    2,461

    Re: Problems configuring eth0

    Quote Originally Posted by leschandrew View Post
    Thanks everyone for the replies. However, the problem persists. Here's what I now have the /etc/network/interfaces file set to:

    auto lo
    iface lo inet loopback

    auto eth0
    iface eth0 inet static
    address 192.168.0.124
    netmask 255.255.255.0
    network 192.168.0.0
    broadcast 192.168.0.255
    gateway 192.168.0.1

    I tried pinging my router @ 192.168.0.1, but I can't even get a reply from that. Is it maybe a wrong setting with my router? Thanks
    Are you sure the router is on 192.168.0.1? And are you sure 192.168.0.124 is available? Are you sure the format of the information above is correct (it's not the same as on my ubuntu server 11.10).

    So ... a lot of questions. Therefor:

    This is what I would do: re-install Ubuntu Server, and in network setup select that your server uses DHCP (so: as a client). Then everything should work. This will take 10 minutes in total or so.

    Then, *if* you want your server to have a fixec IP address, go into your modem/router, and somewhere in your modem/router select that the IP address given to your device running ubuntu server, should be fixed / reserved for that device.

    HTH
    Last edited by sanderj; June 3rd, 2012 at 09:53 PM.

  7. #7
    Join Date
    Jun 2012
    Beans
    8

    Re: Problems configuring eth0

    yeah i'm sure that is the router's address and 192.168.0.24 is available. I checked to make sure using ipconfig on my Windows desktop. I remember during the install it kept getting errors configuring dhcp, and couldn't set it up for some reason. So i just skipped it. I guess I will attempt a re-install.

  8. #8
    Join Date
    Jun 2012
    Beans
    8

    Re: Problems configuring eth0

    okay, I am re-installing ubuntu 12.04, and I ran into a network hardware issue. The info I'm getting is that I am missing non-free firmware that my hardware needs to operate. The specific firmware file is: tigon/tg3_tso.bin. It then gives me an option to load the file from removable media. Can anyone tell me where to find it and any steps I need to take to install it? Thanks..

  9. #9
    Join Date
    Nov 2007
    Location
    Wisconsin
    Beans
    1,139

    Re: Problems configuring eth0

    It depends on how you are installing.

    Here is the list of packages that include the driver: http://packages.ubuntu.com/search?se...ecise&arch=any


    Code:
    File 	                                                Packages
    /lib/firmware/3.2.0-23-generic-pae/tigon/tg3_tso.bin 	linux-image-3.2.0-23-generic-pae [not amd64]
    /lib/firmware/3.2.0-23-generic/tigon/tg3_tso.bin 	linux-image-3.2.0-23-generic
    /lib/firmware/3.2.0-23-lowlatency-pae/tigon/tg3_tso.bin linux-image-3.2.0-23-lowlatency-pae [not amd64]
    /lib/firmware/3.2.0-23-lowlatency/tigon/tg3_tso.bin 	linux-image-3.2.0-23-lowlatency
    /lib/firmware/3.2.0-23-virtual/tigon/tg3_tso.bin 	linux-image-3.2.0-23-virtual
    /lib/firmware/tigon/tg3_tso.bin 	                linux-firmware

    You can see that it's in linux-firmware, but also included in all the kernel images.

    So you can install linux-firmware, but first it may be easier to try a symlink to the existing file in a different location.
    Last edited by Cheesehead; June 4th, 2012 at 03:47 AM.

  10. #10
    Join Date
    Jun 2012
    Beans
    8

    Re: Problems configuring eth0

    okay I got the firmware file installed, however I'm now having a problem configuring the DHCP network. It fails to autoconfigure each time. Not sure what is causing this problem. I am connecting to a router which in turn is connected to a Westell 6100 modem. I just figured out that the modem is doubling as a router as well, which may be messing everything up. does anyone have any ideas? I can include screenshots of both the router and modem configuration menus if needed. Thanks...

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •