Page 6 of 8 FirstFirst ... 45678 LastLast
Results 51 to 60 of 80

Thread: Howto recover the big pointer in unity?

  1. #51
    Join Date
    Aug 2005
    Location
    Northern Michigan USA
    Beans
    1,853
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Howto recover the big pointer in unity?

    this needs an easy fix it works on some machines, others it shows as 48 black in dconf but is still small worked fine in gnome 2

  2. #52
    Join Date
    Oct 2008
    Beans
    3,509

    Re: Howto recover the big pointer in unity?

    Quote Originally Posted by rtimai View Post
    glen (stinkeye),
    You reported:

    glen@Raring:~$ gsettings get org.gnome.desktop.interface cursor-size
    48

    If this is a gconf setting, this key no longer exists in my gconf configuration -- it doesn't appear in gconf-editor. An Interface key does appear in dconf-editor -- but oddly enough it is NOT changed to 48 but remains the default 24 (with "Use large cursor" selected in Unity Tweak.)

    My double-size cursor remains persistent between cold boots. Notably, however, the cursor size starts out small (24) when initially logging in, and the large cursor appears to be activated only after starting the Chromium browser or Gnome-Search. I think the GTK-based rendering of these applications are what triggers the large cursor. In previous versions of Ubuntu, however, the large cursor reverted back to the small size when leaving the GTK-based application. This time however, however awkwardly activated, the large cursor remains persistent. I don't know which Ubuntu Unity update fixed the cursor-size setting, or if it was even intentional. But I seem to recall a recent update to X.org, the underlying display system, and I suspect this is what caused the new behavior. I suspect that a regression error in the future could easily cause the bug to resurface.
    Hi rtimai,
    gsettings is a commandline interface to dconf.
    One of gsettings commands allows you to monitor individual keys or keys from a schema.
    I did this when using unity-tweak to "restore defaults" and "use large cursors" and it showed the dconf changes in terminal as they happened.
    Still inconsistent here.
    unity-tweak-tool version 0.0.5

    If it works for you...just run with it.
    Attached Images Attached Images
    Last edited by stinkeye; July 2nd, 2013 at 02:16 AM.

  3. #53
    Join Date
    Apr 2006
    Beans
    4

    Question Re: Howto recover the big pointer in unity?

    Quote Originally Posted by stinkeye View Post
    Try this.
    I took the installed DMZ-Black theme and removed the 24 and 32 pixel layers so it uses 48 and
    created a DMZ-Black-Large theme.

    Download the attachment to your ~/Downloads folder.
    Right click on ~/Downloads/DMZ-Black-Large.tar.gz > Extract here.
    Move theme to /usr/share/icons...
    Code:
    sudo mv Downloads/DMZ-Black-Large /usr/share/icons
    Add to alternatives, change to theme in dconf and alternatives and change size to 48 pixels (4 separate commands)....
    Code:
    CURSOR=DMZ-Black-Large
    
    sudo update-alternatives --install /usr/share/icons/default/index.theme x-cursor-theme /usr/share/icons/$CURSOR/cursor.theme 20
    
    gsettings set org.gnome.desktop.interface cursor-theme "$CURSOR" && sudo update-alternatives --set x-cursor-theme /usr/share/icons/$CURSOR/cursor.theme
    
    gsettings set org.gnome.desktop.interface cursor-size 48
    Log out/in

    To set back to default cursor and size...
    Code:
    CURSOR=DMZ-White
    
    gsettings set org.gnome.desktop.interface cursor-theme "$CURSOR" && sudo update-alternatives --set x-cursor-theme /usr/share/icons/$CURSOR/cursor.theme
    
    gsettings reset org.gnome.desktop.interface cursor-size
    Log out/in
    How would I make one for the redglass theme all sizes out exept 48?

    Grts

  4. #54
    Join Date
    Oct 2008
    Beans
    3,509

    Re: Howto recover the big pointer in unity?

    Quote Originally Posted by xxbartosxx View Post
    How would I make one for the redglass theme all sizes out exept 48?

    Grts
    Hi xxbartosxx,
    It's quicker for me to actually gimp the theme than explain how to do it,
    but if you want a howto, let me know and I'll post when I have time.


    Download the attachment, extract the redglass-Large folder and move to /usr/share/icons...

    Then run these 4 terminal commands...
    Code:
    CURSOR=redglass-Large
    
    sudo update-alternatives --install /usr/share/icons/default/index.theme x-cursor-theme /usr/share/icons/$CURSOR/cursor.theme 20
    
    gsettings set org.gnome.desktop.interface cursor-theme "$CURSOR" && sudo update-alternatives --set x-cursor-theme /usr/share/icons/$CURSOR/cursor.theme
    
    gsettings set org.gnome.desktop.interface cursor-size 48
    Log out/in.


    To set back to DMZ-White default size(24)....
    Code:
    CURSOR=DMZ-White
    
    gsettings set org.gnome.desktop.interface cursor-theme "$CURSOR" && sudo update-alternatives --set x-cursor-theme /usr/share/icons/$CURSOR/cursor.theme
    
    gsettings reset org.gnome.desktop.interface cursor-size
    Attached Files Attached Files
    Last edited by stinkeye; July 2nd, 2013 at 02:43 PM.

  5. #55
    Join Date
    Apr 2006
    Beans
    4

    Re: Howto recover the big pointer in unity?

    Works like a charm but you don't need to do the gsettings stuff as I am on xubuntu. A HowTo would be rather handy if I wonne edit other themes.

    Grtz & Thx

  6. #56
    Join Date
    Oct 2008
    Beans
    3,509

    Re: Howto recover the big pointer in unity?

    Using gimp to remove pixel layers.
    Copy your cursor theme from /usr/share/icons or a downloaded theme to your Desktop.
    I have not used gimp much and it only allows me to save in the correct format with an extension so I can't replace
    the original images directly when saving in gimp.
    So firstly I add a .xmc extension to all the image files in the theme's cursors folder with pyrenamer.
    Code:
    sudo apt-get install pyrenamer
    Open pyrenamer at the cursors folder and set up as in pic. Hit Preview then Rename.
    Renaming allows me to overwrite the original file when saving in gimp.
    023.jpg

    Now in the themes cursor folder you may see a lot of files with broken link symbols.
    You only need ctrl select the files that are not linked and then open in gimp.
    Arrange files by file_type and select only non linked images.
    The broken links will be fixed when the extensions are removed.
    025.jpg


    Now it's just a production line in gimp.
    Click and hold on the small arrow on the left of the images bar until you stop at the first image.
    022.jpg
    On the right is the layers tab and shows the different pixel layers.
    Click on the top most layer (usually 48px) in the right pane then hold the keyboard down Arrow to move to the bottom.
    The reason for this is it remembers the last layer selection when deleting.
    Hit the delete button repeatedly until you are left with only 48 pixel layers.
    Be aware that some of the animated images have multiple 48 pixel layers you don't want to delete.

    Click on the next image in the imported image bar and repeat....repeat .....

    Then you need to save each edited image.
    026.jpg

    File > overwrite...for each image.

    Once you have overwritten all files select
    File > close all
    You will be warned about unsaved changes.
    The files are already overwritten...so just choose discard changes and close gimp.


    Then you need to remove the .xmc extensions in the theme's cursors folder.
    Open with pyrenamer and set up as in pic below. Hit Preview then Rename.
    024.jpg

    Edit the cursor.theme file to something to reflect the change.
    A cursor.theme file is needed to register the theme with update-alternatives.
    If a downloaded theme doesn't have this file, create it.
    Code:
    [Icon Theme]
    Inherits=DMZ-White-Large
    and also edit the index.theme to...
    Code:
    [Icon Theme]
    Name=DMZ-White-Large
    Comment=White large cursor theme
    Lastly rename the theme folder to the new name shown in the cursor.theme file.
    In this example... DMZ-White-Large, and move to /usr/share/icons

    Register the theme with update-alternatives and select the theme as shown previously...
    Code:
    CURSOR=DMZ-White-Large
    
    sudo update-alternatives --install /usr/share/icons/default/index.theme x-cursor-theme /usr/share/icons/$CURSOR/cursor.theme 20
    
    gsettings set org.gnome.desktop.interface cursor-theme "$CURSOR" && sudo update-alternatives --set x-cursor-theme /usr/share/icons/$CURSOR/cursor.theme
    
    gsettings set org.gnome.desktop.interface cursor-size 48
    The above commands will work with any theme placed in /usr/share/icons that has a cursor.theme file.
    Just change the first command to the name of your cursor theme.
    ie
    CURSOR=modified_theme_name
    The last command, "gsettings set org.gnome.desktop.interface cursor-size 48" command isn't really needed because it can't use anything else but 48 pixels.
    Last edited by stinkeye; July 17th, 2013 at 08:21 AM.

  7. #57
    Join Date
    Jul 2007
    Location
    Nashville TN
    Beans
    134
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Howto recover the big pointer in unity?

    I stated that I'd report here if the large cursor reverted. It DID REVERT, for no apparent reason, Dconf settings remain the same. The 'working' circle animation and 'select' hand are large -- in some windows only -- and the arrow cursor is back to the small 24px size again. On a laptop with 1366x768 resolution, the small screen cursor is difficult to locate. Such a disappointment. Thanks for our comments.

    FOLLOW-UP WORKAROUND!

    Stinkeye provided an excellent procedural for modifying complete cursor theme sets. My situation, however, is somewhat specific, not requiring a cursor overhaul, and I thought I'd add my simple workaround here for others who have trouble locating the small arrow-pointer on the screen. Now, I've tried ALL the dconfig and update-alternatives solutions posted here, but the arrow-pointer has not been affected -- while all the other cursors are double in size when selecting the "large cursors" option.

    So, I used Stinkeye's excellent instructions for modifying the arrow-pointer file (left_ptr) ONLY, to contain only one layer with a size 32 image with the hotspot at axes 1x1. I've uploaded this file as a public file to my UbuntuOne account storage folder.

    So, here's a really simple fix for what I wanted: Replace the /usr/share/icons/DMZ-White/cursors/left_ptr file with the file located at:

    http://ubuntuone.com/3tc2EYtSsSp6hUxWaQjC4t

    The easiest way for those unfamiliar with the command line to perform a file replacement is to open Terminal and enter:

    gksudo nautilus
    or
    gksudo nemo
    (if you prefer Nemo for its ability to display the left pane in Tree View)

    Navigate to and locate /usr/share/icons/DMZ-White/cursors/left_ptr

    FIRST RENAME the left_ptr file to left_ptr~ to preserve the original copy!

    Then COPY the modified file to the DMZ-White/cursors folder

    Logging in/out should activate the new arrow-pointer immediately at the LightDM login screen. ALL of my cursor options in Unity-Tweak-Tool are set at defaults. Hope this helps somebody.

    And THANKS to Stinkeye for the GIMP instructions. Information on editing XMC file layers is not easy to find.
    Last edited by rtimai; July 14th, 2013 at 01:31 PM. Reason: Workaround added, typo fixed, corrected px size reference

  8. #58
    Join Date
    Oct 2008
    Beans
    3,509

    Re: Howto recover the big pointer in unity?

    Can someone check this for me in an up to date 13.04 install.
    It appears 13.04 now observes the ~/.Xresources file for cursor size like previously.

    eg
    When using one of the default DMZ themes,
    I only need to set the size with gsettings...
    Code:
    gsettings set org.gnome.desktop.interface cursor-size 48
    and

    edit ~/.Xresources with the same size change
    Code:
    gedit ~/.Xresources
    add or edit the line
    Code:
    Xcursor.size:48
    log out/in.
    Last edited by stinkeye; July 18th, 2013 at 05:39 AM.

  9. #59
    Join Date
    Jul 2007
    Location
    Nashville TN
    Beans
    134
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Howto recover the big pointer in unity?

    Stinkeye,

    I am confirming, Unity is now parsing the ~/.Xresources file, and it DOES fix the cursor size problem.

    As you'd expect, this takes effect AFTER logging in. The LightDM/Plymouth screen starts out with the tiny 24-pixel pointer (in a 1366x768 resolution laptop screen,) then it enlarges when the desktop loads. But there are still issues with the icon theme. I tried switching to DMZ-Black, and the arrow pointer remains white, while the Wait (spinner,) Select (hand,) and resize arrows are black.

    Okay... I see now, the icon theme needs to be re-set in update-alternatives also. I used Galternatives and confirmed that the theme was still set to DMZ-White, and when I changed it to match Dconf (gsettings) the arrow pointer size updated to 48-point.

    I'm not sure if the Plymouth screen will ever show the large pointer, but it's trivial as far as I'm concerned. Thanks for the heads-up about this change. (And I have the workaround 48-pixel DMZ-Black theme to fall back on if this gets "regressioned" out.) HOW did you notice it?

  10. #60
    Join Date
    Jul 2007
    Location
    Nashville TN
    Beans
    134
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Howto recover the big pointer in unity?

    Oh, just a moment. I thought I'd tried an entry in ~/.Xresources before, but i think I was confusing it with an .Xdefaults file in the same location, that didn't work. This might just be a new discovery for Ubuntu Unity.

Page 6 of 8 FirstFirst ... 45678 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •