Page 5 of 8 FirstFirst ... 34567 ... LastLast
Results 41 to 50 of 71

Thread: Howto recover the big pointer in unity?

  1. #41
    Join Date
    Aug 2005
    Location
    Northern Michigan USA
    Beans
    1,779
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Howto recover the big pointer in unity?

    Well I guess it isn't as fixed as I thought. On the 10 laptops I run at the library (all identical HP g72t) it worked on 7 . On 3 it worked for the guest user but not the admin librarian account. I did the commands in the librarian account as the guest account is a limited user. Any ideas on this?

  2. #42
    Join Date
    Aug 2005
    Location
    Northern Michigan USA
    Beans
    1,779
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Howto recover the big pointer in unity?

    Apparently I spoke too soon. On 10 identical HP laptops at the library, all HP g72t it worked on 7. On 3 it changed to big and black on the limited user but not the admin account. On one it is big but white. And they are set correctly in dconf editor.I hope someone can help on this.
    Last edited by cmcanulty; March 29th, 2013 at 05:05 PM.

  3. #43
    Join Date
    Aug 2012
    Beans
    3

    Re: Howto recover the big pointer in unity?

    @stiinkeye, thanks for the instructions and creating the DMZ-Black-Large package.

    This fixed the situation for me on 12.10 - trying to use Ubuntu on a TV without squinting for the cursor.

    Everything else I tried only made the cursor large some of the time.

  4. #44
    Join Date
    Jul 2007
    Location
    Nashville TN
    Beans
    130
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Howto recover the big pointer in unity?

    I just now discovered that one of the recent Ubuntu updates (30 June 2013) -- probably to X.org -- appears to have fixed the cursor bug in which the large cursor took effect only within certain application windows. I don't know how the large cursor is set in dconf-editor, but in Unity Tweak (you have to install this optional tool) there is a Cursor module where you can select "Use large cursor." And this setting now works! --at least in this login session. My fingers are crossed. Will report back here if the large cursor is not persistent.

    Follow-up: I cold booted, and the large cursor did not appear on the desktop or in the Files (Nautilus) window. However, the large cursor appeared when I started Chromium (which I believe is GTK-based.) But it now persists in the desktop and Nautilus (which I believe are non-GTK applications.)

    I think this is just one of the reasons that Canonical is working to replace X Windows with the new Mir display system, to avoid all the regression errors caused by all the obsolete code in X.
    Last edited by rtimai; June 30th, 2013 at 09:34 PM. Reason: added info & comment

  5. #45
    Join Date
    Oct 2008
    Beans
    3,509

    Re: Howto recover the big pointer in unity?

    Quote Originally Posted by rtimai View Post
    I just now discovered that one of the recent Ubuntu updates (30 June 2013) -- probably to X.org -- appears to have fixed the cursor bug in which the large cursor took effect only within certain application windows. I don't know how the large cursor is set in dconf-editor, but in Unity Tweak (you have to install this optional tool) there is a Cursor module where you can select "Use large cursor." And this setting now works! --at least in this login session. My fingers are crossed. Will report back here if the large cursor is not persistent.

    Follow-up: I cold booted, and the large cursor did not appear on the desktop or in the Files (Nautilus) window. However, the large cursor appeared when I started Chromium (which I believe is GTK-based.) But it now persists in the desktop and Nautilus (which I believe are non-GTK applications.)

    I think this is just one of the reasons that Canonical is working to replace X Windows with the new Mir display system, to avoid all the regression errors caused by all the obsolete code in X.
    What Ubuntu release are you using?

    Using unity-tweak-tool to "use large cursors" doesn't work for me in 13.04.
    Still changes size and theme inconsistently.
    Last edited by stinkeye; July 1st, 2013 at 12:09 AM.

  6. #46
    Join Date
    Jul 2007
    Location
    Nashville TN
    Beans
    130
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Howto recover the big pointer in unity?

    stinkeye, I'm running Ubuntu 13.04 Unity.

    Do you, by any chance, have "Icons on desktop" in Unity Tweak turned OFF? I seem to recall this setting (a.k.a. "allow Nautilus to control the desktop") had to be ON to avoid several other annoying symptoms. If you already have it turn ON, then I'm afraid I don't know what's going on here. I can't find any setting in dconf-editor that seems to refer to the desktop cursor either. A lot has been sealed in a black box since Unity (maybe for our own safety.) Good luck with your cursor.

  7. #47
    Join Date
    Jul 2007
    Location
    Nashville TN
    Beans
    130
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Howto recover the big pointer in unity?

    I am running Ubuntu 13.04 Unity.

    I don't know if this directly affects the cursor, but do you have "Icons on desktop" turned ON? This setting (a.k.a. "allow Nautilus to control the desktop") has an effect on several other annoying symptoms. If you already have it turned ON, I'm afraid I don't have anything else to suggest. If you're already using the workaround described earlier, then -- maybe -- the change in default folder structure may be affecting this fix. Good luck on your big cursor effort.

  8. #48
    Join Date
    Oct 2008
    Beans
    3,509

    Re: Howto recover the big pointer in unity?

    Nautilus is managing the desktop.
    Code:
    glen@Raring:~$ gsettings get org.gnome.desktop.background show-desktop-icons
    true
    So using unity-tweak-tool, if you set the cursor theme to dmz-white by hitting the "restore defaults" button
    and then select "use large cursors", is the size consistent? Isn't here.

    The "use large cursors" appears to just change this dconf setting (default is 24)....
    Code:
    glen@Raring:~$ gsettings get org.gnome.desktop.interface cursor-size
    48
    In 12.04 & 13.04 the only way for me to get a consistently large cursor is to use a cursor theme that only has one large size.
    eg
    HERE, where I removed the 24 and 32 pixel layers from the DMZ-Black theme so it has to use 48.
    Last edited by stinkeye; July 1st, 2013 at 05:30 AM.

  9. #49
    Join Date
    Jul 2007
    Location
    Nashville TN
    Beans
    130
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Howto recover the big pointer in unity?

    Thanks stinkeye, you're right, the cursor-size setting is in dconf, not in gconf. Also, yes, I used Unity Tweak as you described above to set the large cursor. I don't know why these settings are not affecting your desktop cursor size. (I'm not celebrating yet. It remains to be seen whether this behavior persists over the next few days.)

  10. #50
    Join Date
    Jul 2007
    Location
    Nashville TN
    Beans
    130
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Howto recover the big pointer in unity?

    glen (stinkeye),
    You reported:

    glen@Raring:~$ gsettings get org.gnome.desktop.interface cursor-size
    48

    If this is a gconf setting, this key no longer exists in my gconf configuration -- it doesn't appear in gconf-editor. An Interface key does appear in dconf-editor -- but oddly enough it is NOT changed to 48 but remains the default 24 (with "Use large cursor" selected in Unity Tweak.)

    My double-size cursor remains persistent between cold boots. Notably, however, the cursor size starts out small (24) when initially logging in, and the large cursor appears to be activated only after starting the Chromium browser or Gnome-Search. I think the GTK-based rendering of these applications are what triggers the large cursor. In previous versions of Ubuntu, however, the large cursor reverted back to the small size when leaving the GTK-based application. This time however, however awkwardly activated, the large cursor remains persistent. I don't know which Ubuntu Unity update fixed the cursor-size setting, or if it was even intentional. But I seem to recall a recent update to X.org, the underlying display system, and I suspect this is what caused the new behavior. I suspect that a regression error in the future could easily cause the bug to resurface.

Page 5 of 8 FirstFirst ... 34567 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •