Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Eee Slate EP121 - Reporting Bugs

  1. #11
    Join Date
    Aug 2007
    Beans
    4

    Re: Eee Slate EP121 - Reporting Bugs

    I've had the Asus EP121 since it first came out and put Ubuntu on it almost the day I got it. It has gotten a TON better, but it's still frustrating at times. I'll admit that I'm 'tech savvy' but I'm definitely not able to do any type of deep 'detective' work and change things to make it act how I want... Having said that, I'm more than capable of searching the forums and trying 'simple' fixes.

    Touching the screen with my finger seems to work intermittenly, but almost always results in a 'stuck click' behaviour even with the newest eGalax drivers.

    Cannot 'double click' using finger touch.

    Multitouch doesn't work for me.

    Onboard behaviour is also a little annoying at times. When typing in the firefox address or search bar if a suggestion pops down, the keyboard disappears. When placing the cursor in a text entry box on the facebook website the keyboard does not appear.

    These are minor gripes, to be sure considering the Wacom drawing capabilities I gain, but every day use issues that keep this from being my 'daily driver.'

    I just can't wait until we can use the EP121 with the Ubuntu for Tablets interface!

    Amy

  2. #12
    Join Date
    Apr 2013
    Beans
    1

    Lightbulb Re: Eee Slate EP121 - Reporting Bugs

    I was playing with the Slate B121 which is supposed to have the same hardware more or less and installing Ubuntu 13.04 tonight. Like many others have reported with the device, everything worked fine except the touchscreen. The issue I was having with it was that it was not registering the end of my click just as the above post described. I scoured the web for any info in regards to the issue and found things ranging from xorg to drivers. Every where I looked though led me to 1 common task which was to manually install the eGalax Touch drivers. So that is what I did, I installed "eGTouch_v2.5.2107.L-x" and during install I selected USB. From here I rebooted and encountered the same problems.


    Here is where my venture started to yield some new information. Many attempted fixes suggested modifying a file in /etc/X11/xorg/xorg.conf.d/ however I did not have that file and I started investigating. After several hours of reading through a bunch of information, I decided to investigate if any other distros got it working to see if this was the appropriate path. I stumbled across a post discussing getting it to work properly in Crunchbang by modifying a similar xorg conf file located under /usr/share/X11. So I peeked at that location, found the configurations files that were similar to what the "fixes" discussed. The exact file I keyed in on was /usr/share/X11/xorg.conf.d/52-egalax-virtual.conf. Now what was interesting about the Crunchbang article was he provided a much more detailed .conf file, so I copied it into the above .conf file and rebooted. Low and behold all working.

    *ADDED* I ran into the issue again after a period of time. I turned on sound card beep for touch states and it sounded on both. I switched mouse mode from normal to click on touch and that brought touchscreen functionality back. From there I started reading the manual and saw an option I have not seen others mention which is meant specifically for HID on the EEEPC Line. So I turned it on, rebooted and got more calibration options and better function from the touchscreen. So far with further testing it seems to work well. As the issue did come back originally after some use, I am not certain this truly resolved the issues, but will update if it does or does not comeback.

    *ADDED* I shut the tablet down last night and powered it back on this morning to test and lost functionality again. I reran the eGTouchU and notice I lost the calibration options again. I'll have to investigate why I lost the calibration options. I suspect that may be related to the issue. As a side note, switching to click on touch or release still seems to work fine.


    So here is a Recap of steps that seem to get it working:

    1. Download the eGalax driver (eGTouch_v2.5.2107.L-x) on their webpage
    2. Extract to folder under home
    3. Open terminal to folder from above step, mine was /home/"username"/eGalax
    4. Run sudo sh setup.sh
    5. Choose USB option as interface
    6. Choose 1 controller
    7. Reboot
    8. Open terminal
    9. sudo nano /usr/share/X11/xorg.conf.d/52-egalax-virtual.conf
    10. Paste the following into the file
    11. Reboot
    12. *ADDED* Run eGTouchU found in /usr/bin/
    13. *ADDED* Tool tab has 4pts Cal, Linearization, Clear Parameter, and Draw Test. Only line test was available till i remodifed the .conf file below to include Option "HidOnEPC" "1"

    Code:
    #Section "InputClass"
    #   Identifier "eGalax touch class"
    #   MatchProduct "eGalax Inc.|Touchkit|eGalax_eMPIA Technology Inc."
    #   MatchDevicePath "/dev/input/event*"
    #   Driver "egalax"
    #   Option "Device" "usbauto"
    #   Option "Parameters" "/var/lib/eeti.param"
    #   Option "ScreenNo" "0"
    #   Option "SkipClick" "0"
    #EndSection
    
    
    Section "InputClass"
        Identifier "eGalax touch class"
        MatchProduct "eGalax Inc.|Touchkit|eGalax_eMPIA Technology Inc."
        MatchDevicePath "/dev/input/event*"
        Driver "evtouch"
        Option "MinX" "0"
        Option "MinY" "0"
        Option "MaxX" "32768"
        Option "MaxY" "32768"
        Option "ReportingMode" "Raw"
        Option "Emulate3Buttons"
        Option "Emulate3Timeout" "50"
        Option "SendCoreEvents" "On"
        #Option "TapTimer" "0"
        Option "LongTouchTimer" "350"
        Option "ReportingMode" "Raw"
        # Option "Emulate3Buttons"
        # Option "Emulate3Timeout" "50"
        Option "SendCoreEvents" "On"
        # Option "maybetapped_action" "click"
        # Option "maybetapped_button" "3"
        Option "longtouched_action" "down"
        Option "longtouched_button" "1"
        Option "oneandahalftap_action" "click"
        Option "oneandahalftap_button" "3"
        # Option "ButtonNumber" "4"
        # Option "Calibrate" "1"
        #original parameters to use with the "void" driver
        #Option "Device" "usbauto"
        #Option "Parameters" "/var/lib/eeti.param"
        #Option "ScreenNo" "0"
        #Option "SkipClick" "0"
        Option "HidOnEPC" "1"
    EndSection
    
    
    #Section "InputClass"
    #   Identifier "eGalax mouse class"
    #   MatchProduct "eGalax Inc.|Touchkit|eGalax_eMPIA Technology Inc.|eGalaxTouch Virtual Device"
    #   MatchDevicePath "/dev/input/mouse*"
    #   Driver "void"
    #EndSection
    
    
    #Section "InputClass"
    #   Identifier "eGalax joystick class"
    #   MatchProduct "eGalax Inc.|Touchkit|eGalaxTouch Virtual Device"
    #   MatchDevicePath "/dev/input/js*"
    #   Driver "void" 
    #EndSection

    Sources:

    Last edited by JRHigg; April 28th, 2013 at 06:26 PM. Reason: Further details added regarding the reappearance and possible resolution of the problem.

  3. #13
    Join Date
    Sep 2005
    Beans
    93

    Re: Eee Slate EP121 - Reporting Bugs

    Happy news today, finally found a solution to the touchsreen problem. The evdev input driver is the bad guy! So I just replaced evdev driver with the wacom driver and tataaa it works.

    gksudo gedit /usr/share/X11/xorg.conf.d/10-evdev.conf

    and make the following ajustment

    Section "InputClass"
    Identifier "evdev touchscreen catchall"
    MatchIsTouchscreen "on"
    MatchDevicePath "/dev/input/event*"
    Driver "wacom"
    EndSection

    Thats it

  4. #14
    Join Date
    Sep 2005
    Beans
    93

    Re: Eee Slate EP121 - Reporting Bugs

    Happy news today, finally found a solution to the touchsreen problem. The evdev input driver is the bad guy! So I just replaced evdev driver with the wacom driver and tataaa it works.

    Code:
    gksudo gedit /usr/share/X11/xorg.conf.d/10-evdev.conf
    and make the following ajustment

    Code:
    Section "InputClass"
            Identifier "evdev touchscreen catchall"
            MatchIsTouchscreen "on"
            MatchDevicePath "/dev/input/event*"
            Driver "wacom"
    EndSection
    Thats it

  5. #15
    Join Date
    May 2009
    Beans
    1

    Re: Eee Slate EP121 - Reporting Bugs

    Have they released a tablet based install for ubuntu yet I keep hearing about it and see the docmentation on it but dont see a specific download unless its coupled with the standard desktop version or am I missing something here!

    I dont mind setting up the DBoot option on my ep121 but would like an update on peoples experience. It seems like there are only a few of us out here with ep121's and even fewer trying to run Linux or even know what linux is. I wanna run a full linuxOs on this unit but need it tablet focused with wacom functionality.

    @DEADLAND, Noticed you mentioned you resolved the touchscreen/wacom issue! and you give some more details and experience update

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •