Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Problem with mounting.

  1. #11
    Join Date
    Apr 2006
    Location
    Montana
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: Problem with mounting.

    Quote Originally Posted by potatoos View Post
    I did what you suggested bodhi.zazen, but it still won't mount the second drive. I get this error now.

    Code:
    Error mounting: mount exited with exit code 1: helper failed with:
    Unprivileged user can not mount NTFS block devices using the external FUSE
    library. Either mount the volume as root, or rebuild NTFS-3G with integrated
    FUSE support and make it setuid root. Please see more information at
    http://tuxera.com/community/ntfs-3g-faq/#unprivileged
    And this error when trying to mount it from gksudo nautilus (the drive is currently fat32 but was previously ntfs)

    Code:
    NTFS signature is missing.
    Failed to mount '/dev/sdc1': Invalid argument
    The device '/dev/sdc1' doesn't seem to have a valid NTFS.
    Maybe the wrong device is used? Or the whole disk instead of a
    partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
    Is there no way that I could just start all the mounts over? There seems to be a lot of compatibility issues going on, and it probably has something to do with me reformatting one of the drives to several different formats (ntfs, ext4, fat32) trying to get it recognized.
    Well, if you reformatted your partition from ntfs to fat, you have to update fstab

    Code:
    /dev/sdc1 /media/sdc1 ntfs-3g auto,users,locale=en_US.UTF-8 0 0
    See:

    https://help.ubuntu.com/community/Fstab
    https://wiki.ubuntu.com/MountWindowsSharesPermanently
    https://help.ubuntu.com/community/Au...ountPartitions
    There are two mistakes one can make along the road to truth...not going all the way, and not starting.
    --Prince Gautama Siddharta

    #ubuntuforums web interface

  2. #12
    Join Date
    Apr 2006
    Location
    Montana
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: Problem with mounting.

    Quote Originally Posted by NikTh View Post
    Hi ,
    you probably have right. Multiple reformats created the problem . Fat32 ? hmmm... ancient filesytem especially for a HDD. Think about to reformat the drive to NTFS , is little better.

    Try to add below command to rc.local and see how it will be going.

    Code:
    gksudo gedit /etc/rc.local
    before exit 0 add this line
    Code:
    mount -a
    save the document and reboot your system.
    If something goes wrong , you can boot from recovery mode and click root and the give below commands to change the file
    Code:
    mount -o rw,remount /
    nano /etc/rc.local
    and delete the line mount -a
    Thanks
    That is not necessary if you use a proper entry in fstab and will fail with the same error unless you fix fstab.
    There are two mistakes one can make along the road to truth...not going all the way, and not starting.
    --Prince Gautama Siddharta

    #ubuntuforums web interface

  3. #13
    Join Date
    Feb 2012
    Location
    el_GR
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Problem with mounting.

    Quote Originally Posted by bodhi.zazen View Post
    That is not necessary if you use a proper entry in fstab and will fail with the same error unless you fix fstab.
    Hi ,
    thanks for the info.
    I thought this command (in rc.local) would mount all the devices automatically in boot, cuz rc.local executed as root.
    # How to mark the Thread as [SOLVED] when done.
    # Ubuntu Greek Community
    # Gain 20GB of space on copy.com when sign up with my referral link.

  4. #14
    Join Date
    Apr 2006
    Location
    Montana
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: Problem with mounting.

    Quote Originally Posted by NikTh View Post
    Hi ,
    thanks for the info.
    I thought this command (in rc.local) would mount all the devices automatically in boot, cuz rc.local executed as root.
    It would do that, but they are mounted automatically already.

    The problem is, fstab is saying "ntfs-3g" when it should say "auto" or "vfat".

    fix fstab, fix the problem (although your solution shows you are thinking, and that is a good thing).
    There are two mistakes one can make along the road to truth...not going all the way, and not starting.
    --Prince Gautama Siddharta

    #ubuntuforums web interface

  5. #15
    Join Date
    Feb 2012
    Location
    el_GR
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Problem with mounting.

    Hi , bodhi.zazen
    Quote Originally Posted by bodhi.zazen View Post
    It would do that, but they are mounted automatically already.

    The problem is, fstab is saying "ntfs-3g" when it should say "auto" or "vfat".
    I used this message

    Quote Originally Posted by potatoos View Post
    Code:
    Error mounting: mount exited with exit code 1: helper failed with:
    mount: only root can mount /dev/sdc1 on /media/sdc1
    but it seems I missed this
    Quote Originally Posted by potatoos View Post
    Code:
    NTFS signature is missing.
    Failed to mount '/dev/sdc1': Invalid argument
    The device '/dev/sdc1' doesn't seem to have a valid NTFS.
    Maybe the wrong device is used? Or the whole disk instead of a
    partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

    Quote Originally Posted by bodhi.zazen View Post
    (although your solution shows you are thinking, and that is a good thing).
    Thanks Guru !
    # How to mark the Thread as [SOLVED] when done.
    # Ubuntu Greek Community
    # Gain 20GB of space on copy.com when sign up with my referral link.

  6. #16
    Join Date
    Aug 2012
    Beans
    13

    Re: Problem with mounting.

    I changed "ntfs-3g" to "auto" and then to "vfat" and I still can't mount the drive.

    I get this error:
    Code:
    Error mounting: mount exited with exit code 1: helper failed with:
    mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
           missing codepage or helper program, or other error
           In some cases useful info is found in syslog - try
           dmesg | tail  or so

  7. #17
    Join Date
    Apr 2006
    Location
    Montana
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: Problem with mounting.

    Quote Originally Posted by potatoos View Post
    I changed "ntfs-3g" to "auto" and then to "vfat" and I still can't mount the drive.

    I get this error:
    Code:
    Error mounting: mount exited with exit code 1: helper failed with:
    mount: wrong fs type, bad option, bad superblock on /dev/sdc1,
           missing codepage or helper program, or other error
           In some cases useful info is found in syslog - try
           dmesg | tail  or so
    Is there something wrong with the hard drive ? It sounds as if you have formatted the partition a few times.

    If the hard drive is "OK", format it again and use the auto option

    Code:
    /dev/sdc1 /media/sdc1 auto defaults 0 0
    You can add options as needed, depending on the file system, from the links I gave you on fstab.
    There are two mistakes one can make along the road to truth...not going all the way, and not starting.
    --Prince Gautama Siddharta

    #ubuntuforums web interface

  8. #18
    Join Date
    Aug 2012
    Beans
    13

    Re: Problem with mounting.

    Thanks, everyone!
    I changed the line in fstab like you suggested, bodhi.zazen, then reformatted the drive, and it mounted properly.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •