Results 1 to 5 of 5

Thread: Cannot set b43 in master mode

  1. #1
    Join Date
    Dec 2007
    Beans
    11
    Distro
    Ubuntu Karmic Koala (testing)

    Cannot set b43 in master mode

    I have a laptop (HP EliteBook 2540p) that contains a Broadcom B4312 (14e4:4315) LP-PHY WiFi chip. I want to set the chip in master mode (ultimate goal: an Ethernet to Wireless bridge).

    I have blacklisted the Broadcom STA proprietary driver (wl.ko) and installed the firmware blobs for the open-source b43 driver (firmware-b43-lpphy-installer).

    The b43 driver is supposed to support master mode:
    http://www.linuxwireless.org/en/users/Drivers/b43

    But when I try to enable it (sudo iwconfig wlan0 mode master) I get:
    Error for wireless request "Set Mode" (8B06): SET failed for device wlan0; Invalid argument.

    The other modes work fine (even monitor mode, for example).

    Does anyone know why this doesn't work? Is this an LP-PHY issue?

    Thanks!

  2. #2
    Join Date
    Aug 2012
    Beans
    22

    Re: Cannot set b43 in master mode

    I have had the same issue on my Dell Vostro 1310. However, the below links helped me. Give it a shot and see how it goes.

    http://askubuntu.com/questions/14142...h-ubuntu-12-04

    http://ubuntuforums.org/showthread.php?t=1867844

  3. #3
    Join Date
    Dec 2007
    Beans
    11
    Distro
    Ubuntu Karmic Koala (testing)

    Re: Cannot set b43 in master mode

    Quote Originally Posted by brodedra View Post
    I have had the same issue on my Dell Vostro 1310. However, the below links helped me. Give it a shot and see how it goes.

    http://askubuntu.com/questions/14142...h-ubuntu-12-04

    http://ubuntuforums.org/showthread.php?t=1867844
    Thank you. However, these two are not what I need. Just to clarify: my WiFi works fine, I can connect to access points and all. The issue is with turning the laptop into an access point, i.e. enabling master mode.

  4. #4
    Join Date
    Jan 2008
    Beans
    65
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Cannot set b43 in master mode


  5. #5
    Join Date
    Dec 2007
    Beans
    11
    Distro
    Ubuntu Karmic Koala (testing)

    Re: Cannot set b43 in master mode

    Quote Originally Posted by unevenflow View Post
    Thanks, it's great to know that it can be done from a GUI. However, in my case I seem to be able to turn on the hotspot (infrastructure mode), but in fact my phone cannot see it.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •