Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: No wireless after updating packages in 12.04

  1. #1
    Join Date
    Aug 2012
    Beans
    7

    No wireless after updating packages in 12.04

    I use Ubuntu 12.04. Yesterday system asked me about installing updates. I clicked install update. After that, I don't have option to connect any connection cause i don't have an option wireless network, only network or mobile network. This is the output of lspci:




    Code:
    martyna@Martyna:~$ lspci 00:00.0 Host bridge: Advanced Micro Devices [AMD] RS880 Host Bridge 00:01.0 PCI bridge: Advanced Micro Devices [AMD] RS780/RS880 PCI to PCI bridge (int gfx) 00:04.0 PCI bridge: Advanced Micro Devices [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 0) 00:06.0 PCI bridge: Advanced Micro Devices [AMD] RS780 PCI to PCI bridge (PCIE port 2) 00:0a.0 PCI bridge: Advanced Micro Devices [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 5) 00:11.0 SATA controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode] 00:12.0 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller 00:12.2 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller 00:13.0 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller 00:13.2 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller 00:14.0 SMBus: Advanced Micro Devices [AMD] nee ATI SBx00 SMBus Controller (rev 41) 00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) (rev 40) 00:14.3 ISA bridge: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 LPC host controller (rev 40) 00:14.4 PCI bridge: Advanced Micro Devices [AMD] nee ATI SBx00 PCI to PCI Bridge (rev 40) 00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor HyperTransport Configuration 00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Address Map 00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor DRAM Controller 00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Miscellaneous Control 00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 10h Processor Link Control 01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS880M [Mobility Radeon HD 4200 Series] 01:05.1 Audio device: Advanced Micro Devices [AMD] nee ATI RS880 HDMI Audio [Radeon HD 4200 Series] 02:00.0 Network controller: Ralink corp. RT3090 Wireless 802.11n 1T/1R PCIe 03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)

    Please do help, thanks in advance

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,420
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: No wireless after updating packages in 12.04

    Please try this:
    Code:
    sudo modprobe rt2800pci
    Does your wireless spring to life? If so, it's a simple fix. If not, let's see if there are any clues here:
    Code:
    rfkill list all
    dmesg | grep rt2
    Chili's Folly: Intel NUC, i3-4010U, 120 GB SSD, 16 GB RAM, external 500 GB HDD, Ubuntu Saucy; small, silent and fast.

  3. #3
    Join Date
    Aug 2012
    Beans
    7

    Re: No wireless after updating packages in 12.04

    wow, it works!

    Code:
    martyna@Martyna:~$ sudo modprobe rt2800pci
    [sudo] password for martyna: 
    martyna@Martyna:~$ rfkill list all
    0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    martyna@Martyna:~$ dmesg | grep rt2
    [ 2626.388547] rt2800pci 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
    [ 2626.388583] rt2800pci 0000:02:00.0: setting latency timer to 64
    [ 2626.619988] Registered led device: rt2800pci-phy0::radio
    [ 2626.620094] Registered led device: rt2800pci-phy0::assoc
    [ 2626.620152] Registered led device: rt2800pci-phy0::quality
    [ 2626.815671] phy0 -> rt2800pci_mcu_status: Error - MCU request failed, no response from hardware
    martyna@Martyna:~$
    Is there anything else I should do?
    thank u a lot!

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,420
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: No wireless after updating packages in 12.04

    Let's get rt2800pci to load automagically every time:
    Code:
    sudo su
    echo rt2800pci >> /etc/modules
    exit
    rt2800pci_mcu_status: Error - MCU request failed, no response from hardware
    I'm not sure I like that but let's see how it goes. Post back if your wireless isn't working properly.

    Please use thread tools at the top to mark Solved.
    Chili's Folly: Intel NUC, i3-4010U, 120 GB SSD, 16 GB RAM, external 500 GB HDD, Ubuntu Saucy; small, silent and fast.

  5. #5
    Join Date
    Aug 2012
    Beans
    7

    Re: No wireless after updating packages in 12.04

    hey, I have the same situation. after updating i have no internet access. command below didn't work. can i please for the help? thank you so much.

    Code:
    sudo modprobe rt2800pci

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,420
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: No wireless after updating packages in 12.04

    Quote Originally Posted by Rosz777 View Post
    hey, I have the same situation. after updating i have no internet access. command below didn't work. can i please for the help? thank you so much.

    Code:
    sudo modprobe rt2800pci
    Please let us see the usual suspects:
    Code:
    lspci -nn | grep 0280
    rfkill list all
    lsb_release -d
    Thanks.
    Chili's Folly: Intel NUC, i3-4010U, 120 GB SSD, 16 GB RAM, external 500 GB HDD, Ubuntu Saucy; small, silent and fast.

  7. #7
    Join Date
    Aug 2012
    Beans
    7

    Re: No wireless after updating packages in 12.04

    hi, thank for your reply.

    Code:
    martyna@Martyna:~$ lspci -nn | grep 0280
    02:00.0 Network controller [0280]: Ralink corp. RT3090 Wireless 802.11n 1T/1R PCIe [1814:3090]
    martyna@Martyna:~$ rfkill list all
    0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    martyna@Martyna:~$ lsb_release -d
    Description:    Ubuntu 12.04.1 LTS
    martyna@Martyna:~$

  8. #8
    Join Date
    Aug 2012
    Beans
    7

    Re: No wireless after updating packages in 12.04

    i must add, that this situations i'snt the same with the previous problem, cause now i have option to switch on and off my wireless card but i can't connect with any network because ubuntu constantly ask me about password. 2 months ago i had the same situation and i added
    Code:
    blacklist rt2800pci
    blacklist rt2800usb
    blacklist rt2x00lib
    blacklist rt2x00pci
    blacklist rt2x00usb
    to etc/modprobe.d/blacklist-rt2x00.conf
    but i checked this and i have this folder now but wireless still doesn't work

    thanks for ur help

  9. #9
    Join Date
    Oct 2012
    Beans
    2

    Re: No wireless after updating packages in 12.04

    Hi all, I've got the same problem. I updated my lenovo T420S to 12.04 LTS and I'm not given any wireless connection option.

    I've tried the command lines above but I don't make progress. Anyone can help?

    Thanks in advance!

    Frederic

  10. #10
    Join Date
    Oct 2012
    Beans
    2

    Re: No wireless after updating packages in 12.04

    Just to add to the above, this is how far I get in the Terminal:

    frederic@erasmus:~$ sudo modprobe rt2800pci
    [sudo] password for martyna:
    frederic@erasmus:~$ rfkill list all
    0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    frederic@erasmus:~$ dmesg | grep rt2

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •